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1.1 About Retain

Retain Planner is a flexible planning tool for managing staff schedules through a user friendly graphical
interface. It has been designed to resemble the manual 'wallchart' booking system but is much more versatile
than any manual booking system.

Retain Planner provides a wide range of functionality relating to resource planning: 

Wallchart view

 Allocate resources to jobs using user-friendly graphical interface
 Modify bookings using drag & drop functionality
 Roll bookings forward, duplicate, copy and paste
 Rotate views to switch between viewing by resources or viewing by jobs
 Apply colours to highlight important data
 Visual indication of over-allocations and tentative bookings

Report view

 Report on resources' Utilisation, Availability and other relevant information
 Compare planned versus budgeted time and revenue 
 Use formatting options to highlight the important data in report
 Export report data to Microsoft Excel and other applications
 Multiple selection and sorting options allows you to filter out the necessary data

Extended Functionality

 Corporate and Enterprise editions provide advanced functionality and are highly configurable
 Retain Web (available in several editions) allows you to make bookings and create reports

online
 Microsoft Outlook and Lotus Notes calendar integration
 Retain Skills Module allows you to capture and manage resources' skills
 Booking Request module allows you to view and request bookings
 Enterprise Reports provides powerful reporting functionality for more complex reports
 Retain Time module allows you to manage the actual time spent on jobs

Flexible configuration & security (not available in the demo version)

 Easy to use administration tool that allows you to manage user access and configure the
software:

- Control who has access to view/modify certain information
- Define the fields you store against resources, jobs and other database entities
- Create charge rates for resources and jobs
- Password protect your editing rights with the Edit Mode lock 

For more information contact Retain International.

top ^
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1.2 System requirements

Supported Operating System platforms:

 Windows 7

 Windows Vista

 Windows XP Professional

 Windows Server 2003, 2008

Minimum system requirements:

 Processor running at 500 MHz or better

 At least 512 MB of RAM

 100 MB free hard disk space

 XGA (1,024 x 768) or higher resolution monitor 

 Mouse or other Windows pointing device 

top ^

1.3 Installing Retain Planner

To install Retain Planner:

1. Confirm that your machine meets the minimum system requirements.

2. Copy RetainPlanner5-1DemoSetup.exe to a temporary location on your machine.

3. Run RetainPlanner5-1DemoSetup.exe and follow the on-screen instructions to complete the setup.

Note: Do not replace an existing version of Retain using this demo installation. Please contact us if you
would like to upgrade your existing version.

After the installation, you will see shortcuts created in the Windows 'Start' menu for 'Retain Planner 5'. 

4. Run Retain Planner by ticking the 'Run Retain Planner 5 now' checkbox and pressing 'Finish'. 

Alternatively, start Retain Planner manually by going to Start-> Programs-> Retain Planner 5-> Retain
Planner. See the Getting Started section for more information.

Note: Retain Server will be started automatically. Be aware that the initial startup may take a few seconds. If
Windows firewall prompts you to set the blocking status, click on 'Unblock'. 

Retain Planner is the main client application for scheduling resources against jobs. 

Retain Server is a server application that interacts between Retain Planner and the database file ('Retain.fdb'
). This database file stores all the data used by Retain such as resources, jobs and bookings. It is the most
important file in the Retain setup and should be backed up regularly.

top ^
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2 Getting Started

Once you have installed Retain Planner, follow the steps below to edit data and make bookings:

1. Start Retain Planner by going to Start-> Programs-> Retain Planner 5-> Retain Planner.

2. The Wallchart view (the default view) will open.

It has resources/jobs listed on the left-hand side with the date range at the top and bottom of the screen.
Bookings are displayed in the middle of the screen. You can scroll around the date range using the date bar
(click and drag the rectangular box forwards and backwards) at the bottom of the window.

3. When you first enter Retain you will always be in the 'read-only mode'. While in read-only mode you
can move around your Retain notebook and produce reports but you cannot amend any data. To edit
the data you must to be in 'edit mode': select 'Edit-> Edit mode...' from the menu.

Note: The default password is 'abc' (case sensitive).

4. Add a resource by selecting 'Actions-> Modify records-> Resource' from the menu. Enter a
unique name for the new resource and fill in other details, as required. The resource will appear
in the list on the left-hand side of the screen.

5. To switch from to Job view, right-click anywhere within the wallchart and select 'Job View'
from the menu. 

6. Add a job by selecting 'Actions-> Modify Record-> Job...' from the menu. Enter a unique
name for the new job and fill in other details, as required. The job will appear in the list on the
left-hand side of the screen.

7. Switch back to Resource view by right-clicking anywhere within the wallchart and selecting
'Resource View' from the menu.

8. To make a booking, mark an area within the wallchart that encapsulates the necessary date
range, right-click and select 'Make booking...' from the menu. Specify at least one resource and
one job (other fields are optional) and click on 'Save'. The booking will appear against the
selected resource in the wallchart.

Notes: 

- To edit booking details, right-click on the booking and select 'Edit Booking...' from the menu.
- Hover your mouse cursor over the booking and a pop-up will appear displaying the booking
details.
- You can also make bookings in Project and Calendar views. Go to 'Help-> Help Topics' for more
information.

Related Topics

Wallchart view
Report view
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2.1 Wallchart View

Once you have created or opened a new notebook, it will be displayed on the main screen:

The view is divided into the following areas:

1. The menu bar - Located at the top of the screen, this menu provides access to all of Retain's
functions.

2. The toolbar - This is usually located immediately below the menu bar and contains several
buttons. These buttons provide a quick access to many of the commonly used features in
Retain. 

3. The notebook page navigation list - This drop-down list allows you to select the notebook page to
be displayed within the wallchart. You can only select from the pages within the currently open
notebook. You may think of a notebook as a spreadsheet and notebook pages as worksheets
within that spreadsheet. Links to the four most recently opened pages are displayed to the right of
the drop-down.

4. The notebook area - The main part of the screen, this area displays the list of resources/jobs on
the left-hand side and the bookings on the right-hand side.

5. The status bar - Located at the bottom of the screen, this area displays the name of the currently
selected resource and the date range covered by the selected booking. It changes according to
the displayed context. The status bar will also show hints for a menu item that you are pointing to.

6. The dockable pane - Located on the right-hand side of the screen, the dockable pane is used to
'dock' the dialogs you are working with, enabling you to navigate around the Wallchart or see the
changes being made without closing the dialogs.

top ^
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2.2 Report View

Retain Planner has an in-built versatile and powerful report writer which allows you to create various reports.

You can use the Retain report writer to produce both job-based (such as job revenue) and resource-based
(such as resource allocations and utilisation) reports. The reports can also be customised using formatting,
sorting and selection options:

To create a new report you need to add a new notebook page with a 'Report' page type:

1. Select 'Notebook-> Add page...' from the menu. 

Tip: Use the 'Copy page' function if you want to create a report based on an existing report.

2. Choose the 'Report' page type by selecting the appropriate radio button.

3. Type in a descriptive name for the new report.

4. Select the 'OK' button to add the report page to your notebook.

5. Define the report fields and other settings for the new report as required (see the image below). 

Note: you can create a simple report with one or two fields and a date range only.

6. Click on the the 'OK' button button to confirm your changes. A new notebook page will be
created for your report.

When creating new reports you will be prompted to define the parameters using the 'Setup Report' dialog:
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Use this dialog to define the following information:

 Fields - the fields that the report will be based on. You can add resource, job or booking related fields.

 Sort - the order in which the report data will be sorted, including field grouping and sub-totals.

 Selection - the selection criteria that will be applied to report data.

 Date - the date range of the report.

top ^
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3 Backup and Restore

3.1 Backup Database

Please backup your data on a regular basis.

The Backup Database utility will backup your Retain database ('Retain.fdb'). It will save a backup of the
Retain database file to a destination you specify.

To backup Retain database:

1. Ensure that all users have saved their work and exited Retain Planner.

2. Stop Retain Server.  Select File-> Exit or click on the 'X' button in the Retain Server window. 

Note: The backup will fail if Retain Server is not stopped. 

3. Start the Backup Database from Start-> Programs-> Retain Planner 5-> Utilities-> Backup
Database. It can also be found in the 'Server' folder, it is a file called 'RetainBackup.exe'. Backup
Database will backup your Retain database ('Retain.fdb') which is located in the C:\Program
Files\RetainPlannerV5\Server\Data folder. Retain database stores resources, jobs, components and
bookings. 

Note: Backup Database will not backup your Retain notebooks (files with '.RetainNotebook' extension).

4. If not already selected, go to the 'Backup' tab in the 'Retain Backup' dialog:

- 'File to Backup:' is the location of your Retain database. You should accept the default location
which will normally be C:\Program Files\Retain Planner 5\Server\Data\'Retain.fdb'.

- 'Backup File:' is the location where your backup will be saved. Click on the 'Browse' button to
navigate to your destination folder and enter a file name. Note: Please make sure you add the
extension '.fbk' to the end of your file name and click on 'Open'. For example: 'mybackup.fbk'. 

5. Confirm the location is correct and press the 'GO' button. Your Retain database will be backed
up.

Notes:
- You do not need to change the settings in the 'Backup Options' and 'Restore Options' tabs.
- We recommend that you also make a copy of the backup folder on a separate machine or external drive as
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a second backup of your data.

Related Topics:

Backup Notebooks
Restore Database

top ^

3.2 Backup Notebooks

The following files should be manually backed up:

 Retain Notebooks ('.RetainNotebook' files) which are by default stored in the 'Data' folder. E.g.: 
C:\Program Files\RetainPlannerV5\Data

 Retain configuration files ('.ini') which are stored in both the main 'Retain Planner 5' folder and the
'Server' sub-folder.

To perform manual backup:

1. Ensure that all users have saved their work and exited Retain Planner.

2. Manually copy the 'Data' folder (and any other folder that you store Retain Notebooks in) and paste it
into the backup folder.

3. Manually copy configuration files such as 'bkgDialog.ini', 'SvrCnfg.ini', 'ClntCnfg.ini' and 'Servers.ini'
and paste them into a backup folder.

4. Copy the backup folder to a separate machine or external drive.

top ^

3.3 Restore Database

On rare occasions, you may need to restore the Retain Database from a backup.

To restore Retain database:

Before restoring your Retain database from a backup, you should rename the existing 'Retain.fdb' file as the
restore will overwrite this. By default, the location of 'Retain.fdb' is C:\Program
Files\RetainPlannerV5\Server\Data.

1. Stop Retain Server. Select File-> Exit or click on the 'X' button in the Retain Server window.

Note: The restore will fail if Retain Server is not stopped. 

2. Start the Backup Database from Start-> Programs-> Retain Planner 5-> Utilities-> Backup
Database. It can also be found in the 'Server' folder, it is a file called 'RetainBackup.exe'. 

3. If not already selected, go to the 'Restore' tab in the 'Retain Backup' dialog.

- 'File to Restore:' is the location where the restored database will be saved. Click on the 'Browse'
button to navigate to your destination folder.

 - 'Backup File:' is the location of the backup you wish to restore.

4. Confirm the location is correct and press the 'GO' button. Your Retain database will be restored.
top ^



Troubleshooting

1212

4 Troubleshooting

4.1 General issues

 Utilisation is appearing as 100% in reports even though the resource is booked for less

This issue can occur after adding a new resource with a new diary. Check the 'Diary Time' value: if it is zero,
run the overnight script to update the DGD_SUM table.

 Can not see the changes made to data after updating the existing/switching to a new database

Ensure that you clear the cache before using the new/updated database: For Retain Web, clear the contents
in the 'rwpcache' folder; for Retain Wallchart and Security Manager clear the 'cache' folder.

4.2 Retain Wallchart specific

 Installing on Windows XP Service Pack 3, get 'Could not access network' error

Create an empty folder called 'Data' in the same folder as the installer and try running it again. 

 Get 'Could not connect to Server' error 

Ensure that Retain Server is running. Normally, it will be run automatically, but can also be run manually.
- If Retain Server is located on your machine, you should either see an application called 'Retain Server'
running or have it running as a Windows service (Start-> Administrative Tools-> Services).
- If Retain Server is located on a server machine, contact your Retain administrator.

 Can not make/edit bookings

Ensure that you are in 'Edit Mode'. In the main menu within Wallchart go to 'Edit-> Edit mode...'.
If you still can not make/edit bookings, it is possible that you do not have the appropriate access rights.

 Can not create a report

If you can not access reports page, you probably do not have the appropriate access rights. Contact your
Retain administrator.

 Some of the data is suddenly missing/has changed

- It is most likely that there is a selection applied to the view you are in. Clear the selection by going to Data->
Clear Selections. Note that only unlocked selection will be cleared.
- Check that you are looking at the correct date range, i.e. the date bar at the bottom of the screen is showing
the date range you expect.
- It is also possible that another user has deleted/amended the data.

 The fields in 'Booking' dialog are not displayed properly

Right-click within the dialog and select 'Reset dimensions'.

 'Limit results by the locked criteria' checkbox is not working

Ensure that you understand the behaviour of this functionality. If you lock a selection criterion and tick the
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'Limit results by the locked criteria' checkbox, the results of the unlocked criteria will be limited to the locked
selection. See Retain Wallchart User guide for more information. 

 Get ‘Failed to obtain exclusive licence lock’ error 
Confirm that Retain Server is not already running. If the server is on your machine, check the Task Manager
or use a different port.

 Get ‘Invalid Fields’ message for field(s) that exist in the database
The field(s) might be hidden in Retain Security Manager, 'Tables' section.

 Increasing the decimal places through 'Numeric Data Formatting' dialog does not work

The number of decimal places is specified in Retain Security Manager. If you wish to override it with a value
entered through the 'Numeric Data Formatting' dialog within Retain Wallchart, enter '-2' as the decimal places
value for that field.

 I want the decimal places defined in 'Numeric Data Formatting' dialog to depend on the regional
settings

In Retain Security Manager, Tables section select the required field and enter '-1' as the decimal places value.

 Get invalid comparison mechanism error
Integer fields are currently supported for 'Like' comparisons. To be able to compare integer fields, we need to
add another comparison mechanism which is done by adding the following to ClntCnfg.ini:

[DropDown]
VisibleCompareMechanisms=Like,Equals

This allows the 'Equals' configuration to compare integer fields.

4.3 Retain Security Manager specific

 The changes made using Security Manager are not applied in Retain Wallchart/Retain Web

Make sure you have saved your changes in Security Manager by clicking on the 'Save Changes' button and 
selected 'Structure-> Effect changes' from the menu. If that does not work, try restarting Retain Server (after
saving your changes) as well as Retain Wallchart/Retain Web.

 The default user was accidentally deleted

To restore the default user, stop Retain Server and double-click on RecoverDefaultUser.bat from the ‘Server’
folder. 
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5 Support Services

Support for Retain is available worldwide. This topic is linked to your support provider's information: Support
Service Provider.

retaininternational

USA phone: 1 646 688 4496
UK phone: 0845 458 8660
World phone: +44 20 7538 4774

USA fax: 1 646 478 9475
World fax: +44 845 458 8661

General E-mail: info@retaininternational.com
Support E-mail: support@retaininternational.com

Postal Address: Retain International Ltd
33 Beaufort Court
Admirals Way
London, E14 9XL
United Kingdom

mailto:info@retaininternational.com
mailto:support@retaininternational.com
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