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1.2

About Retain Wallchart
Retain Wallchart is a flexible planning tool for viewing and managing staff and job allocations through a user
friendly graphical interface. It has been designed to resemble the manual 'wallchart' booking system but is
much more versatile than any manual booking system:

See the Overview of Retain section for more information.

1.3

About the guide
This guide is intended for new Retain users who wish to learn how to use the software as well as existing
users who want to improve their knowledge of Retain and familiarise themselves with the new features and
functionality.
The guide starts with an overview of the different elements and structure of Retain. It is advisable to read this
chapter if you have not used Retain before.
The Getting Started chapter provides information on on how to run Retain.
For concise descriptions of the basic functionality of Retain, see the Quick Start guide.
The following chapters provide an in-depth view of all the features and functionality of Retain.
Note: This user guide assumes that the new users start with an existing database (either from their
organisation or an example file) that already contains resources and jobs. However, if you are starting 'from
scratch', you are advised to read the Resources, jobs and components chapter before you start to make
bookings.
Lastly, the guide provides useful reference information as well as support contact details.

8
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1.4

Conventions
The following conventions are used throughout this user guide:
· Data file types are referred to as follows:
The file extension for Version 5 Retain notebook files is '.RetainNotebook' (previously the
extention was '.RTN').
· The text to be entered using the keyboard is in bold typeface, for example:
Type A: as the run command.

· Menu options, options within dialogs and special terms are expressed in single quotes, for
example:
Select 'File-> New' from the menu.

· Keyboard strokes are represented in capital letters, for example:
ESC represents the Escape key.
F1, F2, etc. represent the function keys.
· A plus sign between two keys indicates a combination of the keys to be pressed, for example:
CTRL+S represents the action of holding down the Control key and pressing the S key.

1.5

New features
Retain Resource Planning System Version 5.1 introduces the following enhancements:
· A new 'Booking' dialog
· Scenarios and Scenario Bookings
· Dockable Pane
· Numeric Formatting (disabled by default)
· A record of changes made to a booking
· Calculated Wallchart fields
· Job-specific Components

Retain Resource Planning System Version 5.0 introduces the following enhancements:
· 3-D Wallchart View
· Attachments
· Booking Shapes
· Booking Requests
· Over-allocation Notification
· Copy Checkboxes
· Mandatory and Optional Fields

9
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· Screenshot Capture
· Default Notebook
· Multiple Selection of Records
· Fast Field Selection
· Edit Mode Password
· Improved Issue Reporting Tool

1.6

Where to get support
If you have any issues with Retain which you are unable to resolve using this user guide or through your local
support contacts, please contact your Support Service Provider.

10
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2
2.1

Overview of Retain
Overview
The main concept of Retain evolves around the idea of managing resources in order to perform jobs. The
exact meaning of the terms 'resources' and 'jobs' varies from organisation to organisation but the process of
allocating resources to jobs in the form of 'bookings' is applied in all the cases.
Retain is primarily a resource management (as opposed to a project management) tool. It is therefore not
particularly concerned with the individual activities performed during each job. However, 'components', and
'booking types' can be used to indicate the nature of a job.
Furthermore, Retain allows you to maintain information on resources, jobs and components. Users are
encouraged to record descriptive information about jobs and resources to help them in the planning process.
You should balance the benefit of recording this information to the planning process with the time taken to
capture and maintain it. The data on resources, jobs, components, etc. can be updated on a continuing basis
throughout the resource management process. You can build these details up from scratch but it is usually
helpful if the starting position can be established as a one-off exercise, before you start making bookings.
Related Topics:
Resources
Jobs
Bookings
Components
Booking Types
Notebooks
Notebook pages

2.2

Resources
Retain uses the term 'resources' as a general description of people or entities that can be applied to the
process of completing a job.
In many organisations the term 'resources' simply refers to staff. However, since you can also use Retain to
plan other types of resources such as machinery or training rooms, any item with a finite capacity that can
perform a job might be considered a resource.
See the What are resources section for more information.

2.3

Jobs
Retain uses the term 'jobs' as a general description of any project, product or assignment that is being
planned.
What constitutes a job in your organisation depends on the nature of your business and what you consider to
be the 'unit' level of your planning in Retain. Some organisations may set up a separate job for each individual
project, while others may group together projects under a single 'umbrella' job.
Since every booking in Retain must be made against a job, jobs should also be created for non-project
activities such as vacation, sick leave or, in a manufacturing context, machine down-time.
You can group jobs for viewing or reporting purposes by a particular value that they share. For example, you
can use the 'Industry' field to group jobs within the same industry.
See the What are jobs section for more information.
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2.4

Bookings
In Retain a 'booking' represents an allocation of an individual resource (or several resources) to a specific job
which covers a defined date range and a measurable number of hours.
In order to allocate resources to jobs in Retain you will need to make bookings. You can make bookings using
both Wallchart and Calendar views, although it is usually easier to make them using the Wallchart view.
Retain treats all allocations as bookings, regardless of their nature. This means that 'non-jobs' such as
vacation and sick leave should also be entered as bookings. You can use the fields associated with a job
(e.g. booking type) to treat such jobs differently.
For more information on bookings, see the What are bookings section.

2.5

Components
In Retain 'components' are sub-jobs that provide information regarding the nature of each booking made
against a job. Components supply an element of project planning within Retain, since you can assign a
component for each booking and analyse the job into its component parts for reporting purposes.
Components take the form of a simple pick-list of descriptive names, available for selection each time you
make a booking. They are usually defined in general terms applicable to most jobs, such as 'planning',
'fieldwork' and 'reporting'; although you can enter components relating to specific types of job such as 'branch
visit' or 'security review', for example.
The level at which you define components should correspond to that at which you make bookings in Retain.
For example, if your planning in Retain takes the form of bookings of two or more weeks each, your
components should not represent the half-day elements within each booking.
See the What are components section for more information.

2.6

Notebooks and data
Retain uses a database structure to store its data. Resources, jobs, components and bookings are all stored
in separate tables.
The files used by Retain are called Retain notebooks ('.RetainNotebook' files). Notebooks contain views of
your Retain data, allowing you to display and edit your data in various ways as well as create reports using
Retain Report Writer.
Each notebook points to a particular database. In most organisations, you are likely to have a single database
but you may have several notebooks pointing to that data. In a network environment, your Retain data may be
stored on a network drive and shared by many users. Each user may have their own notebook files, or you
may even have notebook files which are shared by several users.
Note: If you intend to share notebook files, remember that the notebook file is changed each time someone
saves it. You may prefer to make shared notebook files read-only so that they cannot be amended.
It is essential, while working with a Retain notebook, to appreciate that the underlying data is the same across
all pages, notebook files and even users of that data.
For example, if you amend a booking in a particular notebook the booking itself is amended, not just the view.
However, if you were to hide some bookings in a notebook then they would still be visible in all other
notebooks - the underlying data would not change.
See the Working with notebooks chapter for more information.
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2.7

Notebook pages
A Retain notebook contains one or more 'notebook pages', each page representing a different view of your
data. The characteristics of each notebook page can be defined and maintained independently, using the
various sort, selection and other display features.
Notebook pages allow you to create an almost unlimited number of views of your data. See the Notebook
pages section for more information.
A notebook can be one of the following three types:
· Wallchart - the traditional Wallchart view with resources or jobs listed on the left-hand side of the page and
a continuous time bar along the top. Each booking is represented as a coloured block within the Wallchart:

· Calendar - a Calendar view where each screen page represents the bookings for one individual
resource or job. Time is represented in a calendar style grid and special navigation features allow you
to move between resources or jobs:

13
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· Report - reports that you can easily develop and quickly generate using the powerful Retain Report
Writer:

Retain notebook pages are dynamic because they represent the view of data.
The best way of working is to create a separate notebook page for each view of your data that you want to
produce on a regular basis and work within these existing notebook pages, rather than create a separate
page for every unique view.

14
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3
3.1

Getting started
Installation
This guide assumes that Retain has already been installed on your personal computer or network drive and is
available to you. If it is not, either consult your local support contacts or refer to the Technical Implementation
Guide for instructions on installing Retain.

3.2

Initial set-up
After the software has been installed, the following initial set-up tasks should have been carried out prior to
Retain 'going live' in your organisation:
1. For network versions, user names and access rights should be defined.
2. The Retain database file should be set up, including:
·
·
·
·

specifying the location of your data files;
setting up initial charge rates and charge periods;
defining the standard working diary for both calculation and display purposes;
setting up colours and shapes as well as defining colour /shape conventions and alias names.

3. The Retain notebook files should be set up, including:
· amending the standard data structures, if required;
· clearing out any sample or test data;
· loading resources and jobs from other applications, if necessary.

3.3

Starting Retain

To launch the application, select the Retain icon

and double-click on it (or press ENTER).

The start-up Retain window will open:

Using this window you can:
· create a new Retain notebook,
· open an existing Retain notebook,
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· set up environment preferences,
· customise the toolbar,
· access the Retain help files
· or close the application.
You will usually start by creating or opening a Retain notebook which gives you access to your planning
information. See the Working with notebooks chapter for more information on creating and/or opening
notebooks.

3.4

Retain interface
Once you have created or opened a new notebook, it will be displayed on the main screen:

The view is divided into the following areas:
1. The menu bar - Located at the top of the screen, this menu provides access to all of the Retain's
functions.
2. The toolbar - This is usually located immediately below the menu bar and contains several
buttons. These buttons provide a quick access to many of the commonly used features in Retain.
You can add and remove the toolbar buttons as required.
3. The notebook page navigation list - This drop-down list allows you to select the notebook page to
be displayed within the Wallchart. You can only select from the pages within the currently open
notebook. Think of a notebook as a document or a spreadsheet; you can have a number of
notebook pages in Retain and each will reside in its own window. Links to the four most recently
opened pages are displayed to the right of the drop-down.
4. The notebook area - The main part of the screen, this area displays the list of resources/jobs on
the left-hand side and the bookings on the right-hand side.

16
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5. The status bar - Located at the bottom of the screen, this area displays the name of the currently
selected resource and the date range covered by the selected booking. It changes according to
the displayed context. The status bar will also show hints for a menu item that you are pointing to.
6. The dockable pane - Located on the right-hand side of the screen, the dockable pane is used to
'dock' the dialogs you are working with, enabling you to navigate around the Wallchart or see the
changes being made without closing the dialogs.

3.5

Switching to edit mode
When you first enter Retain you will always be in the 'read-only mode'. While in read-only mode you can move
around your Retain notebook and produce reports but you cannot amend any data.
To edit the data you have to be in the 'edit mode'. In a network environment you will also need to have edit
access rights which should have been set up by your Retain administrator.
To switch to Edit mode:
1. Select 'Edit-> Edit mode...' from the menu.
Shortcuts: The 'Edit-mode'

button or press CTRL+E.

2. Enter the edit password in the 'Password' dialog. The default password is 'abc' (case sensitive). To change
the password, see the Changing the edit password section.
3. Click on 'OK' or press ENTER.
Once in the edit mode, the 'Edit-mode' button will be grayed out and the 'Edit booking'
enabled. You can now make changes to the data.

button will become

Note: If the edit button is grayed out, it means you do not have the appropriate access rights to switch to the
edit mode.
You will remain in the edit mode until you choose to return to read-only mode. You may want to switch back to
read-only mode at the end of an editing session or if you move away from your PC, to make sure you do not
make changes accidentally. Click on the 'Edit-mode' button again.
Alternatively, you can disable the need to enter a password when switching between the read-only and edit
modes by checking the 'Don't ask me again' checkbox:

Note: If you wish to re-activate the prompt, go to the 'File-> Preferences', 'General' tab and tick the 'Always
show password dialog for authentication' checkbox.
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3.6

Changing the edit password
The edit password provides a simple access control mechanism for users who have full access to the system.
Access for network users is also controlled by user access rights, as defined by your Retain administrator.
When you enter the correct password and enter the edit mode, you can amend all the data stored within
Retain.
When Retain is first installed the edit password is 'abc' (case sensitive). If you are relying on this password to
control access to edit facilities in Retain then you should change this password regularly.

To change the edit password:
1. Select 'Edit-> Change password...' from the menu.
2. In the 'Password' dialog enter the current password and click on the 'OK' button.
3. Enter your new password and click on the 'OK' button.
4. Re-enter the new password and confirm your changes by clicking on the 'OK' button.
Your new password will be saved and will be required whenever you switch into edit mode in the future.
Each Retain user with full edit access rights should maintain their own edit password.
Note that the password is case sensitive and is held locally. If you forget your password, contact your support
provider.

3.7

Exiting Retain
To close the current notebook(s) and exit Retain, select 'File-> Exit' from the menu.
Shortcut: ALT+F4.
You do not need to save changes to the data before exiting Retain because all the changes are saved to the
disk as they are made.
However, you may be prompted to save changes to your notebooks. See the Working with notebooks chapter
for more information.
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4
4.1

Quick start
Quick Wallchart
Opening Retain

Locate the Retain
icon on your workspace and double-click on it or launch the application from the Start
Menu. In the start-up screen you can create a new notebook or open an existing one.
Retain has been set up to resemble a personal notebook consisting of notebook pages that constitute a set of
personalised views of one Retain database. Each notebook can contain one or more notebook pages, each
representing a different view of the data (you can add up to forty notebook pages).
Altering resource, job or booking information within a notebook will change the information held in the
database directly.
Altering the selection criteria, sort order or fields displayed only affects the notebook you are currently working
with. By saving a notebook you will be saving these settings.
To create a new notebook, select 'File-> New' from the menu.
To open an existing notebook, select 'File-> Open' from the menu. The Wallchart view (the default view)
will open. It has resources/jobs listed on the left-hand side with the date range at the top and bottom of the
screen. Bookings are displayed in the middle of the screen.
Related Topics:
Notebooks overview
Creating a new notebook
Opening an existing notebook
Saving the notebook
Default notebook
Navigation
Menu options can be accessed from any part of the screen by right-clicking with your mouse. The contents of
the drop-down menus vary depending on which part of the Wallchart the mouse cursor is positioned in.
There are several ways in which you can navigate within the Wallchart:
Scroll Bars
· The scroll bars at the right-hand side of the Wallchart enable you to scroll up and down the resource/job
list.
· The scroll bars at the bottom of the Wallchart enable you to move forwards and backwards in time.
· The single arrow moves a single unit in time (depending on the date scale displayed).
· The double arrows move one Wallchart view in time.
Transparent Frame
The transparent rectangular frame at the bottom of the Wallchart can be dragged to the left/right or
extended/condensed. The time period displayed in the Wallchart will correspond to that contained within the
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rectangle.
The 'Go To' button
Clicking on the 'Go To' button at the bottom left corner of the screen will open up the 'Move to Date' dialog,
allowing you to specify a required date to be displayed.
To change the time scale displayed within the Wallchart, right-click anywhere on the booking area of the
Wallchart. Select 'Zoom...' from the menu and choose the required date scale. Alternatively, use the time
scale buttons on the toolbar.
Locating a particular resource or job
To quickly locate a record, start typing the name of the required resource/job. See the Finding a particular
resource or job section for more information.

Rotating the view
To switch from Resource to Job view, right-click anywhere within the Wallchart and select 'Job View' from the
menu.
Alternatively, click on the 'Rotate View'

button to switch between the views.

The job view displays the list of jobs on the left-hand side of the screen with the related bookings in the centre
of the Wallchart. Right-click anywhere in the Wallchart and select 'Resource View' to switch back to the
original view.

Booking bar tips
Booking bar tips are displayed when you hover over a booking with your mouse:

These tips are configurable and can be edited to display the fields that are most relevant to you.
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4.2

Quick bookings
Working with bookings
In order to make a booking, you need to:
· Be in edit mode
You must be in the edit mode in order to make any changes to the data. This includes amending resource,
job, component details, making bookings, etc. Select 'Edit-> Edit Mode' from the menu. Type in the password.
The default password is 'abc' (case sensitive).
· Mark an area within Wallchart and make a booking
To make a booking, mark an area within the Wallchart that encapsulates the necessary date range, right-click
and select 'Make booking...' from the menu. See Making a booking section for more information.
You can make bookings for one or more resources using the 'Booking' dialog. A job and at least one resource
must be selected in order to make a booking.
To edit the booking details, right-click on the necessary booking and select 'Edit booking...' from the menu.
You can also change the booking start/end dates using the Wallchart:move the mouse over the left/right
border of the booking and when the cursor changes to a
, resize the booking as necessary.
To move one or more bookings within the Wallchart, click on the necessary booking(s) and drag them to
the required position.
To copy a booking, hold down the CTRL key and click on the booking you wish to copy then drag it to the
position where you want it to be pasted.
To select multiple bookings, hold down the CTRL key and click on the necessary bookings.
To delete a booking, select the booking by clicking on it and press Delete(DEL). Alternatively, right-click on a
booking and select 'Delete booking' from the menu. Click on 'Yes' to confirm the deletion.
Related Topics:
Switching to edit mode
Making a booking
Editing bookings

Using the clipboard
Clipboard is useful when you want to move/copy bookings beyond the currently displayed area of Wallchart. It
is located at the top left-hand side of the Wallchart page.
The clipboard is similar to the normal clipboard facility provided by other Windows applications as you can
paste bookings from the clipboard. However, Retain clipboard is a little different because:
· it only deals with bookings,
· a number of bookings can be stored at any one time,
· each notebook page has its own clipboard. The bookings in one page's clipboard are unavailable in any
other pages' clipboard.
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Copying bookings
You can copy bookings between resources. To copy a booking to the clipboard, hold down the CTRL key and
click on the booking you wish to copy then drag it to the clipboard.
Cutting bookings
Click on the booking to select it. Holding down the mouse button and drag it to the clipboard.
Moving up/down within the clipboard
When the clipboard fills up, arrow keys appear on the right-hand side allowing you to scroll up and down the
list of bookings.
Note that you can also move/copy bookings from the clipboard in the same manner you move/copy them to
the clipboard.

4.3

Quick resources and jobs
Add/edit/delete
Make sure you are in the edit mode before attempting to alter record details.
If unsure, you can check whether you are in edit mode or not by going to the 'Edit' menu. A tick next to the
'Edit Mode...' means you that you are and can edit records.
Adding a resource/job
Right-click on the resource/job list (displayed on the left-hand side of the screen). Choose the 'Modify
Resources/Jobs' option from the menu and click on the 'New' button. Enter the necessary details in the 'Add
Resource' or 'Add Job' dialog. When finished, click on the 'Add' button.
Editing a resource/job
Right-click on the resource/job list (displayed on the left-hand side of the screen). Choose the 'Modify
Resources/Jobs' option from the menu. Locate the record you wish to edit from the drop-drown list and click
on the 'Edit' button. Edit the required details in the 'Edit Resource' or 'Edit Job' dialog. When finished, click on
the 'OK' button.
Deleting a resource/job
Right-click on the resource/job list (displayed on the left-hand side of the screen). Choose the 'Modify
Resources/Jobs' option. Locate the record you wish to delete and click on the 'Delete' button. A warning
message will appear asking you to confirm the deletion. Click on 'Yes' to proceed or 'No' to cancel the
deletion.
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Sorting
Sorting is useful if, for example, you wish to sort your resources alphabetically by grade or office.
Right-click on the resource/job list on the left-hand side of the screen and select 'Sort...' from the menu. You
can choose to sort by a number of different fields. See the Changing sort order section for more information.
Note: Do not forget to clear the sorting once finished.

Selecting
Selecting is very useful as it allows you to filter the view according to your needs. For example, you can
display resources with the 'Manager' grade, show the London office staff only or view the jobs that Alice
Jardine manages. See the Defining selection criteria section for more information.
Selecting – Marked records
You can view only the selected records. Use 'click and drag' functionality to select or deselect the required
records. Alternatively, hold down the CTRL key and click on the records you want to be included in your
selection (from the resource/job list on the left-hand side of the screen). Right-click on the resource list and
choose the 'Select marked records' option.
To clear this selection, right-click on the resource/job list and choose the 'Clear entire selection' option from
the menu. Alternatively, select the 'Data-> Clear entire selection'.
Selecting – Availability
If, for example, you want to show all the resources that are available during a particular time period, mark an
area anywhere within the Wallchart (as if you were going to make a booking). Right-click and select 'Special
Selections-> Add...' from the menu.
In the 'Special Selections' dialog make sure 'Availability' is selected in the 'Calculated Field' drop down and
edit the start and end date of the preferred time frame. Enter an availability percentage (the default is 80%)
and click on the 'OK' button to save changes.
You can perform these Special Selections on other calculated fields such as 'Utilisation'. See the 'Special
Selections' dialog section for more information.
To clear the availability selection, right-click on the resource list and select 'Special Selections-> Clear...' from
the menu.
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4.4

Quick notebooks
Notebooks and pages
You can add up to forty notebook pages to your notebook, each page containing a different view of your data.
You can add a Wallchart, Calendar or Report page. The characteristics of each notebook page can be
defined and maintained independently using the various display features in Retain.
Adding a page
To add a new notebook page, select 'Notebook-> Add page...' from the menu or click on the 'Add page'
button. In the 'Add Page' dialog, choose what type the new page will be (Wallchart, Calendar or Report),
name the page and click on the 'OK' button. A new page will be added to your notebook.
Select the new page from the drop-down list. The sort and selection of the new page defaults to all resources
sorted by name. Once in your new notebook page, use the appropriate sort and selection criteria to change
the view as necessary.
Adding a Calendar page
The calendar view shows bookings for one individual resource or job. Time is represented in a calendar style
grid and special navigation features allow you to move between resources or jobs.
To add a calendar page, select 'Notebook-> Add page...' from the menu or click on the 'Add page'
Choose 'Calendar' in the 'Add Page' dialog, name the calendar page name click on the 'OK' button.

button.

Note that the calendar displayed will default to the first resource in your resource list. For information on how
to select a specific resource or move between resources, see the Calendar view chapter.
Adding a Report page
Reports page allows you to create customised job and resource based reports. You can format, sort, select
and aggregate your reports in a number of ways.
To add a report page, select 'Notebook-> Add page...' from the menu or click on the 'Add page'
Choose 'Report' in the 'Add Page' dialog, name the report page and click on the 'OK' button.

button.

Using 'Setup Report' dialog define the fields you want to display in the report and choose the date range. You
can also define sort or selection, if necessary.
Deleting a notebook page
To delete a page, select it from the drop-down list and choose 'Notebook-> Delete page...' from the menu.
Click on the 'OK' button to confirm deletion of active page.

Saving and closing notebooks
Saving a notebook
To save a notebook, select 'File-> Save' from the menu or press CTRL+S. Select the required location and
type in a name for your notebook. It will be saved with the '.RetainNotebook' file extension.
Note that the view settings such as the sort order or selection of fields of the data will be saved. Any changes
to the actual data (e.g. bookings) will already have been saved within the database while the changes were
being made. See the Saving the notebook section for more information.
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Closing a notebook
To close a notebook, select 'File-> Close' from the menu. If any changes were made and you close the
notebook or exit Retain without saving, you will be prompted with a dialog asking you to confirm that you do
not wish to save changes.

Opening notebooks
When you open a previously saved notebook, the underlying data displayed will be the current data. The
views will be those saved when you last closed the notebook.
To open an existing notebook, select 'File-> Open' from the menu or click on the 'Open'
'Open' dialog specify the location of the notebook, select it and click on the 'OK' button.

button. In the

Format booking bars
Bookings are displayed as coloured bars within the Wallchart. You can customise the following features of
booking bars:
Booking bar height/depth
To change the height of the booking bars on the Wallchart, right-click on a highlighted booking. Select
'Booking Bar-> Depth...' from the menu and choose the bar size you wish to use.
You can also choose to make the depth proportional to the loading of the booking by selecting the appropriate
radio button.
Booking bar layout
To change the layout of your booking bars, right-click on a highlighted booking and select 'Booking Bar->
Layout...'. You can then choose whether to show bookings separate or stacked; select the 3-D look of the bar
(Plain, Embossed or Recessed); and whether to show continuation arrows when the bookings go beyond the
edge of the currently visible screen or to use the word wrap option. See the Booking bar formats section for
more information.
Booking bar fields
To change the details displayed on the booking bars, right-click on a highlighted booking bar and select
'Booking Bar-> Bar Fields...'. From here you can add or delete fields in the booking bar. You can change the
font of text by selecting 'Bar font' from the same menu. See the Booking bar fields section for more
information.
Booking bar tips fields
To change the details displayed as the booking bar tips, right-click on a highlighted booking bar and select
'Booking Bar-> Tips Fields...'. From here you can add or delete fields in the tips box. To change the font of
tips text, select 'Tip font' option from the same menu. See the Booking bar tips section for more information.
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4.5

Quick reports
Report page
To create a Report page, follow the instructions provided in the Creating a report section.
Report fields are displayed on each row of the report. On the Fields tab of the Setup Report dialog select the
fields you want to display in your report from the drop-down list in the 'Fields' panel.
You can select any of the fields from the resource, job and bookings tables, plus a number of special report
fields (calculated fields).
Report sort criteria
Click on the 'Sort...' tab to sort the records listed in your report. See the Sorting and selecting chapter for more
information.
Report selection criteria
Click on the 'Selection...' tab and input selection criteria to choose the records for your report.
Report date range
You can also specify the date range the report will be generated for. Select 'Data-> Date range' from the
menu, click on the 'Date Type' tab and choose the time range you require. If you want to input a manual date
range, choose the 'Manual Date Range' option at the top of the Date Type pick list and use the calendar
buttons to select a start and end date for your report. When you are satisfied with your report specifications,
click on the 'OK' button.

Viewing
Click on the new Report page to view your report. If you have entered sort criteria, the report will be grouped
under sort headings.
To view all records' details right-click anywhere over the main report area and choose the 'Open All Detail'
option.
Report header/footer
To edit the report header and footer, right-click anywhere over the Title area and select the 'Edit Header...'
option. The Header/Footer Configuration dialog will open, from where you can edit either the header or the
footer.
You may edit the following header details: title, sub-title, date of report generation, page number, date range
covered by report, surrounding frame, column titles. You can also choose whether or not to show a header at
all.
You can edit the following footer details: footnote, date of report generation, page number, surrounding frame,
fonts for footer elements. Click on the Footer tab to edit footer details. When you have finished, click on the
'OK' button.
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Printing
It is always a good idea to preview the report before printing it. Select 'File-> Print Preview...' from the menu.
When you have finished viewing the page, click on 'Close'.
To print the active page, select 'File-> Print' from the menu. Using the 'Print' dialog, you can define the
margins, header and footer information as well as the date range you want to be printed.

4.6

Quick preferences
Preferences
Retain preferences are the default settings which will be applied in various areas of Retain Wallchart.
To set the preferences, select 'File-> Preferences...' from the menu.
Available Preferences:
General:

These options will apply to all your Retain notebooks.
For example, you can choose whether or not to display booking bar tips and whether you can
make block bookings.

Bookings:

These options will apply to bookings.
For example, you can choose whether to display field names on booking bars and booking tips.

Availability: These options will apply to availability selections.
For example, the default availability limit.
Printing:

These options will apply to printing.
For example, whether or not the printing should be in colour.

Toolbars
Retain provides a 'toolbar', a panel of buttons located at the top of the screen. These buttons provide a quick
access to most of the commonly used features in Retain. You may wish to customise the toolbar to include
the buttons you will require most frequently.
To customise your toolbar, select 'View-> Toolbar options...' from the menu.
To remove a button from your current toolbar, click on the button in the 'Selected Toolbar' list on the
right-hand side and drag it to the 'Available Buttons' list on the left-hand side.
To add a button to your current toolbar, select it from the 'Available Buttons' list and drag it to the 'Selected
Toolbar' list. Alternatively, use the left and right arrow buttons to move the toolbar button from one list to
another.
To add a separator (space) between the buttons, click on the position in the current toolbar above which
you wish to add the space and click on the 'Separator' button.
Note that buttons can be rearranged using click and drag functionality. When you are finished, click on the
'OK' button.
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4.7

Quick reference
Wallchart view
The following image is an example of a Wallchart view:

For more information see the Wallchart view chapter.

Calendar view
The following image is an example of a Calendar view:

For more information see the Calendar view chapter.
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Report view
The following image is an example of a Report view:

For more information see the Retain Report Writer chapter.

Buttons
Main buttons:
Create new notebook
Open existing notebook
Help Topics
Wallchart view - Edit mode on/off
Wallchart view - Switch between Resource/Job view
Wallchart view - Add new notebook page
Wallchart view - Delete active notebook page
Wallchart view - Change active notebook page name
Wallchart view - Make a booking
Wallchart view - Edit selected booking
Wallchart view - Delete selected booking
Wallchart view - Copy selected booking to clipboard
Wallchart view - Time scale, years
Wallchart view - Time scale, months
Wallchart view - Time scale, weeks
Wallchart view - Time scale, days
Wallchart view - Time scale, hours
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Wallchart view - Change sort order
Wallchart view - Change resource/job selection
Wallchart view - Edit page fields
Wallchart view - Turn Wallchart grid on/off
Print preview - Send to printer
Print preview - Edit print header
Print preview - Edit print footer
Reports - Show/don't show report header
Reports - Show/don't show report footer
Reports - Edit report header
Reports - Edit report footer
Reports - Show more record detail
Reports - Open all record details
Reports - Show less record detail
Reports - Close all record details
Calendar view - Show previous record
Calendar view - Show next record
Note: If you hover over the button with your mouse, a tip will appear indicating the function of that button.
For the full list of available buttons, see the Retain button reference section.
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5
5.1

The Wallchart view
Overview
Wallchart pages in Retain look similar to a traditional 'wallchart' booking system. They have a date scale
along the top and a list of resources on the left-hand side with a number of coloured bars on the grid
representing bookings (commitments to work):

You can do much more with Retain Wallchart than any manual wallchart. In addition to making bookings, you
can:
· rotate the view to see the bookings against jobs instead of resources;
· sort the resources (or jobs) in different ways and filter out unnecessary information from your current view
of the Wallchart;
· manipulate the scale of the booking bars and Wallchart as a whole, as well as define the information
displayed on the booking bars;
· select several bookings at the same time and make changes to all of the selected bookings
simultaneously;
· manage the information on resources and jobs listed on the Wallchart;
· add public holidays and have bookings incorporate their effects.
Related Topics:
Working with the Wallchart
Wallchart display options
Public holidays
Booking display options
Wallchart fields
Setting the opening date
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5.2

Wallchart 3-D view
Retain Wallchart can also be viewed three-dimensionally, providing you with the ability to instantly see the
loading of bookings:

The 3-D view is an alternative view of the Wallchart rather than a replica of the 2-D Wallchart functionality.
To switch to the 3-D view, select 'View-> 3D Wallchart' from the menu.
You can rotate the view upwards, downwards, left or right by clicking on the appropriate arrow. Rotating the
view will reveal the depth of the bookings, which represents their loading percentage (see the image above):

The hovering control for this view is displayed on the top right corner of the screen and does not move when
the the view is rotated.
Clicking on the
and
buttons will zoom the view in and out, respectively. This allows you to see a larger
or smaller number of resources.
To reset the rotation, click on the

button. Note that this does not reset the zoom in depth.

Since the 3-D view provides a visual indication of the loading of each booking, it is especially useful if you
want to assign a booking to a resource with less loading.
For example, imagine you have two resources (Fiona Shoch and Frank Bell) that can be assigned to the
'Market Media' booking. In the original Wallchart view the situation would look similar to this:
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Because you want to make sure the booking goes to the resource with less loading and the traditional
Wallchart view does not visually indicate the loading of bookings (see the image above), you would have to
check each booking ('E-Solutions', 'Urban Future' and 'Digitise') to calculate the total loading for each
resource.
Furthermore, without checking the loading you would most likely assume that since Frank Bell has two
bookings and Fiona Shoch only one, the person with less loading is Fiona Shoch and so you would assign the
'Market Media' booking to her.
However, if you were in the 3-D view, the loading of these bookings would be clearly visible and you would
see that Fiona Shoch has a much greater workload than Frank Bell:

The 'Market Media' booking should therefore be assigned to Frank Bell.
The 3-D view also offers autoscrolling functionality. It allows you to move bookings both horizontally and
vertically within the Wallchart. The view will automatically 'move' along together with the booking. This way
you can move bookings to a date not currently displayed without using a clipboard.
To move a booking, click on it and drag to the required area.
Font scaling is another feature of the 3-D view. If you decide to change the size of the booking bar font,
zooming the view in and out will automatically adjust the size of the font to fit the booking size.
Also, clicking on a booking makes it transparent thus allowing you to see the bookings behind it. This is
especially useful for bookings with high loading:

To switch to the original Wallchart view, go to 'View-> Wallchart'.
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5.3

Working with Wallchart
Working with Wallchart overview
Working with Wallchart includes:
· rotating the Wallchart
· changing the Wallchart date scale
· navigating within the Wallchart
· finding a particular resource or job
· using the Project view
· taking screenshots
· using the dockable pane

Rotating the Wallchart
The Wallchart page can be displayed in two basic views:
· Resource view - lists resources on the left-hand side. Bookings represent jobs allocated against the
resource.
· Job view - lists the jobs on the left-hand side. Bookings represent resources booked to the displayed job.
To switch between these two views, click on a booking, if necessary (the rotated view will open with the
selected booking on the top line) and select 'View-> Rotate view' from the menu.
Shortcuts: The 'Rotate view'
button or press CTRL+R. Alternatively, right-click anywhere over the
booking grid and select either 'Job view' or 'Resource view' as appropriate.
Within these two basic views, there are numerous further options which allow you to manipulate the Wallchart
page on screen. See the Display options and Wallchart fields sections for more information.

Changing the Wallchart date scale
Retain Wallchart page can be displayed using a wide range of date scales. You can work in units as small as
fractions of an hour and as large as months or even years.
You can amend the date scales at any time. This does not affect any of the underlying data and you can
switch between date scales as often as you like.
To change the date scale, select 'View-> Zoom' from the menu and then choose a view.
Shortcuts: The date scale buttons:

(yearly),

(monthly),

(weekly),

(daily),

(hourly).

The standard date scales are displayed as follows:
· Year Approximately 3 years displayed. Each cell represents 1 month.
· Month Approximately 3 months displayed. Each cell represents 1 day.
· Week Approximately 3 weeks displayed. Each cell represents 1 day.
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· Day Approximately 3 days displayed. Each cell represents 1 hour.
· Hour Approximately 1 hour displayed. Each cell represents 5 minutes.
You might want to use the 'year' view for long-term and the 'week' or 'day' views for short-term planning.
You can also customise the settings associated with these standard date ranges.
To manipulate the date ranges manually, resize the transparent date box at the bottom of the Wallchart. Move
the mouse pointer over one end of the box so that the pointer changes to a
. Click on the border and drag
it to resize the date box as necessary. The date range encapsulated within the date box will be displayed in
the Wallchart.
To navigate to a specific date, click on the 'Go To' button at the bottom left corner of the Wallchart:

Enter the necessary date or select it from the calendar and click on the 'OK' button.

Navigating within the Wallchart
There are a number of techniques you can use in order to navigate within the Wallchart:
· Use the date scale below the Wallchart grid. Click on the transparent rectangle and drag it left or right, as
necessary.
· The 'Go To' button. This allows you to go to a specific date. The default value will be the current date,
therefore clicking on the 'OK' button will take you to today's date (indicated by a coloured vertical line that
goes through Wallchart).
· The single and double arrow buttons either side of the date scale. Press the arrows on the left-hand side to
move back in time or the arrows on the right-hand side to move forward in time.
· The scroll bar on the right-hand side of the screen. This allows you to scroll through the list of
resources/jobs displayed on the left-hand side of the screen.
· Cursor keys. Once you have clicked on the Wallchart grid, you can use the cursor keys to move between
the cells on the grid.
· Changing the date scale. Increasing the date range displays more information on the grid.
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Finding a particular resource or job
You can scroll up and down the resource (or job, in the Job view) list within the Wallchart to find a particular
record. However, there is a quicker way to find a necessary record within the Wallchart.
To quickly find a record:
1. Start typing the name of the resource/job and the 'Select record' dialog will appear.
Alternatively, use the 'Go to record'

button.

For example, if you are in the Resource view and want to locate Alison Griffin, press 'A' and the 'Select
Record' dialog will appear:

2. Double-click on the required resource name or select it from the list and click on the 'Goto' button.
3. The Wallchart will refresh with that resource displayed as the first record in the list.
If you have another field displayed within the Wallchart and sort the view by that field, it will also be shown in
the 'Select Record' dialog:

Note: If the 'Use filtering in Select Dialog' checkbox is ticked in the 'Preferences' dialog, only the matching

36

36

The Wallchart view

records will be displayed as you type in the necessary name. Alternatively, all the records will be displayed
with the matching record being highlighted.

The Project view
The Project view separates bookings into sub-fields, providing a better view of bookings belonging to each
resource/job. It is often used to display bookings against a resource on a separate row for each job:

There are many ways of using the Project view. Some of the more frequently used views have bookings
separated into rows:
In Resource view, each resource will have a separate row for:
· each job,
· each job manager.
In Job view, each job will have a separate row for:
· each resource booked to the job,
· each grade of the resource booked for the job.
To turn the Project view on or off, select 'View-> Project view' from the menu.
Shortcuts: The 'Project view'

button or press CTRL+J.
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Screenshot capture
Retain Wallchart has a built-in screenshot creation functionality.
You can take a quick screenshot of the current Wallchart view or a selected area by choosing 'View->
Screenshot' from the menu:

To create a screenshot of the current Wallchart view, select the 'Quick Screenshot' option.
Alternatively, if you want to take a screenshot of the bookings assigned to specific resources for a particular
date range for example, click and drag an area that will encompass the region you wish to capture:

The screenshot will be automatically opened within your default image application. You can then name and
save this screenshot in the required location on your computer.
Note that all the screenshots you take will be temporarily stored as bitmap images in the Windows temporary
directory. Therefore, it is important to save the screenshots you wish to keep.
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Dockable pane
When working with bookings, you may want to move around the Wallchart or see the changes being made
without closing the dialog(s) you are currently working with. The 'Booking', 'Scenario Manager', 'Colour
Legend' and 'Shape Legend' dialogs can be 'docked' in the dockable pane which is situated on the right-hand
side of the Wallchart:

Note that the 'docked' dialogs will also be visible while working in Calendar and Report views.
To add a dialog to the dock, simply couble-click on the title bar or drag and drop it on the dockable pane. You
can add several items to the pane and move them around by dragging up/down or left/right as necessary:
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To close a dialog within the pane, click on the

button for that dialog.

To remove an item from the pane, click on the title bar and simply drag it to the main Wallchart area.

To hide the dockable pane from view, click on the

button.

To resize the dockable pane, click on the border and move it to the right/left as required.

5.4

Wallchart display options
Wallchart display options overview
Retain provides various display options to allow you to view Wallchart and Calendar pages in different ways.
Display options include:
· grid lines - turn the vertical grid lines on or off;
· date scale settings - change standard date settings, grid lines and shading for a more convenient display;
· week display - change how weeks are displayed in the date bar;
· display diary - change the displayed time per day and days per week.
All of these display options are applied to the currently open page, not all pages in the notebook. If you wish to
have the same settings across all pages, create a page with the required settings and copy it. You can then
edit each page as necessary.
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Note that the current display options will be applied when you print out a Wallchart or a Calendar page.
Related Topics:
Public holidays
Booking display options
Wallchart fields

Grid lines and shading
Vertical grid lines in Wallchart and Calendar pages help to identify the individual cells of the booking area.
Thick black grid lines indicate the main dividers within the current screen (e.g. weeks), while grey grid lines
indicate the individual cells within each main divider (e.g. days). Broken grey grid lines indicate the lowest
level of time division, if in use. For further help in identifying individual cells, shading can be applied to the grid.
To turn the vertical grid lines and shading on/off, select 'View-> Grid' from the menu.
Shortcuts:The 'Grid lines'
button or press CTRL+G. Alternatively, right-click over the Wallchart area
and select 'Grid' from the menu.

Customising date scale settings
To customise the date scale settings, select 'View-> Display settings...-> Date Scale Settings' tab from the
menu.
Shortcuts: The 'Display settings'
button ('Date Scale Settings' tab) or right-click anywhere over the
date scale and select 'Date Settings-> Date Scale Settings' tab.
The 'Date Scale Settings' tab allows you to set up:
· the scaling;
· the time information shown in the calendar bars at the top of the resource screen;
· where the grid lines are displayed;
· where shading is applied;
· how booking start and end times should snap to the grid;
· the scrolling unit:
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Select the necessary date scale by choosing the appropriate scale from the drop-down list.
Scale value - The 'Scale factor' field represents the scale value. The larger the number, the greater the
amount of time shown on screen. The value represents the number of seconds for each pixel on screen. As a
general rule, you do not need to adjust this number.
Date bars - Choose which scales you wish to appear in the date bar.
Grid lines - Choose at what time intervals you want the grid lines to appear.
Shade - Choose which time intervals you wish to shade.
Snap to - Choose the smallest unit you wish to plan against in this particular scale.
Unit scroll - Choose the unit of time used when you move the current view left or right by one step.
You can edit these settings for each different date scale for the current page in the notebook.

Week display
Weeks can be displayed in the date bar using either dates, week numbers or both.
To change display settings:
1. Select 'View-> Display settings-> Week Display Mode' tab from the menu:
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Shortcut: The 'Display settings'

button, 'Week display mode' tab.

2. Choose one of the following:
· 'Show Date' radio button to display the date (first day of the week).
· 'Show Week' radio button to display the week number.
· 'Show Both' radio button to display both dates and week numbers.
3. Click on the 'OK' button to save your changes.

Display diary
Display diary settings allow you to customise the time range displayed within the Wallchart.
You will probably want the display diary to correspond your office hours.
To customise the display diary settings, select 'View'-> Display settings-> Display Diary' tab from the
menu.
Shortcut: The 'Display settings'

button, 'Display diary' tab.

· Amend the start and end time for the display diary by typing in the 'Start of day' and 'End of day' fields.
Alternatively, use the up/down arrows to change the displayed time in 5 minute increments:

· Tick the 'Show weekends' checkbox if you want weekends (7 days per week) to be displayed within
Wallchart.
· Tick the 'Mark non-working regions' checkbox if you want non-work time (e.g. public holidays) to be
displayed within Wallchart (as crosshatched areas):

Having non-working regions displayed within the Wallchart will provide a visual display of resources' diaries
and therefore their availability.
· You can also define colour for the non-working regions by clicking on the 'Colour' button. The default
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colour is grey.
Click on the 'OK' button to save your changes.

5.5

Public holidays
Public (statutory) holidays in the Wallchart can be marked visually as crossed-out days. Furthermore, these
days are accounted for in booking operations and calculations. Public holidays are defined using Retain
Security Manager.
In terms of calculations, public holidays are similar to weekends:
· Making a booking that overlaps a public holiday, gives a booking time of one day less than without the
public holiday. For example, if one day is 7.5 hours, then a five day booking overlapping a public holiday
has 30 hours.
· Making a booking that starts or ends on a public holiday, includes the public holiday in the booking time.
For example, if a five day booking starts or ends on a publicholiday, it would have a booking time of 37.5
hours.
Note that Retain does not treat consecutive public holidays (e.g. Christmas) as one holiday. A four day
booking starting on the first of two consecutive holidays would have a booking time of 30 hours, including the
first but excluding the second holiday.
For utilisation and availability calculations, holidays are excluded from standard time. A month that would
normally have 22 working days but has two public holidays uses 20 working days for its calculations.
Booking operations such as moving, copying, using the clipboard, rolling forward, duplicating and splitting
bookings all take into account any public holidays by adjusting the booking details, depending on its settings:
· A five-day fixed-loading booking moved to a date range overlapping a public holiday would adjust the time
to 30 hours to keep its loading of 100%.
· A five-day fixed-time booking moved to a date range overlapping a public holiday would change its loading
to 125% to keep the booking time at 37.5 hours.
· Splitting a booking where the 'split' would occur on a public holiday will have the resulting bookings end on
either side of the holiday.
Though these calculations are what will be most often used for Retain's purposes, it is recommended to
explicitly book public holidays and have overlapping bookings split into one booking ending before and one
starting after the holiday, to ensure the bookings behave as necessary.

5.6

Booking display options
Booking display options overview
Retain provides various display options to allow you to view bookings in different ways. Display options
include:
· booking bar fields - change the fields displayed on the booking bars and in the booking tips.
· booking bar formats - change the depth, layout and font of the booking bars.
· booking tips - display or hide booking tips when moving the mouse over a booking bar and the font of the
booking tips.

44

44

The Wallchart view

Like Wallchart display options, the current booking display options will also be reflected whenever you print
out a Wallchart or calendar page.
All of these booking display options are specific to one particular page in a notebook and cannot be
overridden globally for all pages. If you wish to maintain consistent settings across all pages, then create one
page with the required settings and copy this page to establish the basic settings.

Booking bar fields
You can specify which fields will be displayed:
· within the booking bars themselves and
· within the tips window which pops up over each booking when booking tips are activated.
You can also define the fields separately for the Resource and Job views.
To define booking bar fields:
1. Select 'View-> Booking bars-> Bar fields or Tips fields' from the menu.
Shortcut: Right-click on a booking and select 'Booking bars-> Bar fields... or Tips fields...' from the menu.
2. In the 'Booking Fields' dialog edit the bar or tips fields as required:

3. Click on each tab heading and repeat step 2 for each set of fields as required.
4. Click on the 'OK' button to confirm your changes.
The 'Booking Fields' dialog (see the image above) also allows you to define the various booking bar and
booking tips fields:
Fields can be defined independently under each of the four tab headings:
· Bars (Res) - Fields displayed inside each booking bar when in the Resource view.
· Bars (Job) - Fields displayed inside each booking bar when in the Job view.
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· Tips (Res) - Fields displayed within the pop-up booking bar tips when you move the mouse pointer over a
booking in the Resource view.
· Tips (Job) - Fields displayed within the pop-up booking bar tips when you move the mouse pointer over a
booking in the Job view.
In the 'Booking Fields' dialog:
1. Select a field in the list on the left and click on the 'Add->' button to add it to the displayed fields for the
current tab.
Shortcut: Double-click on the selected item.
Tip 1: You can include information relating to the booked resource and job in your displayed fields. In the
fields list, resource fields are preceded by 'resource.' and job fields by 'job'. Note that adding resource and
job fields may affect the speed of the application.
2. Select a field from the list on the right-hand side and click on the '<-Remove' button to remove it from the
displayed fields for the current tab.
Shortcut: Double-click on the selected item.
3. Select a field from the list on the right-hand side and click on the 'Up' and 'Down' buttons to reposition it
within the displayed fields for the current tab.
4. Click on the tab heading to move between tabs.
5. Click on the 'OK' button when finished.
Related Topics:
Booking bar formats
Booking tips

Booking bar formats
Booking bars can be amended by not only editing the fields and tips but also by defining the depth, layout and
font of booking bars.
Booking bar depth
The depth of a booking bar is its vertical height visible in Wallchart and Calendar pages. You may want to
increase the depth to display more information within each booking bar or to make the depth reflect the
loading of bookings, for example.

To change the depth of booking bars:
1. Select 'View-> Booking bars-> Depth...' from the menu.
Shortcut: Right-click on a booking and select 'Booking Bar-> Depth...' from the menu. There are also
shortcut buttons for individual depth settings, as described below.
2. Set the depth settings as necessary:
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3. Click on the 'OK' button to confirm your changes.
The booking bar depth is set in terms of both:
Standard Depth - the absolute height of the booking bars measured in pixels, and
Relational Depth - the depth relative to the booking's loading.
To select a Standard Depth setting, make sure you are in the 'Depth' tab of the 'Booking bars' dialog and
tick the required checkbox:
· Choose 'Large' to display large booking bars. Shortcut: The 'Large booking bars'

button.

· Choose 'Medium' to display medium booking bars. Shortcut:The 'Medium booking bars'
· Choose 'Small' to display small booking bars. Shortcut: The 'Small booking bars'

button.

button.

You can also define the size manually by amending the value (in pixels) for the appropriate option.
· Choose 'Fit fields' to set the standard depth with respect to the fields displayed within each booking bar.
This option needs to be re-selected if fields are added to the booking bar. Shortcut: The 'Booking bars to fit
fields'

button.

To select a Relational Depth setting, make sure you are in the 'Depth' tab of the 'Booking bars' dialog and
tick the required checkbox:
· Choose the 'Constant' option to display all the booking bars at the same (constant) height.
· Choose the 'Proportional to loading' option to set the depth of booking bars with respect to the loading of
each booking. For example, a booking with 50% loading will be half the height of a booking with 100%
loading. Shortcut: The 'Proportional bookings bars'
more information.

button. See the Proportional bookings section for

Booking bar layout
The layout of booking bars comprises of:
· Bar Stacking - When bookings overlap in time for the same resource or job you can choose this setting so
that they stack vertically, to avoid booking lying on top of each other. Shortcut: The 'Stack booking bars'
button.
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· 3-D Look - plain, embossed or recessed format.
· Show Continuation Arrows - tick the checkbox if you wish to display continuation arrows when bookings
start before or/and finish after the currently visible area.
· Word Wrap - tick the checkbox if you wish the layout to resize according to the text displayed.
To change the layout of booking bars:
1. Select 'View-> Booking bars-> Layout...' from the menu.
Shortcut: Right-click on a booking and select 'Booking Bar-> Layout...' from the menu.
2. Set the layout settings as necessary:

3. Click on the 'OK' button to confirm your changes.
The Bar Stacking options define how bookings will be displayed when they overlap against the same resource
(in the Resource view) or job (in the Job view):
· Choose the 'Separate' option for the bookings to be displayed separately. In cases where bookings
overlap, the overall depth of the resource row will be increased.
· Choose the 'Stacked' option for the overlapping bookings to be stacked (like a deck of cards, for example)
with only one booking fully displayed. This option reduces the screen usage when there are many
overlapping bookings, as will often be the case in the Job view. Shortcut: The 'Bar stacking'

button.

The 3-D Look options change the look of all the booking bars in the current view:
· Choose 'Plain' for no 3-D effect.
· Choose 'Embossed' for the booking bars to appear as if being laid on top of the booking screen.
· Choose 'Recessed' for the booking bars to appear as if being inset into the booking screen.
Booking bar font
The booking bar font is the font used for the text displayed within the booking bars.

To change the font of booking bars:
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1. Select 'View-> Booking bars-> Bar Font...' from the menu.
Shortcut: Right-click on a booking and select 'Booking Bar-> Bar font' from the menu.
2. Using the 'Font' dialog set the new font, as necessary. You can edit the type of font, its style, size and
colour, as well as use of effects such as strikeout or underline:

3. Click on the 'OK' button to confirm your changes. The font you define will be applied to all the booking
bars. You should therefore ensure that it is clearly readable for both on-screen viewing and printable
versions.

Booking bar tips
Booking bar tips are text boxes that appear when you hover over (move the mouse pointer over) a booking.
These text boxes provide additional information on bookings, allowing you to instantly see the details of the
booking:

To turn the booking bar tips on/off, right-click over the booking area (not on a booking) and select 'Booking
Tips' from the menu. Alternatively, select 'File-> Preferences...' from the menu. In the 'Preferences' dialog, go
to the 'General' tab and tick the 'Booking bar tips' checkbox. Repeat the process to return the booking tips
setting to its original state.
If you want to change the fields displayed within the booking tips window, see the Booking bar fields section.
Note: You can also choose whether to show the names of the fields displayed in the booking bar tips using
the 'Show booking tip field names' checkbox in the 'File-> Preferences...-> Bookings' tab.
To change the font of booking bar tips:
1. Select 'View-> Booking bars-> Tip Font...' from the menu.
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Shortcut: Right-click on a booking and select 'Booking Bar-> Tip Font' from the menu.
2. Using the 'Font' dialog set the new font, as necessary. You can edit the type of font, its style, size and
colour, as well as use of effects such as strikeout or underline:

3. Click on the 'OK' button to confirm your changes. The font you define will be applied to all the booking tips.
You should therefore ensure that it is clearly readable for the on-screen viewing of bookings.

5.7

Wallchart fields
You can specify the fields displayed on the left-hand side of the Wallchart in both Resource and Job views.
You can also customise the position and width of these fields allowing you to tailor the Wallchart view to your
requirements. For example, you can display resources and their department or jobs and their office.
In addition, you can add any calculated field to the left-hand side of the Wallchart. Calculated fields are fields
that provide additional information about a resource or job, computed from the underlying data (e.g.
availability or utilisation):
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Note that calculated fields which require a date range (such as availability) will use the date range that is
currently displayed within Wallchart.
To define the fields:
1. Select 'Data-> Fields' from the menu.
Shortcut: The 'Fields'

button.

2. In the 'Setup Wallchart' dialog, 'Fields' tab add or remove the fields for both Resource and Job view (see
instructions below):

3. Click on the 'OK' button to confirm your changes.
You can specify resource fields for the Resource view and job fields for the Job view.
To switch between fields in Resource and Job view, select either 'resource' or 'job' from the 'View'
drop-down list.
Notes:
· The 'Field' panel contains the fields displayed in the current view. The width of each column in this panel
indicates the width of the column as it will be displayed in the Wallchart.
· The current value in the 'Sub Project Field' drop-down list indicates the field that will be used for subsidiary
rows in the Project view.
· The 'Setup Wallchart' dialog may contain different tabs depending on the view of the page you are working
within.
To add a field:
1. Select the field from the drop-down box in the 'Field' panel. You can also use the fast field selection
functionality.
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2. Adjust the width of the column by changing the number under 'Width' or by dragging the line which
separates each field in the top box.
3. Adjust the order in which fields are displayed by clicking on the

and dragging the line up or down.

4. Repeat steps 1 to 3 for each field as required.

To remove a field, click on the
button against the field or move the mouse pointer over a field in the top
box and drag the field outside of the box.
To change the order of the fields, click on the on the left of the field and drag the line up or down. The top
field will be the first field on the left-hand side. Alternatively, move the mouse pointer over the field in the top
box and drag left or right.
To change the column width of a field, change the number under 'Width'. Alternatively, move the mouse
pointer to the right-hand side edge of the field in the top box, so that the mouse pointer changes to a
and
drag the line to increase/decrease the width.
Shortcut: Resize the label column widths directly within the Wallchart view.

To change the field which is displayed in the Project view, click on the 'Sub Project Field' drop-down list
and select the required field.
Note: Select a job field such as 'Job Name' for the Resource view and a resource field such as 'Name' for the
Job view. See the Project view section for more information.
Graphical View Fonts
You can define the fonts for the following items within the Wallchart view:
· expanded records,
· collapsed records,
· sub fields and
· date bar.
To change the display fonts, select 'View-> Fonts' from the menu. Alternatively, click on the 'Fonts'
button. See the Editing fonts section for more information.
Like other display options, fields are specific to each notebook page. To maintain consistent settings
throughout your notebook, create one page with the required settings and then copy that page.
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6
6.1

The Calendar view
The Calendar view overview
The Calendar view in Retain displays the bookings for an individual resource or job in a format similar to a
calendar:

You can set up separate calendar pages in your notebook, if necessary. See the Adding a page section for
more information. Alternatively, you can switch between Wallchart and Calendar views.
To switch a Wallchart page into the Calendar view, select 'View-> Calendar' from the menu.
Shortcut: The 'Calendar view'

button.

To switch back to the Wallchart view, select 'View-> Wallchart' from the menu.
Shortcut: The 'Wallchart view'

button.

Related Topics:
Rotating the calendar
Changing the calendar date scale
Moving between calendar records
Navigating within the current record
Calendar display options
Making bookings in calendar view
Working with notebook pages
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Rotating the Calendar

6.2

The Calendar page can be displayed in two basic views:
· Resource view - displays one resource per screen. Bookings represent jobs allocated against the
resource.
· Job view - displays one job per screen. Bookings represent resources booked on the displayed job.
To switch between these two views, select 'View-> Rotate view' from the menu.
Shortcuts: The 'Rotate view'
button or press CTRL+R. Alternatively, right-click anywhere over the
booking grid and select either 'Job view' or 'Resource view' as required.
Note: If you click on a booking before switching the view, the axis on which the view is rotated will be fixed, so
that the selected booking will be displayed as part of the rotated view. For example, if you are in Resource
View and click on a job, when you switch to Job View, all the bookings for that job will be displayed.

Changing the Calendar date scale

6.3

The Calendar page can be displayed using a wide range of date scales. You can work in units as small as
fractions of an hour or as large as months or even years.
You can amend the date scale at any time. This does not affect any of the underlying data and you can switch
between the date scales as often as you like.
To select one of the standard date scales:
· Select 'View-> Zoom' from the menu and then choose a view.
· Select one of the pre-defined date scale buttons (Year, Month, Week, Day, Hour).
Shortcuts: The date scale

buttons.

In the Calendar view the standard date scales are displayed as follows:
·
·
·
·
·

Year Year per row. Each cell represents 1 month.
Month Month per row. Each cell represents 1 day.
Week Week per row. Each cell represents 1 day.
Day Day per row. Each cell represents 1 hour.
Hour Hour per row. Each cell represents 10 minutes.

You might want to use the 'year' view for long-term and the 'week' or 'day' views for short-term planning.
You can also customise the settings associated with the standard date ranges

.
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Moving between Calendar records
In the Calendar view only one resource (in Resource view) or job (in Job view) is displayed on screen at a
time. The currently selected resource or job name is displayed in the status bar at the bottom of the screen.
To move to the next record, right-click over the booking area and select 'Next record' from the menu.
Shortcuts: The 'Next record'

button or press CTRL+SHIFT+N.

To move to the previous record, right-click over the booking area and choose 'Previous record' from the
menu.
Shortcuts: The 'Previous record'

button or press CTRL+SHIFT+P.

To move to a particular record:
1. Right-click over the booking area and choose 'Select record' from the menu.
Shortcuts: The 'Go to record'
are looking for.

button. Alternatively, start typing the first letter(s) of the resource/job you

2. Select the necessary record in the 'Select Record' dialog.
3. Click on the 'OK' button to move to it.

6.4

Navigating within the current record
Use the following features to navigate within the current record in the Calendar view:
· Cursor keys. Once you have clicked on the calendar grid, you can use the cursor keys to move between
the cells on the grid.
· The date scale on the right-hand side of the calendar grid. Click on the transparent rectangle and drag it up
or down, as necessary.
· The single and double arrows either side of this date scale. Click on the up arrows to move back in time or
the down arrows to move forward in time.
· Changing the date scales. Increasing the date range displays more information on the grid.

6.5

Calendar display options
Most of the display options in the Calendar view are the same as those for Wallchart pages. The only
difference is that the Project view is not available in the Calendar view.
Graphical View Fonts
You can define the following fonts in the Calendar view:
· expanded records,
· collapsed records,
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· sub fields and
· date bar

To change the display fonts, select 'View-> Fonts' from the menu. Alternatively, click on the 'Fonts'
button. See the Editing fonts section for more information.

6.6

Making bookings in Calendar view
You can make bookings in Calendar view in the same way as in Wallchart view.
However, the following restrictions apply when making bookings in Calendar view:
· You can only mark an area for a single resource when in Resource view or a single job in Job view;
· You cannot move or copy the bookings graphically and you cannot use the clipboard.
You may therefore find it easier to make all your bookings within the Wallchart and use the Calendar for
viewing purposes only.
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7

Resources, jobs and other entities
General principles

7.1

The central concept of Retain is managing resources in order to perform jobs. The exact meaning of the
terms 'resources' and 'jobs' varies from organisation to organisation but the process of allocating resources to
jobs in the form of 'bookings' is the same in all cases.
To assist the planning process, Retain offers several levels of classifying bookings in terms of resources,
jobs,components and booking types. The time taken to capture and maintain this information should be
balanced with the benefit to the planning process.
Retain is primarily a resource management (as opposed to a project management) tool. It is therefore not
particularly concerned with the individual activities performed during each job. However, componentsand
booking types can be used to indicate the nature of a job.
Furthermore, Retain allows you to maintain the information stored on these entities. Users are encouraged to
record descriptive information, especially resources and jobs. The data can be subsequently updated on a
continuing basis.
Before making any bookings, it is advisable to first of all determine the level of detail required in order to
maximise the effectiveness of the planning process. Secondly, establish the initial setup. In order to make a
booking, at least one resource and one job is required.
Notes:
·
·

You may want to consider transferring data automatically into Retain from other systems as
part of this set-up exercise.
Depending on your company's setup, you might not be able to see all of the entities mentioned
above or they might be named differently.

Related Topics:
Attachments
Copy checkboxes
Numeric formatting
Linked field operators
Mandatory and optional fields
Editing multiple records
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Attachments
You can attach and save files of any format to resources, jobs, types and bookings:

If you want to add attachments, go to the 'Attachments' tab within the appropriate edit dialog. For example, to
add attachments to a job, go to the 'Edit Job' dialog. To add/modify booking attachments, use the 'Booking'
dialog.
To add a file, click on the
and press the 'OK' button.

button. Navigate to the location where the required file is, click on it

The name of the attached file along with the size, the date it was last updated and the name of the user who
updated it will be displayed (see the image above).
Note that you will not be able to upload file(s) that exceed the server threshold.
To view the attached file, you can open it by selecting it and clicking on the
button.
Alternatively, simply double-click on it. The file will be automatically be opened in the appropriate application.
If any changes are made and saved to the file, Retain will detect the changes and ask you if you wish to save
the amended file to the database. This allows you to quickly edit the file, without the need of downloading it,
saving the changes, deleting the existing attachment and re-uploading the amended one.
To download the file to your computer, click on the
To delete the file from the record, click on the
database and can not be undone.

button.
button. Note that this removes the file from the

If you have any files attached already, you can perform all of the above actions (Open, Download, Delete and
Upload) by right-clicking on a file and selecting the necessary option from the following menu:
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Copy checkboxes
You can copy and paste any number of the field entries between dialogs when creating new (or editing
existing) records for resources, jobs, booking types and bookings. This functionality allows you to speed up
the process of creating new or editing existing records with common attributes (e.g. resources in the same
office and department).
Note that for bookings you can only copy the values and paste them to clipboard but you can not paste them
when creating new or editing existing bookings.
Once you have entered the necessary data for one Resource or Job, click on the
button next to 'Copy
Checkboxes' on the top right corner. A list of checkboxes will be displayed, each of which represents whether
the value of that field will be copied when you click on the 'Copy Fields' button:

You can copy all the values from all fields by ticking the checkbox next to 'All'. Alternatively, select the
required fields that you would like to copy.
For example, if you want to create a number of new resources working in IT department in the London office,
tick the 'Office' and 'Department' checkboxes and click on the 'Copy Fields' button:
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When you now re-open the 'Add Resource' dialog to create another resource record (by clicking on 'Add
Again' for example), clicking on the 'Paste fields' button will paste the values you have just copied into the
appropriate fields:

You can then enter all the other details as necessary.
The copied fields can also be pasted to external documents, such as Notepad:
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Note: The order in which these pasted fields will be displayed in an external file is defined within Retain
Security Manager.

Numeric formatting
Note: This functionality is disabled by default. Contact your Retain administrator if you wish to take advantage
of this feature.
You can customise the display format of numeric data (e.g. the number of decimal places) using the 'Numeric
Data Formatting' dialog.
Select 'View-> Numeric Data Formatting...' from the menu:

Using this dialog you can set the numeric formatting for the following four categories:
Number - fields displaying whole numeric values (no decimal places).
Floating Number - fields displaying numeric values with decimal places.
Percentage - fields displaying numeric values as percentage (with a '%' sign at the end).
Currency - fields displaying numeric values as currency.
The options for each category are:
· Decimal Places - select the number of decimal places you wish to be displayed from a drop-down menu.
Note that if you have a different number of decimal places specified in Security Manager, that value will
override the number specified here.
· Decimal Symbol - enter a symbol to separate decimal places.
· Thousands Separator - enter a symbol that will separate thousands in the numeric value. You can untick
the ckeckbox if you do not want to have a separator.
· Negative Numbers - If you want negative numbers to be displayed, tick this checkbox. And select the colour
the negative number will appear in (see the image bellow).
· Symbol (for Currency category only) - Select from a drop-down list the symbol you wish to be displayed in
the Currency fields. You can also select the symbol to appear before or after the number, by selecting
Prefix or Suffix option, respectively.
For each category of numeric data field, you are presented with a Sample of how your settings for the field will
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appear in Retain:

Clicking on the 'Negative' button will automatically convert the value to a negative one:

Click on the 'Positive' button to revert this change.
The negative numbers are displayed in red because this is specified in the Negative Numbers setting. You
can change the colour to any other by double-clicking on the Negative Numbers colour box and selecting the
required colour from the pop-up dialog:

Click on the 'OK' button to save changes. You can set up different colours for each numeric data category, if
necessary.

Linked field operators
Linked fields are fields that allow you to select the required value from the records of another table in the
database. These fields are graphically presented with a

button.

To perform a selection on a value, you can first select the required operator. Right-click on a linked field to
see the list of available operators:

The list of available operators will depend on your setup. The default operator is set to 'Like'. Using this
operator will return values similar to what you have typed in.
Note: Your operator selection will be remembered after the application is restarted. If nothing shows up in the
drop-down menu, check the operator in use is the one you would expect.
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Mandatory and optional fields
The fields for a resource or job can be classified as mandatory or optional, making it easier to distinguish the
more important fields that always have to be filled in:

You can also hide the mandatory or optional group of fields by clicking on the

button.

Editing multiple records
You can edit multiple records in one go by modifying the value of a certain field. For example, set the 'Office'
to 'London' for a number of resources.
To edit multiple records:
1. When in Wallchart view, select the records you want to update.
2. Choose 'Actions-> Modify selected records' from the menu or right-click on the record lists and select the
'Update selected records' option.
3. Select the field you want to update (e.g. 'Office') and click on the 'OK' button.
4. Enter the required value (e.g. 'London') and click on the 'OK' button. In the pop-up window, displaying the
number of records that are going to be updated, click on 'Yes' to confirm or 'No' to ignore your changes.

7.2

Resources
What are resources?
Retain uses the term 'resources' as a general description of people or entities that can be applied to the
process of completing a job.
In many organisations the term 'resources' simply refers to staff. However, since you can also use Retain to
plan other types of resources such as machinery or training rooms, any item with a finite capacity that goes
into the performance of a job can be considered a resource.
Related Topics:
Adding resources
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Editing resource details
Deleting resourcesDiary

Adding resources
To add new resources:
1. Make sure that you are in 'Edit' mode.
2. Select 'Actions-> Modify records-> Resource' from the menu.
Shortcuts: The 'Modify resources'
Resources'.

button or right-click on a resource name and select 'Modify

3. Click on the 'New' button.
4. In the 'Add Resource' dialog enter a unique name of the new resource and fill in other details, as required
(see the image below).
5. Click on the 'Add' button to add the resource and return to the 'Modify resources' dialog.
6. To add multiple resources, click 'Add Again' and repeat steps 4 and 5 to add more resources, if necessary.
7. Click on the 'Close' button when finished.
The 'Add Resource' dialog allows you to record various details about each resource (this dialog may be
customised to suit the requirements of your organisation). Make sure that you follow any conventions
established by your organisation:

Note that if you need to create a number of resources that will share certain value(s), you can use the copy
checkboxes functionality.
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Editing resource details
To edit the details associated with a resource:
1. Make sure that you are in 'Edit' mode.
2. Select 'Actions-> Modify record-> Resource...' from the menu.
Shortcuts: The 'Modify resources'
button or right-click over the Resource list on the left-hand side of
the screen (in Resource View) and select 'Modify Resources' from the context menu:

3. In the 'Modify Resource' dialog, select a resource and then click on 'Edit' to edit its details.
Shortcut: Double-click on a resource to edit its details directly.
4. In the 'Edit Resource' dialog, edit the resource record details as required. Then click on the 'OK' to confirm
or 'Cancel' to ignore your changes.
5. Repeat steps 3 and 4 to edit further resources as required.
6. Click on the 'Close' button to close the 'Modify Resources' dialog.
To update multiple resources with one value:
1. Select the resources you want to update in the Resource view. See the Making Selections section for more
information.
Tip: For a quick manual selection, highlight multiple resources by clicking and dragging the mouse over
them. Right-click and choose 'Select marked records'. After updating, select 'Clear entire selection' to
display all records.
2. Select 'Actions-> Modify selected records' from the menu.
3. In the 'Update selected resources' dialog, select the field you want to update and click on the 'OK' button.
4. Enter the required value.
You will be asked to confirm the number of records to be updated.
The options available in the 'Modify Resources' dialog are:
· Edit - Change details of a selected record;
· New - Add a new resource;
· Delete - Delete the selected resource.
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Deleting resources
You will want to delete resources when they leave your organisation or are no longer part of your Retain
database for planning purposes.
To delete a resource:
1. Make sure that you are in 'Edit' mode.
2. Select 'Actions-> Modify Record-> 'Resource...' from the menu.
Shortcuts: The 'Modify resources'
Resources'.

button or right-click on a resource name and select 'Modify

3. In the 'Modify Resources' dialog, select a resource and then click on 'Delete' to delete the resource.
4. Click on 'OK' to confirm or 'Cancel' to ignore your changes.
5. Repeat steps 3 and 4 to delete more resources, if necessary.
6. Click on the 'Close' button when finished.
Note: When you delete a resource, all the bookings against that resource will also be deleted. Do not delete
resources unless you are sure that you will not need to include the related bookings in reports or display them
for historical purposes.
As an alternative you could assign a leaving date to a resource and/or assign the resource to a group called
'Left', for example.

Diary
A diary is a set of working days, weeks and years. It will be set up by the administrator and will depend on the
needs of your organisation.
To define the start of the diary, open the 'Edit Resource' dialog for the necessary resource and enter the
date he/she joined the company in the 'Start Date' field:

When the person leaves the company, end their diary by changing the value in the 'End Date' field.
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7.3

Jobs
What are jobs?
Retain uses the term 'jobs' as a general description of any project, product or assignment being planned.
What constitutes a job in your organisation depends on the nature of your business and what you consider to
be the 'unit' level of your planning in Retain. Some organisations may set up a separate job for each individual
project, while others may group together projects under a single 'umbrella' job.
Since every booking in Retain must be made against a job, jobs should also be created for non-project
activities such as vacation, sick leave or, in a manufacturing context, machine down-time.
You can group jobs for viewing or reporting purposes by a particular value that they share. For example, you
can use the 'Industry' field to group jobs within the same industry.
Related Topics:
Adding jobs
Editing job details
Deleting jobs

Adding jobs
To add new jobs:
1. Make sure that you are in 'Edit' mode.
2. Select 'Actions-> Modify Record-> Job...' from the menu.
Shortcuts: The 'Modify Jobs'

button or right-click on a job name and select 'Modify Jobs'.

3. Click on the 'New' button.
4. In the 'Add Job' dialog enter a unique name for the new job and fill in other details, as required (see the
image below).
5. Click on the 'Add' button to add the new job and return to the 'Modify jobs' dialog.
6. Click on the 'Add Again' button and repeat steps 4 and 5 to add more jobs, if necessary.
7. Click on the 'Close' button when finished.
The 'Add Job' dialog allows you to record various details about each job (this dialog may be customised to suit
the requirements of your organisation). Make sure that you follow any conventions established by your
organisation:
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Note that If you need to create a number of jobs that will share certain value(s), you can use the copy
checkboxes functionality.

Editing job details
To edit the details associated with a job:
1. Make sure that you are in 'Edit' mode.
2. Select 'Actions-> Modify record-> Job...' from the menu.
Shortcuts: The 'Modify Jobs'
button or right-click over the job list on the left-hand side of the screen (in
Job View) and select 'Modify Jobs' from the context menu.
3. In the 'Modify Job' dialog, select a job and then click on 'Edit' to edit its details.
Shortcut: While in Jobs view, double-click on a job to edit its details directly.
4. In the 'Edit Job' dialog, edit the job record details as required. Click on 'OK' to confirm or 'Cancel' to ignore
your changes.
5. Repeat steps 3 and 4 to edit further jobs, as necessary.
6. Click on the 'Close' button to close the 'Modify Job' dialog.
To update multiple jobs with one value:
1. Select the jobs you want to update in the Job view. See the Making Selections section for more
information.
2. Select 'Actions-> Modify selected records' from the menu.
3. In the 'Update selected jobs' dialog, select the field you want to update and click on the 'OK' button.
4. Enter the required value. A pop-up box will appear showing the number of records to be updated.
The options available in the 'Modify Jobs' dialog are:
· Edit - Change details of a selected job;
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· New - Add a new job;
· Delete - Delete the selected job.

Deleting jobs
You will want to delete jobs from time to time, when they are no longer part of your Retain planning cycle.
To delete a job:
1. Make sure that you are in 'Edit' mode.
2. Select 'Actions-> Modify Record-> Job...' from the menu.
Shortcuts: The 'Modify Jobs'

button or right-click on a job name and select 'Modify Jobs'.

3. In the 'Modify Jobs' dialog, select a job and then click on 'Delete' to delete the job.
4. Click on the 'OK' button to confirm or 'Cancel' to ignore your changes.
5. Repeat steps 3 and 4 to delete more jobs, if necessary.
6. Click on the 'Close' button when finished.
Note: When you delete a job, all the bookings against that job will also be deleted. Do not delete jobs unless
you are sure that you will not need to include the bookings in reports or display them for historical purposes.

7.4

Components
What are components?
In Retain, 'components' are sub-jobs, providing information regarding the nature of each booking made
against a job. Components provide an element of project planning within Retain, since you can assign a
component for each booking and analyse the job into its component parts for reporting purposes.
Components take the form of a list of descriptive names, available for selection each time you make a
booking. Components are usually defined in general terms applicable to most jobs, such as 'planning',
'fieldwork' and 'reporting'; although you can have components relating to specific types of job such as 'branch
visit' or 'security review'. The level at which you define components should correspond to that at which you
make bookings in Retain. For instance, if your planning in Retain takes the form of bookings of two or more
weeks each, your components should not represent the half-day elements within each booking.
Example:
JOB = Arrow Treasury
ASSIGNMENT = Arrow Treasury Audit 2009
Booking COMPONENT = Planning
Related Topics:
Job-specific components
Adding components
Editing component names
Deleting components
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Job-specific components
In addition to the general/shared component list you can also set up job-specific component lists. Job-specific
components will appear in the list of available components only for related job(s).
To assign job-specific components for a job:
1. If you want to use an existing component, ensure that it is job-specific. Alternatively, create a job-specific
component. You can now assign it to the selected job(s).
2. While in Jobs view, double click on the required job.
Alternatively, select 'Actions-> Modify record-> Job...' from the menu. Choose the required job from the list
and click on 'Edit'.
3. In the ‘Edit Job’ dialog, find the 'Job Specific Components' field and click on the

button:

4. Select the job-specific component you have edited or created and click on 'OK' to confirm your changes.
When making a booking against this job, you will see both the general list and the job-specific component(s)
you have just specified.
To see all the components that are specific to this job, click on the
from the job, click on the

button. To remove a component

button and select the component you wish to remove.

Note that if this field is left blank, the general component list will be used when creating bookings.
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Adding components
To add new components:
1. Make sure that you are in 'Edit' mode.
2. Select 'Actions-> Modify Record-> Component...' from the menu.
Shortcut: The 'Modify Component'

button.

3. Click on the 'New' button.
4. In the 'Add Component' dialog enter a unique name for the new component and fill in other details, as
required:

To create a job-specific component, tick the 'Is Job Specific?' checkbox. This component will not be displayed
in the general/shared component list and will be available when booking against that specified job(s) only.
5. Click on the 'Add' button to add the new component and return to the 'Modify Component' dialog.
6. Click on the 'Add Again' button and repeat steps 4 and 5 to add more components, if necessary.
7. Click on the 'Close' button when finished.
Note that if you need to create a number of components that will share certain value(s), you can use the copy
checkboxes functionality.
Depending on your access rights, you can also create general or job-specific components using the 'Booking'
dialog:

Editing component details
To edit the details of a component:
1. Make sure that you are in 'Edit' mode.
2. Select 'Actions-> Modify Record-> Component...' from the menu.
Shortcut: The 'Modify Component'

button.

3. In the 'Modify Components' dialog, select a component and then click on 'Edit' to edit its name.
4. In the 'Modify Components' dialog, edit the name as required and click on 'OK' to confirm or 'Cancel' to
ignore your changes.
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5. Repeat steps 3 and 4 to edit the names of other components, if necessary.
6. Click on the 'Close' button when finished.
Note: Amending the details of a component does not update the existing bookings with that component. For
the existing bookings to reflect the changes, you have to edit each booking separately.
To make a component job-specific, simply tick the 'Is job specific?' checkbox and confirm your changes.
This component will not be displayed in the general/shared component list when making a booking.
The options available in the 'Modify Components' dialog are:
· Edit - Change the name of a selected component;
· New - Add a new component;
· Delete - Delete the selected component.

Deleting components
To delete a component:
1. Make sure that you are in 'Edit' mode.
2. Select 'Actions-> Modify Records-> Component' from the menu.
Shortcut: The 'Modify Component '

button.

3. In the 'Modify Components' dialog, select the existing component and then click on 'Delete' to delete the
component.
4. Click on 'OK' to confirm or 'Cancel' to ignore your changes.
5. Repeat steps 3 and 4 to delete and 4 to delete more components, if necessary.
6. Click on the 'Close' button when finished.
Note: When you delete a component, all of the associated jobs and bookings will be affected: the component
will be removed from all of these records.

7.5

Booking types
What are booking types?
In Retain, 'booking types' are used as an additional way of classifying bookings. For example, you might want
to use the booking type to describe the nature of the job. You could therefore have 'chargeable',
'non-chargeable', 'training' and other booking types.
JOB = Arrow Treasury
ASSIGNMENT = Arrow Treasury Audit 2009
Booking COMPONENT = Planning
TYPE = Chargeable
Booking types take the form of a list of descriptive names, available for selection each time you make a
booking.
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Related Topics:
Adding booking types
Editing booking type name
Deleting booking types

Adding booking types
To add new booking type names:
1. Make sure that you are in 'Edit' mode.
2. Select 'Action' -> 'Modify Record' -> 'Type...' option from the menu.
3. In the 'Modify Booking Types' dialog, click on the 'New' button.
4. In the 'Add Booking Type' dialog enter a unique name for the new booking type and fill in other
details, as required:

5. Click on the 'Add' button to add the new type name or click on the 'Add Again' button to add
more booking type names, if necessary.
6. Click on the 'Close' button when finished.
Note that if you need to create a number of booking types that will share certain value(s), you can use the
copy checkboxes functionality.

Editing booking type names
To edit the name of a booking type:
1. Make sure that you are in 'Edit' mode.
2. Select 'Data-> Modify Record-> Type...' from the menu.
3. In the 'Modify Booking Types' dialog, click on the

button and select a type name.

4. Click on the 'Edit' button to bring up the 'Edit Booking Type' dialog.
5. In the 'Edit Booking Type' dialog, modify the name of a booking type as required.
6. Click on 'OK' to confirm or 'Cancel' to ignore your changes.
7. Repeat steps 3 to 6 to edit the names of other booking types, if necessary.
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8. Click on the 'Close' button when finished.
Note: Amending the name of a booking type will update all the existing bookings with the new name.
The options available in the 'Modify Booking Types' dialog are:
· Edit - Change details of a selected type;
· New - Add a new type;
· Delete - Delete the selected type.

Deleting booking types
To delete a booking type:
1. Make sure that you are in 'Edit' mode.
2. Select 'Data-> Modify Record-> Type...' option from the menu.
3. In the 'Modify Types' dialog, click on the

button and select a type name.

4. Click on the 'Delete' button to delete the type name.
5. Click 'OK' to confirm or 'Cancel' to ignore your changes.
6. Repeat steps 3 to 5 to delete more type names, if necessary.
7. Click on the 'Close' button when finished.
Note: When you delete a booking type, all of the associated jobs and bookings will be affected: the type will
be removed from all of these records.
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8
8.1

Sorting and selecting
Sorting and selecting overview
One of the most powerful features of Retain is the ability to sort and select (i.e. filter) your data in a number of
ways, providing powerful views of the data. You can, for example:
· display only those resources that are available for a specified date range;
· display only those jobs that are assigned to a particular project manager;
· sort the view in the descending order of resources' grades;
· produce reports by group or division, sub-totalled by manager and so on.
Sorting
You can sort using any fields in your Retain database. You can sort the Resource view by any resource field
and the Job view by any job field. Resources can be sorted independently from jobs and each notebook page
can be sorted differently. You can therefore create a number of different views of your data by simply setting
up a different sort order in each page.
Selecting
There are a number of ways of selecting (i.e. filtering) the records that you want to be displayed. You can:
· define the necessary selection criteria,
· collapse records from the display,
· select marked records,
· use special selections with date ranges,
· use the quick selection functionality (see below)
In both Resource and Job views, you can perform a quick selection on a necessary resource or job,
respectively. Simply select the required record from the 'Job Name/Resource Name' drop-down list:

You can also change this filter to any resource/job field by making it the first sort field in the 'Setup Wallchart'
dialog.
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To remove the selection, select 'All' from the drop-down list.
Note that you can sort and select using any fields from your Retain database. If your organisation has
customised the standard fields, these will also be available for sort and selection purposes.

8.2

Changing the sort order
You can sort the records in each notebook page based on any field, depending on the underlying view.
For example, you can sort the Resource view by any resource field and the Job view by any job field. You can
also sort resources independently from jobs.
Furthermore, each notebook page can be sorted differently. This means that you can create a number of
different views of the booking information simply by setting a different sort order in each page.
When making bookings against multiple resources, sorting can be used to create logical groups of resources.
To sort the active notebook page:
1. Select 'Data-> Sort' from the menu.
Shortcut: The 'Sort'

button.

2. In the 'Sort' dialog, specify the necessary sort criteria by selecting a sort field from the drop-down list (see
the image below).
3. Click on the 'OK' button to confirm your changes.
The 'Sort' tab of the 'Setup Wallchart' dialog allows you to specify the sort order applying to both the Resource
and Job view for the active page:

If there is more than one field in the list, the view will be sorted by the first then the second field and so on.
The first sort field will also determine the contents of the quick selection drop-down list.
To switch between Resource and Job view, select either 'resource' or 'job' from the 'View' drop-down list.
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You can also sort the order in which bookings are displayed in each view: click on the 'booking' tab and select
the field to sort by from the drop-down list.
To add an item to the sort order criteria:
1. Select a field from the drop-down list.
2. Choose 'Ascending' or 'Descending' as the sort order for the selected field.
3. Repeat steps 1 and 2 to add further sort items, as necessary.

To remove an item from the current sort criteria, click on the

button.

You also need to consider the sequence of items in the sort criteria carefully. For example, sorting by
resource grade and then name should produce a meaningful result, but sorting by resource name and then
grade may not.
To amend the sequence of items in the current sort criteria, click on the black dot and drag the line up or
down.
Further sort options are available when working with Report pages. See the Report sort orders and subtotals
section for more information.

8.3

Collapsing records
In Wallchart pages, you can collapse one or more rows in the Wallchart grid. Collapsing the records greys
them out and hides their associated bookings. Collapsed records appear like this:
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To collapse a resource (or job) record, click on the button on the left of the record name. The button will
change to the button to indicate that the record is collapsed.
To collapse all the resource (or job) records at once, select 'View-> Close all records' from the menu.
Shortcut: Right-click on the list of records and select 'Close all records' from the menu.
To expand a resource (or job) record which has been previously collapsed, click on the button on the
left of the record name. The button will change to the button to indicate that the record is now expanded.
To expand all the resource (or job) records at once, select 'View-> Open all records' from the menu.
Shortcut: Right-click on the list of records and choose 'Open all records' from the menu.

8.4

Selecting marked records
In Wallchart pages you can mark one or more resources or jobs and then filter the view to show only the
marked records. To do this:
1. Select the first record from the resource or job list. Holding the CTRL key, select more records.
Alternatively, use 'click and drag' functionality to select or deselect the required records.
2. Right-click on the list of highlighted records and choose 'Select marked records' from the menu:
Shortcut: The 'Select marked records'

button.

Marked records will be displayed and all other records will be excluded from the display.
To clear the marked records selection, select 'Data-> Clear selection' from the menu.
Shortcuts: The 'Clear selection'
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selection'.

8.5

Defining selection criteria
Selection criteria overview
You can perform quick searches on the current view by either Selecting marked records or Special selections.
To perform other types of searches you will need to define selection criteria.
To define selection criteria for the active notebook page:
1. Select 'Data-> Selection' from the menu.
Shortcuts: The 'Selection'
button. Alternatively, right-click on the record list on the left-hand side of the
Wallchart and choose 'Selection...'.
2. In the 'Selection' dialog specify the selection criteria as necessary.
3. Click on the 'OK' button to confirm your changes. The Wallchart view will refresh listing the resources that
match the selection criteria.
You will also see the 'Selection' icon below the toolbar indicating that a selection is applied to the current view.
Hover your mouse over the icon and the details of the selection will be displayed:

Related Topics:
The selection dialog
Selection operators and conditionsSelection on date fields
Booking selection filters
Fast field selection
Cross-referencing Resource and Job view selections
Locking selection criteria
Removing selection criteria
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The selection dialog
The 'Selection' tab within the 'Setup Wallchart' dialog allows you to specify the selection criteria that applies to
both the Resource and Job views for the currently active page.
You can also cross reference your selections between Resource and Job views and include booking fields in
your selection criteria:
Select 'Data-> Selection...' from the menu:

The current selection criteria are displayed in the middle of the screen.
Note: Consider the sequence of items in the selection criteria as the order of items can determine the
meaning of the selection.
To switch between Resource and Job view, select either 'resource' or 'job' from the 'View' drop-down list.
You can also apply selections to bookings.
To add an item to the selection criteria:
1. Choose an 'Operation' setting to apply to this item from the drop-down list.
2. Select a field in the 'Field' column.
3. Choose a 'Condition' followed by a value in the pop-up box.
4. Click on the 'OK' button within the pop-up box and the 'OK' button within the main dialog. The Wallchart
view will refresh the list of resources that match the selection criteria.
Repeat the steps 1 to 3 to add further selection criteria, if necessary.

To remove an item from the current selection criteria, click on the

button against the relevant row.

To amend the sequence of items in the current selection criteria, click on the
up or down.
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You can also lock the selections, allowing you to clear selections up to the last locked selection. Tick the
checkbox under the

icon against the row you would like to lock.

Related Topics:
Selection operators and conditions
Selection on date fields
Removing selection filters
Selection operators and conditions
Selection filters in Retain are derived from the selection operations and conditions applied to one or more of
the underlying database fields. For example, the selection criteria that you would use to display all resources
of grade 2 will consist of the following elements:
Operation
AND

Selection Field
resource.Grade

Condition
=

Condition Value
2

In most cases your searches will probably be very simple, like the one above.
However, Retain allows you to build up complex selection criteria using the above elements. For complex
criteria it is important to understand the usage of these elements in Retain.
If you make a mistake or change your mind, you can start again without closing the dialog by clicking on the
'Clear selection' button.
To clear the selection within the Wallchart, right-click on the resource list and select 'Special Selections->
Clear...' from the menu.

Operations
Each item in your selection criteria must use one of these three operations:
· And - Includes all records which satisfy the expression. This is the basic selection operator to which you
can add other expressions. For instance, if you wish to view resources with the grades equal to Manager,
then the expression would be 'AND Resource.Grade = Manager'.
· Subtract - Excludes all records which satisfy the expression. For example, 'Subtract Resource.Grade =
Manager' will show all resources excluding the ones with the grade equal to Manager.
· Or - Includes all records that satisfy any of the values. For instance, if you want to display either resources
of grade 2 or grade 3:
Operation
AND
OR

Selection Field
resource.Grade
resource.Grade

Condition
=
=

Condition Value
2
3

Other examples:
Display only resources of grade 2 and in the 'London' department:
Operation
AND
AND

Selection Field
Condition
resource.Grade
=
resource.Department

Condition Value
2
=
London

Display resources of grade 2, excluding those in the 'London' department:

81

Sorting and selecting

Operation
AND
SUB

Selection Field
Condition
resource.Grade
=
resource.Department

Condition Value
2
=
London

Conditions
Each value in your selection criteria will use one of the following conditions:
· Equals

The value in the database field equals the condition value.

· Greater than or equal to

The value in the database field is greater than or equal to the condition value.

· Contains

The value in the database field contains the condition value (the text string).

· Less than

The value in the database field is less than the condition value.

· is Blank

There is no value in the database field.

· is One Of
multi-value fields).

The value in the database field is one of the condition values (used with

Examples:
Display only those resources that are of grade '2' or above:
Operation
AND

Selection Field
resource.Grade

Condition
>=

Condition Value
2

Display only those jobs that contain 'ABC' in their name':
Operation
AND
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Selection Field
job.Name

Condition
Contains

Condition Value
ABC
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Selection on date fields
When selecting on date fields, you can either select the necessary date from the pop-up calendar or enter the
date manually:

For example, if you want to create a selection on resources that have left on or after the 16th of March 2009,
choose the appropriate condition and select the date using the calendar (or enter it in the text box).
If you plan to use the selection in the future, tick the ‘Relative to today’ checkbox. This will adjust the
selection results according to today's date every time the selection is performed. That is, if we use the above
selection two months later, the result will also include the people who have left within that period.

Booking selection filters
You can restrict the bookings that are displayed on the Wallchart in two ways:
· By specifying selection criteria.
· By setting up cross-references between your resource and/or job selection criteria.
Select 'Data-> Selection...' from the menu and click on the 'booking' tab within the 'Setup Wallchart' dialog:
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The booking selection hides bookings that do not meet the selection criteria but does not restrict the rows
displayed within Wallchart. For this reason, booking selection filters operate differently to resource and job
selection filters.
For example:
IF
You select resources with grade = 1
You select resources with grade = 1
and cross-refer to the Job view
Select bookings with resgrade = 1

THEN
The Resource view only displays rows for grade 1 resources. All the
bookings are displayed for these resources.
As above but in the Job view only bookings with respect to grade 1
resources are displayed.
All the resources are displayed in the Resource view. Only bookings
with resgrade 1 are displayed in either Resource or Job view.

You can also add a sort order within the 'Sort Order' panel. This will determine how the results of the
selection will be displayed within the Wallchart.
The following checkboxes provide additional settings that can be applied:
Filter Res /Jobs - Takes out resources (in Resource view) or jobs (in Job view) for which there are no
bookings.
Show All Bookings - For the displayed Jobs or Resources, shows all the bookings.
Furthermore, since in Retain you can set details such as resource grade or job priority on a booking by
booking basis, the information stored in booking level fields such as 'resgrade' is not necessarily the same as
in the underlying resources or jobs. From the above example, information in 'resgrade' in the booking table
need not be the same as the current 'grade' of the resource.
To clear the selection or the sort order, click on the 'Clear Selection' or 'Clear Sort Order' button,
respectively.
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Fast field selection
The fast field selection functionality is available within the field list pop-ups in the Fields, Sort and Selection
tabs within the 'Setup Wallchart' dialog.
This allows you to find the fields you want to use much faster.
When you start typing in the name of the required field, the closest match will be automatically highlighted in
the list.
For example, if your required field was 'Mobile Number', typing in 'mob' will automatically display 'Mobile
Number' in the drop-down list:

Cross-reference view selections
Using the basic selection criteria you can filter Resource and Job views independently. For example, you can
filter the Resource view to display only resources of grade 1 and the Job view to display jobs where the
manager name is 'Smith'.
The 'Selection' tab also allows you to cross-reference your selection filters. In this way you can apply your
resource selection criteria to the bookings displayed in the Job view and vice-versa.
For example, you can display resources of grade 1 in the Resource view and the bookings relating to grade 1
resources when you rotate the screen to the Job view. Likewise, you can display jobs belonging to manager
'Smith' in the Job view and the bookings relating to manager 'Smith' jobs when you rotate the screen to the
Resource view.
To apply resource selection criteria to the Job view:
1. Switch to the 'Resource' view in the 'Setup Wallchart' dialog (using the drop-down menu at the top right
corner).
2. Define your resource selection criteria in the usual way within the 'Selection' tab.
3. Tick the 'Use selection in Job view' checkbox.
To apply job selection criteria to the Resource view:
1. Switch to the 'Job' view in the 'Setup Wallchart' dialog (using the drop-down menu at the top right corner).

85

Sorting and selecting

2. Define your job selection criteria in the usual way within the 'Selection' tab.
3. Tick the 'Use selection in Resource view' checkbox.
Note: Reset these cross-reference checkboxes once you have finished filtering.

Locking selection criteria
You can lock selection criteria at a particular level so that it is always applied, even after clearing (the
unlocked) selections.
To lock a selection criterion, select the line you wish to lock and tick the checkbox under the 'Lock'

icon.

If you lock one or more selection criteria and tick the 'Limit results by the locked criteria' checkbox, the results
of the unlocked criteria will be limited to the locked selection. This is effectively an AND between the lines
which are locked and the unlocked lines below.
For example:
AND Office=London
AND Position=Auditor
AND Position=Consultant
This selection will return auditors from the London office and consultants from all offices.
To display auditors and consultants from the London office only, you can lock the 'Office=London' selection
line and tick the 'Limit results by the locked criteria' checkbox. This way the two subsequent selections (i.e.
the 'position' field) will be applied to the results of the locked selection (i.e. 'London' office).
When clearing a selection, the locked criteria will still be applied. You therefore need to unlock it in order to
remove it.
To unlock selection criteria, display the selection dialog by selecting 'Data-> Selection...' from the main
menu. Remove the tick from the checkbox under the 'Lock'

icon.

Removing selection criteria
To remove selection criteria, select 'Data-> Clear selection' from the menu.
Shortcuts: The 'Clear selection'
entire selection' from the menu.

button or right-click anywhere within the Wallchart and select 'Clear

Notes:
· Resource and Job view selections can be set up independently, therefore must be removed separately.
· The locked selection criteria needs to be unlocked in order to be cleared.
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8.6

Special selections using date ranges
Special selections overview
A number of frequent planning requirements refer to time periods, for example finding out which resources
are available to perform a job during a specified time period. In Retain there are a number of special functions
to perform such selections. They are independent of the other selections using selection criteria.
To select resource or job records based on time periods:
1. Make sure that you are in a Wallchart page, either in the Resource or Job view.
2. Mark an area anywhere on the booking grid.
Tip: It does not matter which resource record the marked area covers, but the start and end dates should
match the time period in which you are interested.
3. Select 'Data-> Special selections-> Add...' from the menu. This will use the default selection criteria.
Shortcuts: The 'Add a special selection'
button or right-click anywhere within the Wallchart and select
'Special selections-> Add...' from the menu.
4. If necessary, amend your special selection using the 'Special Selections' dialog and click on the 'OK'
button.
Records matching the criteria will be displayed and all other records will be excluded from the display. When a
special selection is already active, an additional selection line will be applied using the same procedure.
Remember this when using the button - it adds an additional selection line to the dialog when used.
To edit the current special selection, select 'Data-> Special selections-> Edit...' from the menu, or
right-click anywhere within the Wallchart and select 'Special selections-> Edit...'.
This allows you to edit the current special selection. If no special selection is active, 'Edit' takes you to an
empty 'Special selections' dialog.
Related Topics:
The 'Special selections' dialog
Hiding the 'Special selections' dialog
Deactivating special selections
Clearing special selections
Availability preferences
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The 'Special selections' dialog
The 'Special selections' dialog allows you to enter special selection criteria based on parameters such as:
availability percentage, available days for resources or adjusted revenue for jobs:

You can define separate date range for each selection criterion. All criteria use their own date range to which
the criteria are applied. Special selections consist of a number of selection criteria.
To create selection criteria:
1. Select the field you want to use, for example 'availability' for resources, that selects based on availability
percentage.
2. Select the start and end date for the date range of the booking. Note that each line has its own date range.
If you marked an area before displaying the dialog, this will automatically populate these values.
3. Select the condition to use for this field, either '=' (equal to); '>=' (greater than or equal to); '<' (less than)
and 'Contains' (contains text string).
4. Enter the value to compare the field to in the selected date range.
5. Click on the 'OK' button.
For example, select '>=' as a Condition and enter 80 as the condition value to select on all resources who
have availability of 80% or more for the selected period.
To add a selection line, click on the 'Add Line' button.
When using multiple lines, the resources displayed are those for which each line is true, i.e. the lines are
combined using an AND operator.

To remove a selection line, click on the

button.

Further options
· Hide the dialog window with 'Hide for availability' (Resource view only).
· (De)activate special selections with 'Special Selection Active'.

88

88

Sorting and selecting

Hiding the 'Special selections' dialog
For people primarily using the default availability selection, it is possible to hide the 'Special selection' dialog
when using 'Special Selections-> Add...' from the menu.
This is only available for the Resource View. When used, this will add a default line to the current selection
and will directly apply the selection. When there is no current selection, this is equivalent to directly applying
the default selection. The criteria can still be edited using the 'Special Selections-> Edit...' option.
To hide the 'Special Selections' dialog, tick the 'Hide for availability' checkbox. See the Availability
preferences section for an alternative way to hide the dialog.

De-activating special selections
To de-activate special selections, open up the 'Special selections' dialog and remove the tick for the
'Special Selection Active' checkbox. Alternatively, select 'Data-> Special selections' from the menu and
uncheck 'Use'.
This will keep the selection criteria in memory (as opposed to clearing the selection) but will not apply the
selection to the resources displayed, allowing you to change any other selection criteria independently.
To re-activate the special selection, tick the 'Special Selection Active' checkbox in the 'Special selections'
dialog or select 'Use' from the 'Data-> Special selections'.

Clearing special selections
To clear special selections, select 'Data-> Special selections-> Clear' from the menu. Alternatively, use the
'Clear special selection'
from the menu.

button or right-click on the booking grid and choose 'Special selections-> Clear'

All records will again be displayed in the current view. This will empty the 'Special selection' dialog.
To temporarily deactivate the selection (and reactivate it later), remove the tick from the 'Special Selection
Active' checkbox in the 'Special selection' dialog.
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9
9.1

Working with bookings
Bookings overview
In Retain a booking represents an allocation of an individual resource (or several resources) against a specific
job which covers a defined date range and a measurable number of hours.
In order to allocate resources to jobs in Retain you will need to make bookings. You can make bookings in
either Wallchart or Calendar view, although it is usually easier to make them in Wallchart. Bookings have a
solid black border in both normal and 3-D Wallchart views.
Retain treats all allocations to the Wallchart as 'bookings', regardless of their nature. This means that
'non-jobs', such as vacation and sick leave also need to be entered as bookings. You can use the fields
associated with the job to treat bookings against these special types of jobs differently from other types. See
the Adding jobs section for more information.
Related Topics:
Making a booking
Entering main booking details
Entering additional booking details
Booking list display
Visual Warnings
Make proportional bookings
Viewing bookings
Editing bookings
Splitting bookings
Locking bookings
Cutting bookings
Using the clipboard
Duplicating bookings
Rolling bookings forward
Deleting bookings
Undo booking operations
Scenario bookings
Ghost bookings
Booking requests
Booking colours
Over-allocation notification
Booking shapes

9.2

Making a booking
In order to make scenario bookings and see them within the Wallchart, you must be in edit mode and have
'Data-> Booking Visibility-> Show Normal Bookings' option selected.
Shortcut: The 'Show Normal Bookings'

button.

To make a booking:
1. Mark an area within the Wallchart.
2. Select 'Actions-> Make booking...' from the menu.
Shortcut: Right-click over the marked area and select 'Make booking...'.
3. Enter the main booking details using the 'Booking' dialog:
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Note that your 'Booking' dialog might look different from the above image as it is fully customisable and will
depend on the requirements of your organisation.
4. Entering additional booking details, if necessary.
5. Saving the changes by clicking on the 'Save' button.
One job and at least one resource must be selected. If you are in the Resource view, the 'Resource' field will
will contain the resource(s) selected when you marked a booking area. If you are in the Job view, the marked
job will be selected in the 'Job' field.
Using the 'Booking' dialog you can create multiple bookings at the same time, and work with both new and
existing bookings. See the Booking list display section for more information.
Resizable Components
Depending on the settings within your bkgDialog.ini, you can resize the 'Booking' dialog components as
necessary. Simply move the border of the section you want to increase or decrease. All the other sections
within the dialog will be automatically resized.
You can also double-click on the border of a section to make it auto size.
To reset all the size changes, right-click anywhere within the dialog and select 'Reset dimensions' from the
menu.
UNDO/REDO functionality
You can undo and redo the actions performed using the 'Booking' dialog (that are not related to attachments)
by pressing the appropriate button.

Click on the

button to undo or the

button to redo the action.

Note: The undo and redo functionality is applied to the 'Booking' dialog only; any other changes made in
Wallchart will not be affected.
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Marking an area
There are two different ways of marking an area within the Wallchart in preparation for making a booking:
Using the mouse:
1. Find the resource (or job) against which you want to make the booking.
2. Move the mouse pointer to the start date of the booking, adjacent to the required resource or job.
3. Click and hold down the left button of your mouse.
4. Move the mouse pointer to the end date of the booking.
5. Release the mouse button.
Using the keyboard:
1. Find the resource (or job) against which you want to make the booking.
2. Using the cursor keys, move the black rectangle to the start date of the booking adjacent to the required
resource or job.
3. Hold down the SHIFT key while using the cursor keys to move to the end date of the booking.
4. Release the SHIFT key.
A black bar marks the scope of the booking you are about to make.
Note: make sure you have selected the correct resource (or job) and the start and end dates covered by the
marked area correspond to the duration of the booking you wish to make.

Entering booking details
Main booking details
Once you have marked an area within the Wallchart, make a booking:
· Select 'Actions-> Make booking' from the menu.
Shortcuts: The 'Make booking'
button or right-click anywhere within the Wallchart and select 'Make
booking...' from the menu. Alternatively, press CTRL+K.
· Enter the basic booking details in the 'Main' tab and click on the 'Save' button when finished. When you
click on the 'Save' button, changes to all the bookings currently displayed within the 'Booking' dialog will be
saved, even if not all of them are selected:
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Note that your 'Booking' dialog might look slightly from the above image as it is fully customisable and will
depend on the requirements of your organisation.
A job and at least one resource must be selected in order to make a booking. If you are in Resource view
when you mark an area within the Wallchart, the 'Resource' field will display the selected resource; if you are
in Job view, the selected job will be displayed in the 'Job' field.
The 'Booking' dialog allows you to work with multiple bookings at the same time; to create new and edit
existing bookings simultaneously.
If you select more than one resource, a separate booking will be created against each of the resources in the
booking list display. The booking list display is the top pane of the 'Booking' dialog, listing the details of all the
bookings being worked on.
For each field you will find all or some of the following controls:
· To select a value, click on the
drop-down list.

button and start typing in the necessary value and/or select it from the

· If you wish to assign a value that does not exist in the list, you can create it by clicking on the

· To clear all of the selected values, click on the
click on the

button.

button. To clear the currently selected value,

button.

Resource/Job
You need to specify a resource and a job in order to make a booking.
You can also book several resources at once by:
· marking an area within the Wallchart (while in Resource view) that encapsulates the necessary resources;
or
· selecting the necessary resources and choosing 'Actions-> Make block booking...' from the menu. All the
visible resources will appear in the booking list display in the 'Booking' dialog.
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Component
You can add a component to further describe the booking. Components are usually generic 'sub-jobs' which
break down a job into its component parts.
When making a booking against a job that has job-specific components assigned to it, you will see both the
general/shared component list as well as the job-specific components.
Type
You can also select a type for your booking. Types can be used to classify bookings in terms of 'chargeable'
and 'non-chargeable', for example.
If a job has a default type (JOB_BKG_BTY_ID) and you make a booking against that job, the type will default
to that job type.
Booking Start/End dates
The easiest way to define the start and end dates for a booking is to mark an area within the Wallchart
encapsulating the necessary date range. However, you can also edit the start and end dates using the
'Booking' dialog.
Simply type in the dates or click on the

button and select the required dates from the calendar.

Note that when you amend the start and/or end dates, the size of the booking will be adjusted automatically
within the Wallchart.
Booking Loading/Time
Select the 'Loading' radio button and enter the percentage of commitment for this booking or select 'Time' to
assign a fixed number of hours for the job (despite the length of a booking). See the Making proportional
bookings section for more information.
Note: Loading and time values are important for the way bookings are handled with regards to public holidays
.
'Book partial day' checkbox
When you want to make a booking that ignores the start and/or end time of the resource's diary, you can book
time outside the usual working hours by ticking the 'Book partial day' checkbox. For example, if you wish to
make a booking that starts earlier than your working day, lasts two and a half days or is on a weekend, you
have to tick this checkbox.
'Include non-working days' checkbox
Tick this checkbox if you want to include the non-working days (e.g. weekends) into the booking time
calculations. You will not be able to book time outside the resource's diary unless you tick this checkbox.
'Grouped' checkbox
Bookings that have the same start date, job and duration can be grouped, allowing you to manipulate several
bookings as a set. This is especially useful if you have, for example, a number of resources assigned to a
training course. Using the grouped bookings functionality you can easily manage these bookings as one unit.
If the training course is postponed, you can simply move the group to another date without having to edit each
booking individually.
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To group selected bookings, tick the 'Grouped' checkbox.
Note that when you make changes to a booking in a group, you will be asked if you want to apply them to all
the other bookings within that group.
'Move and Resize' menu
If you select the 'Move...' option from this menu, the 'Move Bookings' dialog will pop-up, allowing you to move
one or more bookings further in the future by specifying the necessary number of days and/or weeks:
You can change the duration of one or more bookings by selecting the necessary number of days and/or
weeks in the 'Booking Offset' dialog:

If you select the 'Change Length...' option from this menu, the 'Change Booking(s) length' dialog will pop-up,
allowing you to change the length of one or more bookings by entering the necessary number of days to be
added:

'Book Partial Day' menu
This menu is not displayed by default. It allows you to quickly book the first half ('Book AM'), second half
('Book PM') or the whole day ('Book Full Day') when editing a one day long booking, without having to edit the
times manually:

Note: If the selected booking is longer than one day or if no bookings are selected, the menu will not appear.
Colour Scheme Based Values
If the colour scheme is based on an entity displayed in the 'Booking' dialog (e.g. component or booking type),
the values in the appropriate drop down list will be colour coded accordingly.
For example, if the colour scheme is based on the booking type (BKG_BTY_ID), when you click on the
button for the 'Type' field, you will see the value as well as its corresponding colour:
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To cancel the changes made to one or more bookings, click on the 'Clear' button.

Note that when you make changes to bookings using the Wallchart, the 'Booking' dialog will get updated even
if hidden or docked.
Related Topics:
Additional booking details
Create resource shortcut
Create job shortcut
Create component shortcut
Create booking type shortcut
Booking list display
Visual warnings
Create resource shortcut
The create resource shortcut allows you to create a new resource without exiting the 'Booking' dialog.
To create a resource using the 'Booking' dialog:
1. Click on the

button next to the Resource field.

2. The following dialog will be displayed, allowing you to create a new resource:
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3. Fill in the necessary details.
4. Click on the 'Add' button to complete the creation of a resource or 'Add Again' to add another one.
The newly created resource will be displayed in the Resource field in the 'Booking' dialog, enabling you to
continue with the creation/editing of a booking.
See the Adding resources section for more information.
Create job shortcut
The create job shortcut allows you to create a new job without exiting the 'Booking' dialog.
To create a job using the 'Booking' dialog:
1. Click on the

button next to the Job field.

2. The following dialog will be displayed, allowing you to create a new job:
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3. Fill in the necessary details.
4. Click on the 'Add' button to complete the creation of a job or 'Add Again' to add another one.
The newly created job will be displayed in the Job field in the 'Booking' dialog, enabling you to continue with
the creation/editing of a booking.
See the Adding jobs section for more information.
Create component shortcut
The create component shortcut within the 'Booking' dialog allows you to add a new component without
interrupting the process of creating/editing a booking.
To create a component using the 'Booking' dialog:
1. Click on the

button next to the Component field.

2. The following dialog will be displayed, allowing you to create a new component:

3. Fill in the necessary details.
To create a job-specific component, tick the 'Is Job Specific?' checkbox. This component will not be
displayed in the general/shared component list but will be available when booking against the specified job(s).
The job(s) you select while making/editing a booking will be assigned this component.
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Note that the the job-specific component will become job-specific only after you click on 'Save' in the 'Booking'
dialog.
4. Click on the 'Add' button to complete the creation of a component or 'Add Again' to add another one.
The newly created component will be displayed in the Component field in the 'Booking' dialog, enabling you to
continue with the creation/editing of a booking.
See the Adding components section for more information.
Create booking type shortcut
The create type shortcut within the 'Booking' dialog allows you to add a new booking type without interrupting
the process of creating/editing a booking.
To create a booking type using the 'Booking' dialog:
1. Click on the

button next to the Type field.

2. The following dialog will be displayed, allowing you to create a new booking typet:

3. Fill in the necessary details.
4. Click on the 'Add' button to complete the creation of a booking type or 'Add Again' to add another one.
The newly created type will be displayed in the Type field in the 'Booking' dialog, enabling you to continue with
the creation/editing of a booking.
See the Adding booking types section for more information.
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Additional booking details
You can also add additional details when making a booking.
Click on the 'Additional' tab within the 'Booking' dialog:

Note that your 'Booking' dialog might look slightly different from the above image, as it is fully customisable
and will depend on the requirements of your organisation.
Notes
If you have several people who are in charge of the planning process or simply wish to leave a reminder for
yourself about a certain booking, you can attach notes. Type in the text in the editable box and click on the
'Save' button:

Custom Rates (Revenue)
Retain derives the charge rate applied to each booking automatically, based on its 'charge code'.
The charge rate is a combination of:
·

Charge band of the selected resource,

·

Charge rate description of the job selected and

·

Date range of the booking

When you select a resource and job for the booking, the corresponding charge rate should already be
defined, so you need do no more. However, you can override the default revenue rate by ticking the
'Customise Rate' checkbox and amending the appropriate rate for the current booking. Change the rate
either by typing in a new figure or using the up and down arrows to adjust the figure.
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Attachments
Depending on your setup, you may also be able to add attachments to bookings using the 'Booking' dialog.
To add a file, click on the
button. Navigate to the location where the required file is and click on
the 'OK' button. Navigate to the location where the required file is, click on it and press the 'OK' button.
The name of the attached file along with the size, the date it was last updated and the name of the user who
updated it will be displayed.
To view the attached file, you can open it by selecting it and clicking on the
button.
Alternatively, simply double-click on it. The file will be automatically opened with the appropriate application.
If any changes are made and saved to the file, Retain will detect the changes and ask you if you wish to save
the amended file to the database. This allows you to quickly edit the file, without the need of downloading it,
saving the changes, deleting the existing attachment and re-uploading the amended one.
Note that you can also view booking attachments using the 'View Booking' dialog.
To download the file to your computer, click on the
To delete the file from the record, click on the
and can not be undone.

button.
button. This removes the file from the database

Note that the undo/redo functionality is not be applied to any actions related to attachments.
Related Topics:
Booking list display
Visual warnings
Booking list display
The top section of the 'Booking' dialog displays the list of bookings you are currently working on.
Since the new booking dialog allows you to work with multiple bookings at the same time, the booking list
display is used to manage these bookings:

You can only edit the selected bookings from the list. The bookings that are not selected will not be updated.
The 'Selected' column shows the bookings that will be affected with the changes you make. To select a
booking, simply double-click on it or tick the 'Selected' checkbox.
If you have a booking selected and double-click on it, all the bookings in the list will be selected. If you
double-click on a booking that is not selected, it gets selected while the rest of the bookings will be
de-selected.
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Note that when you click on the 'Save' button, changes to all the bookings displayed in the booking list, not
just selected bookings will be saved.
To resize the booking list display by clicking on the tabs below it and dragging them up or down, as
necessary.
To hide the booking list display, click on the

button. Click on the same button to show the list.

You can also select the booking values you wish to be displayed by clicking on the
hand side. A list of all the available values will appear:

button on the top left-

Each value represents a column in the booking list display. Tick/untick the checkbox for each column that you
want visible/hide. You can change this at any time.
If you are editing a large number of bookings, you can navigate through them by using the

buttons.

To go to a previous record in the list, click on the
button. To go to the next record, click on the
button.
To go to the first record in the list, click on the
button and click on the
button to go to the last booking in
the list.
To remove a booking from the list, select it (tick the 'Selected' checkbox) and click on the
warning message will pop-up asking you to confirm the deletion.

button. A

To add a booking to the list, click on the
button. If you have any booking selected, all the values from the
selected booking will be copied to the new booking. If you do not have any booking selected, a new booking
with only the following default information will be created: start date (today), end date (tomorrow), loading
(100%) and zero booking time.
Note: When you click on the
button or mark an area within Wallchart to create one or more bookings, only
the recently added booking(s) will be selected, allowing you to edit the necessary details.
By default, the time in the 'Booking Time' column is displayed in minutes. You can change the format of the
value to be displayed to hours as well as minutes. To do that, right-click anywhere in the booking list display
and select the required value(s) (minutes, hours) from the menu.
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Visual warnings
A visual warning
sign will appear for the fields that might affect other bookings. For example, if you have
several bookings selected the warning will appear, indicating that the resource will be changed for all selected
bookings if a value is selected.
Hover over this warning sign to see the description of the warning.
Another visual indication of warnings and errors is provided at the bottom of the 'Booking' dialog. As soon as
you make a change to one or more bookings, an appropriate error/warning message will be displayed. You
can then make the necessary changes before saving.
For example, if you forget to add a job to a booking and you try to save the changes, you will get the following
error message:

Warnings/errors of the same type are grouped. Click on the

9.3

button to view them:

Making proportional bookings
When you make a booking, Retain assumes that the work requires 100% commitment. For example, if the
standard working week in your organisation is 35 hours long, a two-week booking will take up 70 hours.
The duration of the booking is displayed in the 'Booking' dialog as 'Start/End Time'. The 'Time' box shows the
total number of booked hours for a booking. In case of a 100% commitment, this is equal to the duration of
the booking.
You can make proportional bookings by:
· Ticking the 'Loading' checkbox and enter a percentage commitment for this booking. The corresponding
fixed hours will be calculated automatically. For example, a 50% commitment over a 70 hour period would
produce a 35 hour booking.
· Alternatively, tick the 'Time' checkbox and enter a fixed number of hours for the booking. The
corresponding loading percentage will be calculated automatically. For instance, 35 hours over a 105 hour
booking period would represent a loading percentage of 33%.
In Wallchart or Calendar pages you can represent the loading of bookings graphically by setting the booking
bar depth to 'Proportional to loading'. See the Booking bar display options section for more information.
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9.4

Viewing bookings
To view a booking:
1. Find the necessary booking within the Wallchart. See the Navigating within the Wallchart section for more
information.
2. Move the mouse pointer over the booking so that the mouse pointer changes to a
. If booking tips are
activated, a text box will appear, displaying information about the booking. See the Booking bar tips section
for more information.
3. Select 'Actions-> Booking Info' from the menu to see all the details of the booking.
Shortcuts: Double-click on the booking or select it and press the 'Booking info'
right-click on a booking and select 'Booking info...' from the menu.

button. Alternatively,

To view information on the resource or job related to the selected booking, select 'Actions-> Resource info...'
or 'Job info...' from the menu. Alternatively, press the 'Resource info'
or 'Job info'
on the selected booking and then select 'Resource info...' or 'Job info...' from the menu.

button or right-click

A record of changes made to a booking
The 'Booking Audit Trail' field within the 'View Booking' dialog displays the last five changes made to that
booking. The user name of the person who made the changes as well as the date and time of change will be
shown:

9.5

Editing bookings
You can edit bookings either graphically on the Wallchart or manually through the booking details screen.
Once you have made a booking you will normally find it quicker to edit it graphically through the Wallchart.
Moving bookings
Moving a booking in the Wallchart automatically updates booking details such as the resource (or job) name
and the start and end dates of the booking.
Charge code and charge rate information may also be updated. For example, if you move a booking relating
to resource grade '1' to a resource with grade '2' the booking adopts the charge rate associated with grade 2
(unless the charge rate is fixed). Other details about the booking remain the same.
To move a booking:
1. Move the mouse pointer over the booking so that the mouse pointer changes to a

.

2. Click and hold down the left button of your mouse.
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The mouse pointer will change to a

to indicate the move operation.

3. Move the highlighted booking to the new location. You will see a transparent copy of the booking floating
over the Wallchart behind the mouse pointer, indicating where the booking would end up if you were to let
go of the mouse button:

4. Release the mouse button. The booking will be moved to the new location.
See the Booking preferences section for the 'snap to' settings.
Wallchart view also offers autoscrolling functionality. You can move bookings both horizontally and
vertically within the Wallchart. The view will automatically 'move' along together with the booking. This way
you can move bookings to a date not currently displayed without using a clipboard.
Alternatively, use the clipboard to move bookings to resources, jobs or time periods outside the currently
displayed view.
Copying bookings
Copying a booking creates a new booking with identical characteristics to the first, but with new details such
as the resource (or job) name and the start and end dates of the booking, if relevant, based on the location of
the new booking.
Charge code and rate information may also be updated. For example, if you copy a booking relating to
resource grade '1' to a resource with grade '2' the new booking adopts the charge rate associated with grade
2. If the booking was originally entered with a manual charge code or rate, it will be updated to the default
charge code or rate. Other details about the booking remain the same.
To copy a booking:
1. Move the mouse pointer over the booking so that the mouse pointer changes to a

.

2. Hold the CTRL key down and then click and hold down the left button of your mouse.

The mouse pointer will change to a
operation.

. The '+' sign inside the hand indicates that this is a copy

3. Move the outlined booking to the new location.
Tip: Concentrate on placing the bottom left corner of the booking into the cell into which you want to copy
the booking.
4. Release the mouse button and the CTRL key.The booking will be copied to the new location. See the
Booking preferences section for different 'snap to' settings.
Use the clipboard to copy bookings to resources, jobs or time periods outside the current view of the booking
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information.
Resizing a booking
Resizing a booking on the Wallchart automatically updates its start or end date, depending on which end of
the booking you move.
Unless the booking is for a fixed number of hours (see the Making proportional bookings section for more
information), resizing also changes the number of hours allocated to the booking; 'stretching' the booking
increases the booked hours and 'shrinking' the booking reduces the booked hours. Other details about the
booking remain the same.
To resize a booking:
1. Move the mouse pointer over either to the left or right end of the booking, so that the mouse pointer
changes to a
.
2. Click and hold down the left button of your mouse.
3. Move the mouse pointer to the new location.
A marked area will indicate the scale of the amended booking.
4. Release the mouse button.
The booking will be resized to the new location. Repeat the process if the booking isn't exactly where you
wanted it.
Selecting multiple bookings
You can select multiple bookings and then move, copy or delete them in one go. However, you can only
resize one booking at a time. Selecting multiple bookings is particularly useful when there is a relationship
between the bookings which you want to preserve. For example, you can use this functionality when a job has
been rescheduled by selecting all the bookings against that job and moving them to the new start date.
To select multiple bookings you can:
· Click on one of the required bookings. Hold down the CTRL key down and click on other bookings to select
or deselect them, as necessary. The booking colour will change to indicate that they are currently selected.
· Release the CTRL key. Perform the necessary operations on the selected bookings.
Alternatively:
· Mark an area within the Wallchart that encapsulates the required bookings.
· Right-click anywhere within the selected area (but not on a booking) and choose 'Select touched bookings'
from the menu. All the bookings within the marked area will be selected. You can now add more bookings
or remove the unnecessary ones by holding down the CTRL key.
Note that all booking operations (editing, duplicating, splitting and so on) are affected by public holidays.
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9.6

Splitting bookings
This function will split a booking in half, rounding each half to the current 'snap to' settings. This is useful for
spreading out bookings over resources or time while fixing the number of hours.
See the Customising date scale settings section for more information.
To split a booking:
1. Click on the necessary booking in the Wallchart.
2. Select 'Actions-> Split booking' from the menu.
Shortcut: Right-click on the booking and select 'Modify-> Split booking' from the menu.
3. A booking smaller than the current 'snap to' settings will be split in two. It is recommended to do the
splitting on a smaller date scale (from months to weeks, for example).

9.7

Locking bookings
The database can be set up so that individual bookings can be locked.
Note that only normal (live) bookings can be locked.
To lock a booking, right-click on the required booking and select 'Modify-> Lock Booking' from the menu:

The locked booking will be outlined in red:

The booking must be unlocked before it can be modified. To unlock a booking, right-click on it and select
'Modify-> Unlock Booking' from the menu.
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9.8

Cutting bookings
Users have the ability to divide one booking into two by visually cutting the booking in the Wallchart view at
any point along its length. The two newly created ends of the bookings will 'snap to' as defined in your
preferences. See the Customising date scale settings section for more information.
To cut a booking:
1. Select the booking you wish to cut and choose 'Actions-> Cut booking tool' from the menu.
Shortcut: Right-click on the booking and select 'Cut booking tool' from the menu.
2. Move the mouse pointer to the position at which you wish to cut the booking and click the left button of your
mouse:

3. The booking will be cut:

9.9

Using the clipboard
To enable Retain's clipboard, select 'View-> Booking Clipboard' from the menu. It will appear as the
rectangular area immediately above the list of resources/jobs.
To see (or enlarge) the clipboard, click on the top left corner of the Wallchart and drag it downwards:

This clipboard is particularly useful when you want to move or copy bookings beyond the currently displayed
area in the Wallchart.
The Retain clipboard is similar to a normal Windows clipboard, in that you can cut (move) and copy bookings
to the clipboard and paste them back into the Wallchart.
The Retain clipboard is different from other clipboards, however, because:
· A number of bookings can be stored in the clipboard at any one time.
· The clipboard only deals with bookings.
· Each notebook page has its own clipboard and the bookings in one page's clipboard are not available in
any other page's clipboard.
To copy or move a booking to the clipboard:
· To copy a booking to the clipboard, right-click on a booking and select 'Copy to Clipboard'. Alternatively,
select a booking and click on the
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· To move a booking to the clipboard, drag it to the clipboard directly and release the booking within the
clipboard area.
Note that if you perform the Undo action at this point, the booking will re-appear on the Wallchart but a copy
in the clipboard will remain.
Bookings remain on the clipboard until you move them back to the Wallchart. If you have several bookings on
the clipboard at the same time scroll bars will appear to allow you to navigate between bookings.
To copy or move a booking from the clipboard, you can either:
1. Move the mouse pointer over the booking in the clipboard.
2. Drag the booking to move the booking in the usual way, or press CTRL and then drag to copy the booking.
3. Release the booking within the required location of the Wallchart.
Alternatively:
1. Select an area within the Wallchart you want to copy/move the booking to.
2. Choose the required booking within the clipboard.
3. Right-click and select 'Move to wallchart' to move or 'Copy to wallchart' to copy the booking.
Note: The original start time of the booking is maintained, the 'Snap to' settings are ignored.
To remove bookings from the clipboard:
1. Move the mouse pointer over the clipboard area.
2. Right-click with the mouse.
3. Choose 'Delete selected' to delete a selected booking.
Alternatively, select 'Clear Clipboard' to remove all the bookings from the clipboard.
Note that you can hide and unhide the clipboard by selecting 'View-> Booking Clipboard'.

9.10 Duplicating bookings
If you have a booking that you want to assign to other resources or you know will re-occur in the future, you
can use the duplication wizard:

To duplicate a booking over time or resources:
1. Select 'Actions-> Duplicate bookings...' from the menu. The 'Duplication wizard' dialog will open.
Shortcuts: The 'Duplicate bookings'

button or right-click on a booking.

2. Select whether to duplicate bookings over time, resources (or both) by ticking the appropriate
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checkbox(es):

3. If duplicating bookings across resources, select the required resources by highlighting them in the
'Available' list and moving to the 'Selected' list using the '>' button. You can move a resource from the
'Selected' list using the '<' button, add all resources using '>>' and remove all resources using the '<<'
button.
4. Check to see if your settings are correct and click on 'Finish' to duplicate the bookings.
Duplicating over time depends on the duplication period selected:
1. Select 'Actions-> Duplicate bookings...' from the menu. The 'Duplication wizard' dialog will open.
Shortcut: Right-click on a booking and select 'Duplicate bookings'.
2. Select whether to repeat bookings across time by clicking the appropriate checkbox.
3. If duplicating over time, select duplication period, either yearly, monthly, weekly, daily or custom.

4. For yearly, monthly or weekly bookings, select the duplication interval (e.g.: every 5 weeks).
5. Select the dates the duplicating bookings should start, depending on the period:
Yearly:
Select the day of the year.
Monthly:
Select the day of the month or 'Last day of the month'.
Weekly:
Select the day(s) of the week.
Custom:
Enter custom dates.
6. Choose a day when to start duplicating. The default start date is the first day after the selected booking
ends:
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7. Select when to stop duplicating. The 'Duplicates' field will show the number of duplications to be made
within that period. The default is one duplication. Alternatively, type in or use the up/down arrows to change
the required number of duplications.
Note: Daily and weekly duplication will not copy to weekends but copies for yearly or monthly duplication
might end on weekends or public holidays. Check the duplicates and move them to weekdays, if necessary.
8. Review your settings and click on 'Finish' to duplicate the bookings:

9.11 Rolling bookings forward
Rolling bookings forward functionality is especially useful when scheduling recurring jobs.
You can save time by rolling normal (live) bookings forward without the need to create each booking again for
the second and subsequent periods.
To roll bookings forward:
1. In Wallchart, filter the Resource and/or Job view as required, so that only the bookings that you want to
roll forward are displayed. See the Sorting and selecting section for more information.
For example, if you only want to roll forward bookings for jobs belonging to manager Smith, filter the jobs
view by setting selection criteria where Manager = 'Smith'.
Note: Only normal (live) bookings can be rolled forward.
2. Select 'Actions-> Roll forward' from the menu.
Shortcut: The 'Roll forward'

button.
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3. In the 'Roll forward' dialog, specify the roll forward dates.
4. Click on the 'OK' button to roll the bookings forward.
A status bar will be displayed while the bookings are rolled forward. This may take some time.
5. Once the roll forward process is complete, check the new bookings and amend them for the current
period as required.
The 'Roll forward' dialog
When you select 'Actions-> Roll forward' from the menu, the following dialog will be displayed:

Using the 'Roll forward' dialog:
1. Choose one of the following options:
·

Roll forward all resources visible in this wallchart (number of records): bookings of all the
resources of current Wallchart will be rolled forward.

·

Roll forward only the resources touched by the selected region (number of records): only
bookings of the resources in the selected region will be rolled forward.

2. Specify the Date range of the bookings to be copied forward. This could also be done by highlighting an
area within the Wallchart. All bookings starting within the specified date range (and matching the current
selection settings) will be rolled forward.
3. Specify the Destination date for the new bookings. If the start date of the area you have highlighted is
different from the start date of the selected booking, the difference between these two start dates will be
applied.
For example, if you have a three-day-long booking that starts on 04/05/2012 and the specified date range is
between 29/04/2012 and 08/05/2012, the difference between these two start dates is 3 working days (the
weekend is excluded). Therefore, if the destination date is 03/06/2012, the new booking will start on
08/06/2012.
Hint: Use the same day of the week for the destination date to avoid creating weekend bookings.
4. Select the type of bookings you wish to create by ticking the appropriate checkbox. The rolled forward
bookings can be created as:
· live (normal) bookings
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· scenario bookings
Note: When roll-forwarding to scenario bookings, you can specify a scenario these bookings will belong to.
You can either select from an existing list of active scenarios or type in a new name. Entering a new name
means the bookings will be rolled forward to a new scenario with the name you specified.
· ghost bookings
· booking requests
When done, click on the 'OK' and select 'Yes' in the confirmation message to perform the roll forwarding.
If you are in the Job view, you will also see the 'Target jobs' tab:

·

Roll forward to the original job. This option will make new bookings against the original job.

·

Roll forward to new job. With this option you may choose a different job for the new bookings.

Rolling bookings forward is normally only the starting point of planning the recurring jobs. Move, copy and
resize the new bookings as usual, taking into account the differences in timing and duration of the jobs and
reallocating the bookings to different resources as necessary.
Note: Although rolling forward functionality resembles duplicating bookings, the difference is that it works with
multiple bookings, allowing you to create a copy of a number of bookings and move them to the required date.

9.12 Deleting bookings
Deleting bookings removes them permanently from the Wallchart and all reports.
To delete bookings:
1. Click on the booking in the Wallchart.
2. Select 'Actions-> Delete booking' from the menu.
Shortcuts: The 'Delete selected booking'
button or press Delete(DEL). Alternatively, right-click on a
booking and select 'Delete Booking...' from the menu.
3. The 'Delete Booking' dialog will appear. Click on 'Yes' to delete the displayed booking or 'No' to cancel
deletion of the displayed booking. Select 'Yes to All' to delete all the selected bookings or 'Cancel' to abort
the deletion.
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If you delete a booking by mistake, you can undo this action by pressing CTRL+Z.

9.13 Undo booking operations
All editions of Retain now have the facility to undo the last action that was performed on a booking.
To undo the last action, select 'Edit-> Undo' from the menu or press CTRL+Z:

Note that this does not apply to any other operations performed within the Wallchart.

9.14 Scenarios
Depending on your access rights, you might be able to create and edit scenarios and scenario bookings. You
can create scenarios using the Scenario Manager.
In Retain, a scenario is a collection of potential bookings that are called scenario bookings.
Scenarios provide an additional tool for planning your work with Retain. A scenario allows you to see how a
potential project or several projects would look like if comprised of different bookings. This is especially useful
if you are planning several projects and wish to have an overview of a possible scenario and compare
collections of bookings.
For example, if you think that you will win a tender and want to see which resources would be most suitable
for the job, you can create a scenario for this hypothetical project. If you win the tender, you can simply make
that scenario live. If you do not win the tender, you can delete the scenario or archive it for historical purposes.
Scenarios are divided into four types depending on their status.
Notes: You can not report on scenarios. Also, scenarios are user-specific which means that you will only be
able to see the scenarios you have created.

Types of scenarios
Scenarios can be divided into the following three types, according to their status:
Active
Active scenarios are the ones you are currently working with. You can edit scenario bookings that belong to
active scenarios and you can make an active scenario live.
Lived
When a potential project has been confirmed, you can make that scenario live. Once a scenario booking is
lived, the bookings that belong to it become live bookings (normal bookings). Therefore, if you edit the
bookings that belong to a lived scenario you will be editing live bookings, not scenario bookings. You can also
rollback a 'lived' scenario or archive it.
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Archived
When a potential project has been canceled or postponed, you can archive the scenario for historical
purposes or potential future use. Archived scenarios are also useful for comparing the initial planning with the
final result. Only 'lived' scenarios can be archived and the scenario bookings belonging to an archived
scenario are uneditable.
Rollback a scenario
If you 'live' a scenario by mistake or before the project has been confirmed, you can roll it back to the 'active'
state. Only 'lived' scenarios can be rolled back.
In cases when a scenario is rolled back but some of the bookings have been lived or deleted in the meantime,
you will, depending on your functional access rights, either:
- get a warning asking whether you want to roll back all the live bookings generated from the scenario, even if
they have been modified or
- will not be allowed to roll back a scenario if another user has changed any of the live bookings generated
from the scenario.
To illustrate, the following diagram represents the transitions allowed in the scenario model:

To manage scenarios, use the 'Scenario Manager' dialog.
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Scenario Manager
The 'Scenario Manager' dialog allows you to manage scenarios. Select 'View-> Scenario Manager' from the
menu to open the dialog:

You can move the 'Scenario Manager' dialog around or add it to the dockable pane. When you close the
'Scenario Manager' dialog, Retain will remember whether it was docked or not and will re-open it
accordingly.
You can also choose which scenario bookings you wish to be displayed within the Wallchart by ticking the
appropriate checkboxes. To display all the scenarios, click on the 'Show/Select All' button. To hide all the
scenarios, click on the 'Hide/Deselect All' button.

To create a scenario:

button or right-click anywhere in the 'Scenario Manager' dialog and
1. Click on the
select 'New Scenario' from the menu.
2. Enter a descriptive name for the scenario in the 'Name' column.
3. Click on the required scenario to select it and add scenario bookings to it.
To see a particular scenario booking within the Wallchart:
1. Tick the ‘Selected’ checkbox for the scenario the booking belongs to.
2. Expand the scenario by clicking on the

button.

3. Double-click on the necessary booking. It will be displayed in top-left corner of the Wallchart.
To delete a scenario, select it from the 'Scenario Manager' dialog by clicking on it, right-click on the scenario
and select 'Delete Scenario' from the menu. Alternatively, press DELETE (DEL) button on your keyboard or
click on the
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To make an active scenario live, select it from the 'Scenario Manager' dialog by clicking on it, right-click on
the scenario and select 'Live Scenario' from the menu. Alternatively, click on the

button.

To archive a lived scenario, select it from the 'Scenario Manager' dialog by clicking on it, right-click on the
scenario and select 'Archive Scenario' from the menu.
To rollback a lived scenario, select it from the 'Scenario Manager' dialog by clicking on it, right-click on the
scenario and select 'Rollback Scenario' from the menu. Alternatively, click on the

button.

To edit the name of a scenario:
1. Select the required scenario from the 'Scenario Manager' dialog by clicking on it.
2. Click on the 'Name' value for the scenario and edit the name as necessary.
3. Press 'Enter' or click away from the modified scenario for the new name to be saved.

The

button provides the same options as the right-click menu.

If you have a number of scenarios, you can group them according to their visibility in Wallchart, name or
status. For example, click on the 'Status' column header and drag it to the area above to display the scenarios
according to their status.
The 'Current Scenario' drop-down list shows the active scenario and is only used when performing
operations through the 'Booking' dialog. When editing bookings (e.g. duplicating, rolling forward, copying to
clipboard), the scenario of the bookings you are working with will be used (not the scenario selected in the
'Current Scenario' drop-down).

Warnings are displayed at the bottom of the 'Scenario Manager' dialog. Click on the
them.

button to display/hide

Depending on your setup, you may be able to filter the data displayed in the dialog by clicking on the
button and defining the necessary conditions. Alternatively, you can hover over a column header
and click on the
button. You can now sort the view by choosing from the possible values or customising
your own filter.
The selected value(s) will appear at the bottom of the booking list display.
To remove the selection, click on the

button.
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9.15 Scenario bookings
Depending on your access rights, you might be able to create and edit scenario bookings. A 'scenario
booking' is a booking that is assigned to one or more scenarios.
You are able to toggle on and off the visibility of scenario bookings using the main menu. Select 'Data->
Booking Visibility' and make sure there is a tick against 'Show Scenario Bookings'.
Shortcut: The 'Show Scenario Bookings'

button.

Scenario bookings appear as hatched out bookings with a stippled border and an 'S' in the top right corner in
the normal Wallchart view:

In the 3-D View scenario bookings are presented with a solid black border and an 'S' in the top right corner:

Note: While you can display only scenario bookings within the Wallchart, you will most likely want to view
normal bookings as well, in order to see how scenario bookings appear alongside the existing normal
bookings.
See the following section on how to make scenario bookings.

Making a scenario booking
In order to make scenario bookings and see them within the Wallchart, you must be in edit mode and have
'Data-> Booking Visibility-> Show Scenario Bookings' option selected.
To make a scenario booking:
1. Create a scenario and name it (or select an existing scenario from the 'Scenario Mode'
drop-down menu).
2. Once you have a required scenario selected, mark an area within the Wallchart.
3. Select 'Actions-> Make scenario booking' from the menu.
Shortcut: Right-click over the marked area and select 'Make scenario booking...'.
4. In the 'Scenario Booking' dialog, enter the booking details as for a normal booking and click on
the 'Save' button. This will save all the bookings currently displayed in the 'Scenario Booking'
dialog, even if some are not selected.
One job and at least one resource must be selected. If you are in the Resource view, the 'Resource' field will
will contain the resource(s) selected when you marked a booking area. If you are in the Job view, the marked
job will be selected in the 'Job' field.

118

118

Working with bookings

If you select more than one resource, a separate booking will be created against each of the resources.
To delete scenario bookings:
1. Click on the booking in the Wallchart.
2. Select 'Actions-> Delete booking' from the menu.
Shortcuts: The 'Delete selected booking'
button or press Delete(DEL). Alternatively, right-click on a
booking and select 'Delete Booking...' from the menu.
3. The 'Delete Booking' dialog will appear. Click on 'Yes' to delete the displayed booking or 'No' to cancel
deletion of the displayed booking. Select 'Yes to All' to delete all the selected bookings or 'Cancel' to abort
the deletion.

Making scenario bookings live
Once a scenario booking is confirmed, you can make it 'live'. You can also live all bookings in a scenario in
one go. When you make scenario bookings live, they become normal bookings.
To make scenario bookings live, select the necessary scenario from the 'Scenario Manager' dialog by
clicking on it and click on the
Scenario' from the menu.

button. Alternatively, right-click on the scenario and select 'Live

A copy of the booking will appear below the scenario booking within the Wallchart, indicating that this scenario
booking has been lived:

9.16 Ghost bookings
'Ghost bookings' in Retain are planned but unconfirmed bookings. For example, if you know that a
certain project will take place in two months time but the exact day has not been confirmed yet, you
can make a ghost booking. Similarly, if you are considering two people for a particular job, you can
make ghost bookings against both of them.
You are able to toggle on and off the visibility of ghost bookings using the main menu. Select 'Data-> Booking
Visibility' and make sure there is a tick against 'Show ghost bookings'.
Shortcut: The 'Show Ghost Bookings'

button.

Note: If you want to see only ghost bookings displayed in the Wallchart, make sure you tick 'Show Ghost
Bookings' in the 'Data-> Booking Visibility' menu.
Ghost bookings appear as bookings with a solid grey border within the Wallchart (in both normal
Wallchart view and the 3-D View):
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Making a ghost booking
In order to make ghost bookings and see them within the Wallchart, you must be in edit mode and have
'Data-> Booking Visibility-> Show Ghost Bookings' option selected.
To make a ghost booking:
1. Mark an area within the Wallchart.
2. Select 'Actions-> Make ghost booking' from the menu.
3. In the 'Booking' dialog, enter the required details as for a normal booking.
Shortcut: Right-click over the marked area and select 'Make ghost booking...'.
One job and at least one resource must be selected. If you are in the Resource view, the 'Resource' field will
will contain the resource(s) selected when you marked a booking area. If you are in the Job view, the marked
job will be selected in the 'Job' field.
If you select more than one resource, a separate booking will be created against each of the resources.
4. Click on the 'Save' button to confirm. That this will save all the bookings currently displayed in the
'Booking' dialog, even if some were not selected.

Convert to ghost bookings
You can also convert 'normal' bookings to 'ghost' bookings. This feature is useful if, for example, a
job is postponed and you are not sure if the person will still be available.
To convert a normal booking to a ghost booking, select the necessary booking, right-click on
the booking and select 'Convert to Ghost'.

Confirm ghost bookings
Once the planned project or resource's availability is confirmed, simply confirm a ghost booking to
make it a 'normal' booking.
Select 'Data-> Booking Visibility-> Show Ghost Bookings' from the menu.
To confirm a ghost booking, select it in the Wallchart and choose 'Actions-> Confirm booking' from the
menu. Alternatively, right-click on the booking and select 'Modify-> Confirm Booking' from the menu.
To confirm multiple ghost bookings, select multiple bookings by holding down the CTRL key and and
choose 'Actions-> Confirm booking' from the menu.
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9.17 Booking requests
Retain offers the ability to make 'Booking requests'. For example, a user may want to make a booking
request for vacation time or a project manager may create a series of booking requests to organise
resources for a potential job.
You are able to toggle on and off the visibility of booking requests using the main menu. Select 'Data->
Booking Visibility' and make sure there is a tick against 'Show Booking Requests'.
Shortcut: The 'Show Booking Requests'

button.

The number of booking requests you will see depends on whether you are an administrator or a requester.
The administrator will see all the booking requests he/she is a manager of, while the requester will only see
booking requests he/she has submitted:

Note: If you want to see only booking requests displayed in the Wallchart, make sure you tick
'Show Booking Requests' in the 'Data-> Booking Visibility' menu.
Booking requests appear as transparent bookings with stippled border in the normal Wallchart view:
· Booking requests (requests for booking creation) have a '+' symbol at the top right corner:

· Booking requests for deletion have a '-' symbol at the top right corner:
· Rejected booking requests have a red cross going through them:
· Ghosted booking requests have a 'R' symbol at the top right corner and they are duplicated below the
booking request that was ghosted (which in turn will be marked with a 'G' sign):
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Note that in 3-D view booking requests have a solid black (not stippled) border.
Once a booking request is confirmed ('made live') by the administrator, it will appear as a normal booking.
Related Topics:
Making a booking request
Requesting a booking deletion
Administering booking requests

Making a booking request
In order to make booking requests and see them within the Wallchart, you must be in edit mode and have
'Data-> Booking Visibility-> Show Booking Requests' option selected.
To make a booking request:
1. Mark an area within the Wallchart.
2. Right-click over the marked area and select 'Make booking request...'.
3. In the 'Booking' dialog, enter the details as for a normal booking.
4. Click on 'Save' to confirm. This will save all the bookings currently displayed in the 'Booking' dialog, even if
some are not selected:
One job and at least one resource must be selected. If you are in the Resource view, the 'Resource' field will
will contain the resource(s) selected when you marked a booking area. If you are in the Job view, the marked
job will be selected in the 'Job' field.
If you select more than one resource, a separate booking will be created against each of the resources.
When you successfully create a booking request, you will be presented with a confirmation dialog:

Note: When the booking request is modified by the resource manager, the booking status will change to
'Ghost' or 'Confirmed'. They can be seen through the separate Booking Request module. See the Booking
Requests section for more information.

Requesting a booking deletion
You can submit a request to delete a booking in Retain Enterprise and this request will appear in the User
Request Queue in the Booking Request module.
To submit a request for deletion:
1. Right-click on the booking you want to delete.
2. Select 'Modify-> Request Deletion'.
3. In the 'Request Deletion' dialog, click on 'Yes' to submit or 'No' to cancel the request.
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4. A pop-up message confirming your request details will appear:

You should also be able to see this request in the User Request Queue of the Booking Request Module.
Once the administrator accepts this request your booking will be deleted from the Wallchart.

Administering booking requests
Retain also has the ability to convert 'request' bookings to 'ghost', 'normal' or 'rejected' bookings. These
features help the resource manager to modify booking requests through the Wallchart.
To see an existing booking request, you must ensure that the 'Show Booking Requests' option from the 'Data'
menu, 'Booking Visibility' is active.
In order to convert booking requests, you must first be in edit mode. See the Switching to edit mode section if
you are not sure whether you are in edit mode.
To convert a booking request to a normal booking, right-click on the required booking request and
choose 'Live Request' from the menu.
If the request was for deletion, the original booking and the request will be deleted. Otherwise, the request will
be converted to a normal booking.
To reject a booking request, right-click on the required booking request and select 'Reject Request' from
the menu. In the pop-up window you can enter the reason for rejection. It will be stored in the 'Rejection
Reason' field within the 'View Booking' dialog:

You can resubmit a rejected request by right-clicking on it and selecting 'Resubmit Request from
the menu.
You can also send a booking request to ghost by selecting the 'Send Request To Ghost' option from the
menu; however, this functionality has now been almost entirely replaced by the integration of booking
requests in Wallchart.
Administering multiple booking requests
When you want to edit a booking request that was created for more than one resource, you will be presented
with a 'Booking Request Group' dialog:
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To edit all of the booking requests displayed in the dialog, click on the 'Live All', 'Ghost All' or
'Reject All' button, as necessary.
To edit only one/some of the booking requests or to perform different actions on different requests, select
the required resource and click on the 'Live Selected', 'Ghost Selected' or 'Reject Selected' button, as
necessary.
Once finished, click on the 'Close' button.

9.18 Booking colours
The colour of a booking represents a particular value of that booking. The colour scheme is essentially a set
of colours, with each colour representing a certain value. Your administrator will be able to edit the colour
scheme but not rename or delete it.
For example, a default colour scheme displaying bookings according to their type may look similar to this:

The 'Colour Legend' (see the image above) displays the values that each colour represents. To open the
colour legend, go to 'View-> Colour Key'. You can use the colour legend to change the booking colour (and in
this example, the booking type) and apply it to bookings.

124

124

Working with bookings

Note: you will not be able to change the colour of: lived or archived scenario bookings and booking requests
for deletion.
To change the colour of a booking:
1. Select a colour from the colour legend. The mouse pointer will change to 'paint-pot'.
2. Move the mouse pointer over the required booking. The mouse pointer will change to 'pouring paint-pot'.
For instance, to change the type for 'E-Solutions' booking to 'Chargeable', select it from the colour legend and
click on the booking:

The booking colour (and at the same time the booking type) will be changed:

3. Once finished, click anywhere on the booking grid (away from the bookings) to remove the 'paint-pot'.
You can also change the booking colour (and the booking type in this example) by right-clicking on a booking
and selecting 'Change colour to' option from the menu. The list of colours and their descriptions will be
displayed:
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Note: The 'Change colour to' menu option and the ability to change the colour of a booking using the colour
legend will be disabled if the colour scheme is not based on one of the acceptable fields from the BKG table.
This prevents you from accidentally changing the values of internal Retain fields such as job (if the colour
scheme is based on the JOB table field) by editing a booking.
You can keep the colour legend displayed throughout your current session and use it whenever you need it.
To move the colour legend:
1. Click on the header bar or the colour legend dialog, holding the mouse button down.
2. Move the mouse pointer to the new location.
3. Release the mouse button.
You can also move the colour legend from the main Wallchart view by dragging it to dockable pane on the
right-hand side of the screen.
To close the colour legend, click on the

button.

A booking will be of the default colour when it is not assigned a value corresponding to the colour scheme.
The default colour of the booking is white and the default shape is rectangular:
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Over-allocation notification
Note that if you do not have the appropriate access rights, you may not be able to over-allocate.
Over-allocation occurs when the total value of loading (for one or more bookings) for a specific date range is
more than 120%. Over-allocated bookings are displayed in red.
For example, if you have several bookings (none of which exceeds the maximum loading):

and you move one of the bookings to the same date range as an existing booking, thus causing overallocation, both of the bookings in conflict will become red:

Since the total loading for 'Virgin Media' and 'Digital Solutions' for that date range now equals 200%, both
bookings become red.
To compare, if you make several bookings against the same date range but the total value of loading does
not exceed 120%, the bookings will not be considered to be in conflict:

Since the total loading value of these four bookings is 115%, over-allocation does not occur.

127

Working with bookings

9.19 Booking shapes
In addition to colours, you can create bookings with different shapes:

The shape of a booking depends on a particular value of that booking, as is in the case of colours.
Colours and shapes allow you to visually represent two individual values for each booking.
For example, you can have booking shapes which are dependent on the component of the booking.
The 'Shape Legend', available from 'View-> Shape Key' menu option, allows you to see the values assigned
to each shape:

Note: you will not be able to change the shape of: lived or archived scenario bookings and booking requests
for deletion.
You can also easily change the value of the booking that the shape represents by using the shape legend.
In this example, the shape of each booking represents its component. If you wanted to change the component
for the 'E-Solutions' booking to 'Audit', you would select the component in the shape legend:
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then hover over the booking, and click on it:

The component of the booking changes to 'Audit' and consequently, the booking shape becomes ribboned:

Alternatively, you can change the booking shape (and the booking component in this example) by
right-clicking on a booking and selecting 'Change shape to' option from the menu. The list of shapes and their
descriptions will be displayed:
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Note: The 'Change shape to' menu option and the ability to change the shape of a booking using the shape
legend will be disabled if the shape scheme is not based on one of the acceptable fields from the BKG table.
This prevents you from accidentally changing the values of internal Retain fields such as job (if the colour
scheme is based on the JOB table field) by editing a booking.You can keep the shape legend displayed
throughout your current session and use it whenever you need it.
To move the shape legend:
1. Click on the header bar or the shape legend dialog, holding the mouse button down.
2. Move the mouse pointer to the new location.
3. Release the mouse button.
You can also move the shape legend from the main wallchart view by dragging it to dockable pane on the
right-hand side of the screen.
To close the shape legend, click on the

button.

A booking will be of the default shape when it is not assigned a value corresponding to the shape scheme.
The default shape of the booking is rectangular and the default colour is white:
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10 Working with notebooks
10.1 Notebooks overview
Notebooks contain views of your Retain data. They allow you to display your Retain Wallchart in various ways
and to define report formats used by the Retain Report Writer.
Each notebook can contain one or more notebook pages, each page representing a different view of your
data. Each notebook page may be either a Wallchart, calendar or report type page and can be defined
independently. See the Working with notebook pages section for more information.
Each notebook points to a particular database. In most organisations, you are likely to have a single
database, but you may have several notebooks pointing to that data. In a network environment, your Retain
data may be stored on a network drive and shared by many users. Each user may have their own notebooks,
or you may even have notebooks which are shared by several users. (Note: If you intend to share notebooks
the notebook file is changed each time someone saves it. You may prefer to make shared notebook files read
only so that they cannot be amended.)
It is essential, while working with a Retain notebook, to appreciate that the underlying data is the same across
all pages, notebook files and even users of that data.
For example, if you amend a booking in a particular notebook the booking itself is amended, not just the view.
However, if you were to hide some bookings in a notebook then they would still be visible in all other
notebooks - the underlying data would not change.
Related Topics:
Creating a new notebook
Opening an existing notebook
Saving the notebook
Default notebook
Closing the notebook
Importing/exporting notebook pages
Notebook windows

10.2 Creating a new notebook
To create a new notebook, select 'File-> New' from the menu. Alternatively, use the 'New file'
press CTRL+N.

button or

The new notebook file will be created with a temporary name such as 'ntbk1' and a default 'Resource' page
will be provided. You can now work with the notebook as necessary.
A temporary notebook name given to a new notebook is equivalent to an untitled document in a word
processing application or unsaved workbook in a spreadsheet application. Remember to save your new
notebook under a meaningful name and to save changes to your notebooks from time to time, such as when
you add new notebook pages. See the Saving the notebook section for more information.
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10.3 Opening an existing notebook
If you currently have a notebook open, you should close it before opening another notebook.
To open an existing notebook, select 'File-> Open' from the menu. Alternatively, use the 'Open'
button
or press CTRL+O. You can open both, notebooks with the current ('*.RetainNotebook') and old ('*.RTN') file
extensions.
Generally, you should only need to have one notebook open at any one time, since you may be working with
several pages within that notebook. See the Working with notebook pages chapter for more information.
Note: The four most recently opened notebooks will be listed in the 'File' menu.

10.4 Saving the notebook
To save the current notebook, select 'File-> Save' from the menu. Alternatively, use the 'Save'
or press CTRL+S.

button

If the notebook has not been named previously, you will be prompted to enter a name for it.
To save the current notebook under a different name, or to save a notebook which has not been
previously named:
1. Select 'File-> Save As' from the menu.
2. Enter the new name of the notebook file. Retain notebook files should be given a '.RetainNotebook' file
extension.
3. Click on the 'OK' button to save the notebook under this new name.
If you enter an existing filename, Retain will ask if you want to overwrite the existing notebook. Click on 'Yes'
to overwrite the existing notebook or 'No' to enter a different filename.
Note: When you save a notebook, you are saving your views of the Retain data, including any pages added
or deleted and any changes to the formats of existing pages. You are not saving the data itself. Changes to
your bookings, jobs, resources and components are saved to the underlying database as you go along, so
you do not need to worry about saving these changes separately.
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10.5 Default notebook
You can save a notebook with the current settings as your 'Default Notebook'. Every time a new notebook is
created, it will inherit the settings of the default notebook.
If you want to save the current notebook settings to be the default settings, select 'File-> Save As Default
Notebook':

Note that you can have only one default notebook at a time. It will be saved locally on your machine and
under your username and will not be accessible to other users.
To restore the factory settings select 'File-> Clear Default Notebook'. Make sure you clear the default
notebook before connecting to a different database.

10.6 Closing the notebook
To close the current notebook, select 'File-> Close' from the menu. Alternatively, double-click on the
icon at the top left corner of the notebook window or press CTRL+F4.
If you have made changes to your notebook, you will be prompted to save them before closing the file. See
the Saving the notebook section for more information.
When you exit Retain, you will automatically close all open notebooks.
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10.7 Importing/exporting notebook pages
You can import and export individual notebook pages so that pages can be easily moved between different
notebooks. Select 'Notebook-> Export page...' to export and 'Notebook-> Import page...' to import a page:

By exporting a notebook page you will be able to use it within another notebook or make it available for other
users to use.
For example, if two users are working on sperate notebooks and one of them wants to use a report that the
other user has designed, the creator of the report needs to export it by selecting 'Notebook-> Export page...'
from the menu to save the file as a Retain notebook page:

Enter a name for your page (it will be saved with the '.RetainPage' extention) and click on the 'Save' button. In
the example above, the exported page is a report page called UtilisationReport.
The user who wants to use this report has to navigate to the file and import it to their own notebook by
selecting 'Notebook-> Import page...':
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Navigate to the file and click on the 'Open' button. The selected page will be displayed in Retain.
You can import both pages with the new ('*.RetainPage') and old ('*.rtnPage') file extensions:

10.8 Notebook windows
In Retain you can open several notebooks at once, as long as they point to the same underlying database.
See the Opening an existing notebook section for more information.
Each notebook you open in Retain is contained in its own window.
Resizing notebook windows
You can manipulate each notebook window as follows:
· To expand the notebook window to its maximum size, click on the 'Maximise'
the window.

button at the top right of

· To restore a maximised window to its original size, click on the 'Restore down'
the window.

button at the top right of

· To minimise the notebook, click on the

or

button at the top right of the window.

To manually resize a window, move the mouse pointer to the border of the window you want to resize. The
mouse pointer will change to a
. Now drag the border until the window is of the size you want and then
release the mouse button.
To close a notebook window, click on the

or

button at the top right corner of the window.
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Window menu options
Any open notebook windows are listed in the 'Window' menu. To switch to a different window, select it from
the 'Window' menu. Alternatively, if the notebook windows are minimised, click anywhere on the window area
to activate it.
The following options are also available from the 'Window' menu:
· Cascade - overlays your open notebook windows one on top of another, each window having the same
dimensions.
· Tile vertically - tiles your open notebook windows side by side, each window being of the same width.
· Tile horizontally - tiles your open notebook windows on top of each other, each window being of the same
height.
· Arrange icons - when all the open notebook windows are minimised, arranges them evenly across the
bottom of the screen.
· Close all - closes all open notebook windows.
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11 Working with notebook pages
11.1 Notebook pages overview
Each notebook can contain one or more notebook 'pages', each page containing a different view of your data.
The characteristics of each notebook page can be defined and maintained independently, using the various
sort, selection and other display features in Retain, allowing you to create an almost unlimited number of
views of your data.
You can see all the pages of the currently open notebook in the page drop-down list:

A notebook page can be one of the following three types:
· Wallchart - the traditional Wallchart view with resources/jobs listed on the left-hand side of the page and a
date bar along the top. Each booking is represented as a coloured block in the middle of the screen.
· Calendar - a calendar view where each screen page represents the bookings for one individual resource or
job. Time is represented in a calendar style grid and special navigation features allow you to move to other
resources or jobs.
· Report - a powerful Report Writer view that allows you to easily develop and quickly generate various
reports.
Create a separate notebook page for each view of your data that you want to produce on a regular basis.
When you save a notebook, all the page formats are stored so you can retrieve them quickly at a later date.
Remove notebook pages that you no longer need or simply update them as necessary. You will often be able
to work using your existing notebook pages, rather than creating a separate page for every unique view.
If you decide to use a number of notebook pages, consider creating separate notebooks to deal with pages of
a similar type. For example, you might set up pages relating to monthly reports in a 'MonthlyReports' notebook
or pages relating to particular staff groups into a 'Groups' notebook.

Note: No more than 40 pages per notebook can be created. If the 'Add page'
and 'Copy page'
buttons (and the appropriate menu options) are disabled, you already have 40 pages in the current notebook.
Related Topics:
Adding a page
Inserting a page
Copying a page
Renaming a page
Deleting a page
Navigating between pages
Switching to Wallchart or Calendar view
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Setting the opening date
Editing fonts

11.2 Adding a page
To add a new page to the current notebook:
1. Select 'Notebook-> Add page' from the menu.
Shortcut: The 'Add page'

button.

2. Choose the page type by selecting the appropriate radio button.
3. Type in a descriptive name for the new notebook page.
4. Click on the 'OK' button to confirm your changes. The new page will be added as the last page in the page
drop-down list.
Notes:
· When adding a Report page you will be prompted to define the report format. See the Creating a report
section for more information.
· The maximum number of pages for a notebook is 40. Therefore, both the 'Add page'
appropriate menu option will be disabled when a notebook has 40 pages.

button and the

11.3 Inserting a page
To insert a new page in the current notebook:
1. If you have several pages in your notebook, select the page you want to appear after the inserted page in
the page drop-down list.
2. Select 'Notebook-> Insert page' from the menu.
Shortcut: The 'Insert page'

button.

3. Choose the page type by selecting the appropriate radio button.
4. Type in a descriptive name for the new page.
5. Click on the 'OK' button to confirm your changes. The inserted page will always appear before the page
selected in step 1.
Note: When adding a Report page you will be prompted to define the report format. See the Creating a report
section for more information.
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11.4 Copying a page
To make a copy of a notebook page:
1. If it is not the currently open page, select the page you want to copy from the page drop-down list.
2. Select 'Notebook-> Copy page' from the menu.
Shortcut: The 'Copy page'

button.

3. The new page will be added as the last page in the current notebook drop-down list. The copied page will
contain all the characteristics of the original page but can be amended as required without affecting the
original page. See the Renaming a page section for more information.

Note: The maximum number of pages for a notebook is 40. Therefore, both the 'Copy page'
the appropriate menu option will be disabled when a notebook has 40 pages.

button and

11.5 Renaming a page
To rename a notebook page:
1. If it is not the currently open page, select the page you want to rename from the page drop-down list.
2. Select 'Notebook-> Rename page' from the menu.
Shortcut: The 'Rename page'

button.

3. Type in the new name for the page.
4. Click on the 'OK' button to confirm your changes.

11.6 Deleting a page
To delete a notebook page:
1. If it is not the currently open page, select the page you want to delete from the page drop-down list.
2. Choose 'Notebook-> Delete page' from the menu.
Shortcut: The 'Delete page'

button.

3. Click on the 'OK' button to confirm the deletion.
Notes:
· Deleting a page does not affect any underlying data such as resources, jobs or bookings that were
displayed in the deleted page.
· A notebook needs to have at least one page. Therefore, you will not be able to delete the last page.
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11.7 Navigating between pages
To switch to a different page:
· Using the mouse: select the page from the page drop-down list.
· Using the keyboard: use CTRL+PageUp and CTRL+PageDown to move through the pages in the page
drop-down list.
You can change the order of notebook pages by moving them up or down. This is useful for notebooks with a
lot of pages.
To move a page, select the page (if it is not the currently active page) you want to move from the page
drop-down list and choose 'Notebook-> Move page up' or 'Move page down' from the menu. The page will be
moved accordingly.

11.8 Switching to Wallchart or Calendar view
To switch from Wallchart to Calendar view, ensure that the Wallchart view is the currently active view and
select 'View-> Calendar' from the menu.
Shortcut: The 'Calendar view'

button.

To switch from Calendar to Wallchart view, ensure that the Calendar view is the currently active view and
select 'View-> Wallchart' from the menu.
Shortcut: The 'Wallchart view'

button.

Notes:
· If you are using both views regularly you may find it convenient to create a separate page for each view.
· Report pages cannot be converted to Wallchart or Calendar views.

11.9 Setting the opening date
When you open a Wallchart or Calendar page, the view will start with today's date. You can change the date
to:
· a certain fixed date;
· a date relative to today's date;
· a date the view started when the notebook was last closed.
To set the opening date for a currently active notebook page:
1. Select 'View-> Opening date...' from the menu.
2. In the 'Opening Date' dialog, set the opening date for the current page as required (see the instructions
below):
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3. Click on the 'OK' button to confirm your changes.
The opening date guidelines:
· Specify a Fixed date if you want the notebook page to always start with the same date. You are likely to
use this option for historical views of your data or when you are planning from a fixed point of time in the
future, for example.
· Select a Relative date with an offset value of zero if you want the notebook to always start with today's
date, based on your computer's internal clock. You are likely to use this option for most of your resource
planning activities.
You can also specify a start date relative to today's date by setting a required value in the 'Offset from
today (Days)' box. For example, set the offset to '+30' if you want the notebook page to start 30 days after
today or '-30' for 30 days prior to today.
· Choose the Last Closed Date option if you want the notebook page to always start with the date that the
last saved notebook page started with.

11.10Editing fonts
You can edit the fonts of several Retain components:
· expanded and collapsed records, sub fields and date bar in Wallchart and Calendar views;
· report fonts: report detail, total and sort levels;
· report header fonts: header title, sub-title, date, page number, date range and columns;
· report footer fonts: footer date, page number and footnote;
· header and footer fonts when printing Wallchart and Calendar pages.
To edit fonts:
1. Select 'View-> Fonts' from the menu.
Shortcut: The 'Fonts'

button.

2. Depending on which fonts you are editing (see the list above), you will be presented with a dialog similar to
this:
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3. Using this dialog, select an item that you want to edit and click on the 'Set font...' button. Alternatively,
double-click on the required item.
4. The 'Font' dialog will appear, allowing you to alter the font as required. You can edit the type of font, its
style, size and colour, as well as use of effects such as strikeout or underline:

5. Click on the 'OK' button to confirm your changes.
Note: When altering fonts, make sure that they are clearly visible for both on-screen viewing and printable
versions.
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12 The Retain Report Writer
12.1 Report writer overview
Retain provides its own versatile and powerful report writer which allows you to create various customised
reports.
You can use the Retain Report Writer to produce both job-based (such as job cost and forecast revenues)
and resource-based (such as resource allocations and utilisation analyses) reports. You can format, sort,
perform selections and aggregate your reports in a number of ways.
Related Topics:
Creating a report
Report fields
Calculated fields
Report date range
Report selection criteria
Report grouping and subtotals
Viewing the report
Report headers and footers
Saving and exporting reports
Report Examples

12.2 Creating a report
To create a new report, you need to add a new notebook page with a 'Report' page type:
1. Select the 'Add page' option from the 'Notebook' menu.
Shortcut: The 'Add page'

button.

Tip: Use the 'Copy page' function if you want to create a report based on an existing report format.
2. Choose the 'Report' page type by selecting the appropriate radio button.
3. Type in a descriptive name for the new report.
4. Select the 'OK' button to add the Report page to your notebook.
5. Define the report formats for the new report as required (see the image below).
6. Click on the the 'OK' button button to confirm your report formats. A new notebook page will be created for
your report.
7. Select the new page from the drop-down to generate the report.
When you create a new Report page you will be prompted to define the report formats at the 'Setup Report'
dialog:
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Use this dialog to define the following information about the report:
· Fields - add the resource, job or booking fields that you want to appear in each row of your report.
· Date - specify the date range to be covered by the report.
· Sort - specify the order in which the report data will be sorted, including any aggregation of your data by
way of sub-totals.
· Selection - enter any criteria by which you want to filter the contents of the report.
As a minimum you should normally enter one or two fields and a date range for your report. You can produce
a quick report in less than a minute with just these elements, although in practice you may want to experiment
with the different report settings to produce the report in your preferred format.

12.3 Report fields
Report fields are displayed on each row of the report. You can select any of the fields from the resource, job
and booking tables. You can also customise the position and width of these fields in the report.
To define report fields:
1. Select 'Data-> Fields' from the menu.
Shortcut: The 'Fields'

button.

2. In the 'Setup Report' dialog, 'Fields' tab, add or remove the fields you want to be displayed in the report
(see the instructions below):
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3. Click on the 'OK' button to confirm your changes.
To add a field:
1. Select the field from the drop-down list in the 'Field' panel.
2. Adjust the width of the column by changing the number under 'Width' or by dragging the line which
separates each field in the top pane.
3. Adjust the order in which fields are displayed by clicking on the

and dragging the line up or down.

4. Repeat steps 1 to 3 for each field as required.
Tip: You do not need to include the fields you wish to use for sorting here. The sort fields are added using
the 'Sort' tab and will be displayed in the report automatically.
Only combine report fields if they have a logical relationship. Generally, this means producing reports based
on fields from either resource, job or booking tables but not a combination of fields across these tables. For
instance, the resource 'grade' and the job 'priority' fields do not have a logical relationship.
Since the booking table contains information related to both resources and jobs, you can often use this table
to produce booking level reports. For example, you can use the 'Resource Name' and 'Job Name' fields from
the booking table rather than extracting these name fields from the resource and job tables.
If using booking level fields rather than the values held in the corresponding resource or job tables, note that
Retain allows you to change the priority colour, resource grade and charge type on a booking by booking
basis. You may therefore notice differences between the reports using these fields at a booking level from
those at the resource/job level.

To remove a field from the report, click on the
button against the field or move the mouse pointer over a
field in the top pane and drag the field outside of the box.
To reposition a field within the report, click on the on the left of the field and and drag the line up or
down. The top field will be the first field on the left-hand side. Alternatively, move the mouse pointer over the
field in the top pane and drag it left or right.
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To change the width of a field within the report definition, change the number under 'Width'. Alternatively,
move the mouse pointer to the right edge of the field in the top pane, so that the mouse pointer changes to a
and drag the line to increase/decrease the width.
Shortcut: You can also resize the fields within the report by dragging the column header separators left or
right.
To create time series reports (reports spanning over periods of time), add the field(s) you wish to report on
for each of the period individually.
For example, if you wish to report on the utilisation of resources over the next three months, add the
'utilisation' field three times and select 'Next month' as the Date type in the 'Date' tab. The report may look
similar to this:

For more sample reports see the Report Examples section.

12.4 Calculated fields
Standard report fields are preceded by 'resource', 'job' or 'booking' to indicate the table they relate to. For
example:
· resource.Name - the resource name field in the Resource (RES) table;
· job.Name - the job name field in the Job (JOB) table;
· booking.Startdate - the booking start date from the Booking (BKG) table.
In addition to the standard database fields, Retain also provides a number of special fields that provide
additional information about a resource or job, computed from the underlying data (e.g. availability, utilisation,
revenue), called 'calculated fields'.
The two most commonly used calculated fields are:
Availability
This field calculates the resource's availability percentage for a given date range.

146

146

The Retain Report Writer

Public holidays/weekends (as defined in the diary) do not count towards diary time.
Utilisation
This field calculates the resource's utilisation percentage for a given date range depending on the charge
rates of the jobs he/she is booked on.

Deducted time refers to non-work bookings (such as holidays) that are setup through Retain Security to be
excluded from utilisation calculations.
It is important that these definitions are understood by everyone using Retain.
The behaviour of these calculated fields can be modified in Retain Security Manager for different charge
rates.
For example, there is a resource booked for two weeks, one week on a chargeable job and another week on
a holiday. The utilisation percentage will depend on the charge band of these jobs. In this case, 'Chargeable
job' charge band is always 'included', therefore the calculation will differ depending on whether you wish to
take into account the time spent on holidays or not.
In other words, if 'Holiday' charge band is defined as 'deducted' then the overall utilisation for this two week
period will be 100%. If 'Holiday' charge band is defined as 'excluded', utilisation will be 50%:

Note: The term 'reporting period' used below refers to both, the currently displayed or selected date range
within Wallchart as well as the date range used when creating a report.
Table Calculated Field

Description

RES
All booked time
Availability
Available Time
Booked Days
Booked Time
Current Charge Band
Current Diary
Default Diary Time
End Date

Total booked time within the reporting period, including time coming from ghost bookings
The resource's availability percentage in the reporting period
The resource's available time (in minutes) within the reporting period with no negative
values allowed
Total amount of time (in days) the resource has been booked on within the reporting
period
Total amount of time (in minutes) the resource has been booked on within the reporting
period
The current value of the resource's 'Charge band' history field
Resource's diary
Total diary time for the default diary (in minutes) within the reporting period
End date of the Blank diary
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Diary Time
Ghost Utilisation
Ghost true diary time
Ghosted availability
Holiday Booking time
Is in submitted booking request
Last Booking Change Date
Revenue
Start Date
Utilisation
Utilised Time
Maximum Loading %
Utilised Days
Available Days
Booking Count
Diary Days
Diary Warning
Is Coach for this resource
Scenario Available Time
Scenario Availability
Scenario Utilisation
Scenario Booked Time
Scenario Utilised Time
Attachments Count

Total diary time for the resource (in minutes) within the reporting period
Utilisation percentage for the reporting period based on the charge band of the jobs and
including ghost bookings
Utilisation percentage for the reporting period, computed using the diary time excluding
holidays (including those generated by ghost bookings)
Availability percentage for the resource including time generated by ghost bookings in the
computation
Total time (in minutes) the resource is booked on holidays in the reporting period
Returns 'Y' if the resource has a submitted request; 'N' otherwise
Returns the last change date of a live booking made against the resource
Revenue
Start date of the Default diary
Utilisation percentage for the resource within the reporting period based on the charge
rate of the jobs the resource is assigned to
Total utilised time (in minutes) for the resource within the reporting period
Maximum percentage booked in a day within the period
Utilised days within the period by resource
Available days within the period for a resource
Number of bookings within the period for a given resource
Total amount of diary time (in days) for the resource
Calculated field used to determine whether a resource has bookings after the termination
date
Returns 'Y' if the resource is coached by the currently logged on user; 'N' otherwise
The resource available time (in minutes) within the currently displayed date range
including active scenario bookings
The resource's availability percentage within the currently displayed date range including
active scenario bookings
Utilisation percentage for the resource within the displayed date range based on the
charge rate of the jobs the resource is assigned to, including scenario bookings
Total booked time against the resource in the currently displayed date range including
scenario bookings
Total utilised time (in hours) for the resource within the currently displayed date range
including scenario bookings
The number of attachments associated with the resource

JOB
Booked Days
Booked Time (Hours)
Revenue
Revenue Variance
Time Variance
Total Booked Time (Hours)
Booking Count
Attachments Count

Total amount of time (in days) booked against the job within the reporting period
Total amount of time (in hours) booked against the job within the reporting period
Job revenue
Job revenue variance
Time variance (in hours) between the job budgeted time and the total booked time
against it
Total hours booked against a job regardless of the reporting period
Number of bookings within the period for a given job
The number of attachments associated with the job

BKG
BRQ Submit Date
Booking Class
Booking Conflict
Booking Request Notes
Fast Time (Hours)
Is Active Scenario Booking
Is Live Booking or Submitted BRQ
Is Submitted BRQ line
Is a Administered Booking Request
Line
Is in conlict on managed job?
Is in conflict on managed resource?
Resource Diary Time
Resource Emergency Diary Time
Scenario ID of booking
Scenario Name
Scenario Status Code
Time (Days)
Time (Hours)
True Loading
True Time
Booking Record Time (Hours)
Booking Record Time (Days)
Maximum Loading %
Attachments Count
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Returns the earliest request submission date
Displays the booking class: line of a booking request, actual or ghost
Total loading for the reporting period
Returns the notes stored against booking requests
Time (in hours) against a booking for the reporting period
Returns 'Y' if the booking is in an active scenario; 'N' otherwise
Returns 'Y' if the booking is a live or submitted request; 'N' otherwise
Returns 'Y' for submitted requests; 'N' otherwise
Returns 'Y' if the request is in the currently logged on user's administered queue; 'N'
otherwise
Returns 1 if there is a conflict on a job managed by the currently logged on user; 0
otherwise
Returns 1 if there is a conflict on a resource managed by currently logged on user; 0
otherwise
The amount of diary hours against the booked user during the date range of the booking
The resource emergency time (in hours) during the date range of the booking
The Scenario ID which the booking belongs to
Name of the scenario which the live booking belongs to
Returns the status code of the scenario booking
Total time of the booking in days
The time of the booking in hours
True loading for fixed time bookings
The time of the booking in hours used to fix up fixed loading Bookings
Total booking hours irrespective of the currently displayed date range
Total booking days irrespective of the currently displayed date range
Maximum percentage booked in a day within the period
The number of attachments associated with the booking
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12.5 Report date range
Most of the reports you create will require a date range. The date range of the report determines the cut off
points for all calculations in the report, including utilisation percentages, booked hours and job costs.
Where bookings span across the specified date range then they will be time apportioned for the purposes on
each report. For example, if only one week of a three-week booking is included in the date range of a report,
then 33.3% of the booking will be included in the report for the purposes of generating time and cost figures.
To define the date range:
1. Select 'Data-> Date range' from the menu or click on the 'Date' tab in the 'Setup Report' dialog.
Shortcut: The 'Date range'

button.

2. In the 'Date' dialog, edit the date range as necessary:

3. Click on the 'OK' button to confirm your changes.
The 'Date Type' drop-down list includes several pre-defined date ranges ('Last quarter', 'Next month', 'This
year', etc.). It is advisable to use one of these values where possible because the report will then
automatically use the appropriate date range whenever you run the report.
To select a pre-defined date range, click on the 'Date Type' drop-down list and select the required item from
the 'Date Type' drop-down list.
The pre-defined date ranges are calculated automatically with reference to your computer's internal clock.
Make sure your clock is set to the correct date. If your date range needs to be absolute, not relative, select the
required range first to set the dates, and then select Manual Date Range to make them absolute.
If none of the pre-defined date ranges are suitable for your requirements then you will need to specify a date
range manually.
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To set a manual date range, select 'Manual Date Range' from the 'Date Type' drop-down list and enter start
and end dates manually as required.
Tip: Click on the calendar buttons to the right of each box to select the date from the pop-up calendar.
To set a report with no date range, select 'No Date Range' from the 'Date Type' drop-down list.
Note: Generally, reports using booking information will require a date range.

12.6 Report selection criteria
Use report selection criteria to filter the contents of your report in much the same way as you filter the display
of a Wallchart or Calendar view.
To define selection criteria for your report:
1. Select 'Data-> Selection' from the menu or click on the 'Selection' tab heading in the 'Setup Report' dialog.
Shortcut: The 'Selection'

button.

2. In the 'Selection' dialog, specify criteria as required (see the image below).
3. Click on the 'OK' button to confirm your changes.
The report selection dialog
The 'Selection' tab in the 'Setup Report' dialog allows you to specify the selection criteria to be applied to the
active Report page:

To add a selection criterion:
1. Choose an 'Operation' to be applied. See the Selection operators and conditions section for more
information.
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2. Select the necessary table (resource, job or bookings) and choose the required field from the 'Field'
drop-down list.
3. Choose a 'Condition' followed by a value in the pop-up box. See the Selection operators and conditions
section for more information.
4. Repeat steps 1 to 3 to add further selection criteria as required. Click on the 'OK' button once finished.
Your report selection criteria should form a logical relationship with the rest of the report definition. For
example, if your report contains resource based fields you should not attempt to filter the report based on job
selection criteria.
Note: You should consider the sequence of items in the selection criteria carefully because the order of items
can determine the meaning of the selection.
To amend the sequence of selection criteria, click on the

and drag the line up or down.

If you are reporting on bookings and have resource or job field as your first field in the report, you can display
resources/jobs with bookings only by ticking the 'Filter Res/Jobs' checkbox.
To remove a selection criterion, click on the

button against that value. Alternatively, click on the

button to remove all of the criteria.
For time series reports with date dependent fields (such as availability or utilisation) you can specify time
series selections.
To specify a time series selection, add the criteria as usual (see above) and tick one of the following
checkboxes:

· First Column - the criteria applied to the first report period only. The records that match the specified
selection criteria for the first period only (disregarding the values of other periods) will be shown.
· All Columns - the criteria applied to all of the report periods. Only the records that match the specified
selection criteria for all of the periods will be shown.
· Any Columns - the criteria applied to one or more report periods. The records that match the specified
selection criteria for either of the periods (one or more) will be shown.
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12.7 Report sort orders and subtotals
Report sort overview
Use the report sort order both to sort the rows displayed in your report and to provide sub-totals in the report,
analysing the report in logical groupings as required.
To specify the report sort order and subtotals:
1. Select 'Data-> Sort' from the menu or click on the 'Sort' tab heading in the 'Setup Report' dialog.
Shortcut: The 'Sort order'

button.

2. In the 'Sort' tab, specify sort criteria as necessary.
3. Click on the 'OK' button to confirm your changes.
Related Topics:
The report sort dialog
Grouping and expanding

The report sort dialog
The 'Sort' tab in the 'Setup Report' dialog allows you to specify both the sort order and, using the 'Group By'
setting, the levels at which the report will be aggregated:

To add a sort order criterion to the report:
1. Select a field from the drop-down list in the 'Field' box.
2. Select the direction of a field as 'Ascending' or 'Descending'.
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3. Repeat steps 1 and 2, as necessary.
4. Click on the 'OK' button once finished.

To remove a sort order criterion, click on the

button.

You should consider the sequence of items in the sort criteria carefully. For example, sorting by resource
grade and then resource name will produce a meaningful report, while sorting by resource name and then
grade will not.
To amend the sequence of items in the sort criteria, click on the

and drag the line up or down.

You can also hide the field headers for the sub-totals within the report by un-ticking the 'Field Headers'
checkbox. It is ticket by default.

Group By and Expand To
In the 'Sort' tab of the 'Setup Report' dialog' you can select 'Group By' and 'Expand To' to control how your
report looks:
· Group By - determines which sort fields will be displayed as titles and subtotals in the report for expanding
and collapsing.
The sort fields you include here need not be defined in the 'Fields' tab, otherwise they will appear twice.
· Expand To - defines the level of detail at which the report will open when first generated.

12.8 Viewing the report
Viewing report overview
If you have any reports created, they will be available in the notebook page drop-down list.
If the report has not been generated during your current session, then a progress bar will indicate that the
report is being generated.
If the report has been generated before and you want to make sure you have the latest report data, you
should refresh the report.
Related Topics:
Expanding and collapsing report sections
Report display options
Recalculating the report
Refreshing the report
Report headers and footers
Report Examples
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Expanding and collapsing report sections
If your report has one or more sort titles, you can expand and collapse the sections of the report as defined by
those titles. The or buttons adjacent to the report sort titles will indicate whether they can be expanded or
collapsed:

Expanded report sections are indicated by the

button. Collapsed sections are indicated by the

button.

To expand or collapse an individual report section, double-click on the report section row or click on the
report section and press the SPACEBAR.
To expand all the nodes in the report by one section level, select 'Actions-> Show more detail' from the
menu.
Shortcuts: The 'Show more detail'
detail' from the menu.

button or right-click over the report area and select 'Show more

To expand all the nodes in the report fully, select 'Actions-> Open all details' from the menu.
Shortcuts: The 'Open all details'
from the menu.

button or right-click over the report area and select 'Open all details'

To collapse all the nodes in the report by one section level, select 'Actions-> Show less detail' from the
menu.
Shortcuts: The 'Show less detail'
from the menu.

button or right-click over the report area and select 'Show less detail'

To collapse all the nodes in the report fully, select 'Actions-> Close all details' from the menu.

154

154

The Retain Report Writer

Shortcuts: The 'Close all details'
from the menu.

button or right-click over the report area and select 'Close all details'

The level of expansion of the report on screen will be used when the report is printed out or exported.
Note: It is generally preferable to use these shortcuts to modify the report outline level rather than editing the
settings in the 'Sort' tab of 'Report Setup' dialog. Using the dialog will result in a full recalculation of the report
which is not desirable for complex reports because it might be time consuming.

Report display options
The following display options are available for Report pages:
· Grid lines - turn the report record grid lines on or off.
· Fonts - set the fonts for different elements of the report as required.
· Indent totals - choose whether to indent report totals or to have them appear directly beneath their
corresponding report entries.
· Report column widths - resize the report columns as required.
Grid lines
Grid lines surrounding the records in the report can help to identify the individual fields in the report. However,
you may find that grid lines make the report look cluttered. You may also want to exclude the grid lines when
printing out the current view of the Report page.
To turn the report grid lines on or off, select 'View-> Grid' from the menu.
Shortcuts: The 'Grid lines'
select 'Grid' from the menu.

button or press CTRL+G. Alternatively, right-click over the report area and

Repeat the process to return the grid lines to their original state.
Fonts
You can define fonts for each of the following elements of the report:
· report details;
· report totals;
· report sort levels (up to 5 levels).
To change the report fonts, select 'View-> Fonts' from the menu. Alternatively, click on the 'Fonts'
button. See the Editing fonts section for more information.
Indent totals
You can indent the sub-totals and totals in the report or have them appear directly underneath their respective
columns. Indented totals may look more pleasing to the eye, although they do take up more room; with
indented totals you may also need to adjust the width of the report columns.
To turn the indent totals on or off, select 'View-> Indent Totals' from the menu.
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Shortcut: Right-click over the report area and select 'Indent totals' from the menu.
Report column widths
You may need to adjust the widths of the columns in your report in order to accommodate large numbers or
indented totals. You can also adjust the column widths as a way of hiding the columns from the view.
To adjust the report columns widths:
1. Move the mouse pointer over the right side of the title of the column you wish to change, so that the mouse
pointer changes to a
.
2. Click on the left button of your mouse and hold it down.
3. Move the mouse pointer horizontally to the required new position.
4. Release the mouse button.
5. Repeat steps 1 to 4 for each column, if necessary.
You can also adjust the report column widths using the fields definition while creating a report. See the Report
fields section for more information.

Note: If you see ****** instead of data, it means that the column is too narrow for the data to be displayed.
Make the column wider (see above).

Recalculating the report
When you first define or view a report in your current Retain session it will be calculated based on the latest
available data. However, once you have viewed a report once it will not be calculated again until you require it
to be updated, as calculating a report takes some time.
To recalculate the report, select 'Actions-> Refresh' from the menu.
Shortcuts: The 'Refresh'

button or press F5.

Refreshing the report
If you are running Retain in a network environment and other users have made changes to the data, you can
use the refresh command to ensure all the latest changes will be reflected in your report.
To refresh a report, click on the 'Refresh'

button or press F5.

Note that this command takes longer than recalculating.
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12.9 Report headers and footers
Headers and footers overview
You can customise the layout of a report by including page numbers, dates, titles, etc. by editing the report's
header and footer.
Related Topics:
Editing the header
Editing the footer
Hiding and showing the header
Hiding and showing the footer

Editing the header
To edit the report header:
1. Select 'View-> Header...' from the menu.
Shortcuts: The 'Header'
the menu.

button or right-click over the report's header and choose 'Edit Header...' from

2. In the 'Page Setup' dialog, define the report header details as necessary:

3. Click on the 'OK' button to save your changes.
· Show header - show or hide the report header.
· Title - show or hide the report title. If showing, type in the title for the report.
· Sub-title - show or hide the report sub-title. If showing, type in the sub-title for the report.
· Date - show or hide the report date.
· Page number - show or hide the report page number.
· Show date range - show or hide the date range covered by the report.
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· Surrounding frame - show or hide the frame surrounding the report header.
· Column titles - show or hide the column titles.
· Fonts - set the fonts for the various header elements by clicking on the 'Font...' button. See the Editing
fonts section for more information.

Editing the footer
To edit the report footer:
1. Select 'View-> Footer...' from the menu.
Shortcuts: The 'Edit footer'
the menu.

button or right-click over the report's footer and choose 'Edit Footer...' from

2. In the 'Page Setup' dialog, define the report footer details as necessary:

3. Click on the 'OK' button to save your changes.
· Show footer - show or hide the report footer.
· Footnote - show or hide the report footnote. If showing, type in the footnote for the report.
· Date - show or hide the report date.
· Page number - show or hide the report page number.
· Surrounding frame - show or hide the frame surrounding the report footer.
· Font - set the fonts for the various footer elements by clicking on the 'Font...' button. See the Editing fonts
section for more information.
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Hiding and showing the header
To show or hide the report header, tick the 'Show header' checkbox in the 'Header configuration' dialog.
Shortcuts: The 'Toggle header'
from the menu.

button or right-click over the report header area and choose 'Header...'

Hiding and showing the footer
To show or hide the report footer, tick the 'Show footer' checkbox in the 'Footer configuration' dialog.
Shortcuts: The 'Toggle footer'
from the menu.

button or right-click over the report footer area and choose 'Footer...'

12.10Saving and exporting reports
Your report definitions are stored along with all your other notebook pages in your Retain notebook. Although
you can produce reports very quickly with the Retain report writer, it is worthwhile saving any report formats
that you intend to use on a regular basis. See the Saving your notebook section for more information.
Exporting reports
Reports created using the Retain report writer can be exported in spreadsheet format and hence transferred
to other applications such as popular spreadsheet packages.
You can either:
· export the report to clipboard, for immediate transfer. Exporting a report to clipboard will copy the contents
of the current report to the Windows clipboard.
· export the report to a file, for later use. Exporting a report to a file will copy the contents of the current
report to a text file.
To export a report to clipboard, generate the report and customise the view on screen as required then
select 'Edit-> Export to clipboard' from the menu.
The report will remain on the Windows clipboard until replaced by another 'Cut' or 'Copy' operation. Switch to
another application such as Excel and paste the report contents into the application using the normal
Windows 'Paste' function.
To export a report to file, generate the report and customise the view on screen as required then select
'Edit-> Export to file' from the menu. Enter a name and path for the report file and save it.
Open a TXT file in another application, such as Notepad. The exported report file will contain separate rows
and columns for each report record and field, respectively. The report data can now be easily manipulated
using a spreadsheet application.
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13 Printing
13.1 Printing overview
Retain enables you to print both Reports and Wallcharts for use within your company. There are various
settings available to enable you to produce the printout you require. However, it is easy to overlook certain
settings and it is recommended to take note of the general rules for printing.
Related Topics:
General rules for printing
Previewing the current page
Printing the current page
Printing Wallcharts
Print configuration options
Page setup

13.2 General rules for printing
These are the general rules for printing from Retain:
· Retain prints the currently active notebook page.
If you want to print a particular report, make sure that the report is the active page. Similarly, if you want to
print a Wallchart page, make sure that it is the active page.
· Retain prints the current view of your data.
Set your sort and selection criteria as necessary and consider recalculating the report before printing. Use
the print preview option to ensure the view is as required.
· Retain printing takes into account the current display options.
If you are printing a Wallchart page, define the display settings such as grid lines, date scales, booking bar
formats, etc. Similarly, when printing a report, define the report display settings.
· Graphical printing can take some time.
Use a fast printer with a large printer memory if possible. If you are using a shared printer, you may want to do
the graphical printing during the off-peak hours. Use print preview to check you have the correct settings.

13.3 Previewing the current page
It is usually a good idea to preview the page before printing it, in order to check that the format of the print out
is what you require.
Retain always prints the currently active notebook page. If the page you want to preview is not currently
displayed, select it from the page drop-down list to make it the active page.
To preview the current page:
1. Set sort, selection and other display options as required.
2. Refresh the view if needed.
3. Select 'File-> Print preview' from the menu.
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Shortcuts: The 'Print preview'

button or press CTRL+V.

A 'Print Preview' dialog will be appear, showing how the page will look like when it is printed:

4. Set the configuration options. See the Print configuration overview section for more information.
The following options are available in the 'Print Preview' window:
Display the previous print page (if there is more than one page).
Display the next print page (if there is more than one page).
Display one page.
Display two pages side by side.
Magnify the view (zoom in to display half of the page). Shortcut: Click on the previewed page.
Reduce magnification (zoom out to display the full page). Shortcut: Click on the previewed page.
Print the page(s) being previewed.
Print the current page.
Edit the print header.
Edit the print footer.
Specify the type of page numbering (only for reports).
Insert page breaks (only for reports).
Close the preview window.
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13.4 Printing the current page
Retain always prints the currently active notebook page. If the page you want to print out is not currently
displayed, select it from the page drop-down list to make it the active page.
To print out the current page:
1. Set sort, selection and other display options, as required.
2. Recalculate/refresh the view, if necessary.
3. Select 'File-> Print...' from the menu.
Shortcuts: The 'Print'

button or press CTRL+P.

4. In the 'Print' dialog set the configuration options as necessary. To print out the current page only, select
pages from 1 to 1 in the 'Print range' section.
5. Click on the 'OK' button to start printing.
Note that clicking on the 'Page Setup' button will open up the 'Page Setup' dialog, allowing you to customise
the header and footer settings.

13.5 Printing Wallcharts
When printing Wallcharts, the date range is significant. The date range specifies the span of the print. The
number of pages affects how much time is printed on each page. In the screen shot above, three months will
be on one page.
Note that all resources/jobs (not just the ones visible on the screen) will be printed.
In the 'Print Preview' dialog, right-click anywhere within the main window and select 'Dates...' from the menu:
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Using the 'Dates' dialog, specify the date range and number of pages to be printed.

13.6 Print configuration options
Print configuration overview
In the 'Print' dialog, clicking on the 'Page Setup' button will open up the 'Page Setup' dialog allowing you can
define the following page settings:
· Header - edit the page header details.
· Footer - edit the page footer details.
· Page numbering - set horizontal or vertical page numbering when dealing with adjacent pages in reports.
· Page breaks - insert page breaks between the sections of a report.
Related Topics:
General Printing settings
Page setup
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Print headers
The 'Header' tab in the 'Page Setup' dialog allows you to define various header settings when printing
Wallchart and Calendar pages.
Shortcut: The 'Edit Header'

button in the 'Print Preview' window:

· Show header - show or hide the whole header.
· Title - show or hide the print title and type a title for the printout.
· Sub-title - show or hide the sub-title and type a sub-title for the printout.
· Date - show or hide the date of printing.
· Time - show or hide the time of printing.
· Page number - show or hide the print page number.
· Show date range - show or hide the date range covered by the printout.
· Surrounding frame - show or hide the frame surrounding the print header.
· Column titles - show or hide the column titles (reports only).
· Font... - set the fonts for the various header elements by clicking on the 'Font...' button. See the Editing
fonts section for more information.
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Print footers
The 'Footer' tab in the 'Page Setup' dialog allows you to define various footer settings when printing Wallchart
and Calendar pages.
Shortcut: The 'Edit footer'

button in the 'Print Preview' window:

· Show footer - show or hide the whole footer.
· Footnote - show or hide the report footnote and type a footnote for the printout.
· Date - show or hide the date of printing.
· Time - show or hide the time of printing.
· Page number - show or hide the print page number.
· Surrounding frame - show or hide the frame surrounding the print footer.
· Font... - set the fonts for the various footer elements by clicking on the 'Font...' button. See the Editing fonts
section for more information.
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Print page numbering
When the contents of Report page exceed the width of a standard page, you can use the 'Numbering' tab in
the 'Page Setup' dialog to define the sequence of page numbering.
Shortcut: The 'Page numbering'

button in the 'Print Preview' window:

· horizontal - pages are numbered across each adjacent page before moving to the next vertical page.
· vertical - pages are numbered vertically before moving to the next adjacent page.

Print page breaks
The 'Breaks' tab in the 'Page Setup' dialog allows you to insert page breaks between the sections of a report.
Shortcut: The 'Page breaks'

button in the 'Print Preview' window:

· Use page breaks - tick this checkbox to force page breaks between the sections of the report or clear the
checkbox to remove page breaks.
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· Page break level - specify the level at which page breaks will be made. Up to 4 page break levels are
available, based on the sort titles defined for the report.
Page breaks will only be applied if you have expanded the corresponding view in the report. See the
Expanding and collapsing report sections section for more information.

General printing settings
To set general printing preferences:
1. Select 'File-> Preferences...', 'Printing' tab:

2. Tick the appropriate check box for the settings you require:
· To use colours when printing
· To print all calendars in one session
· To use an alternative printing mode
3. Click on the 'OK' button to confirm your changes.
Notes:
· Use colours only if printing with a colour printer. The colours of booking bars in Wallchart or Calendar view
may will depend on the resolution of your printer.
· You may find that with certain printers the use of the alternative printing mode is necessary to achieve the
required results.
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Page setup
Retain prints using your default printer. You may need to amend settings in the 'Page Setup' dialog to obtain
the required results in your printing.
For example, you can adjust the margins and select the orientation of the printout (portrait or landscape)
using this dialog.
To amend the page setup:
1. Select 'File-> Print setup...' from the menu.
2. In the 'Page Setup' dialog, amend the printing settings as required:

3. Click on the 'OK' button to confirm your changes.
Note: Click on the 'Printer...' button to select the printer you wish to use.
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14 Customising Wallchart
14.1 Retain preferences
Retain preferences overview
Retain preferences are the default settings which will be applied in various areas of the software. You can set
preferences for your use of Retain in several areas as follows:
· General - Set whether booking bar tips are displayed, what happens when you drag bookings in Project
view and whether you can make block bookings.
· Bookings - Set where bookings will 'snap to' when moved graphically and whether to display fields names
on booking bars and booking tips.
· Availability - Set the default percentage to apply when performing a special selection and whether to
display the special selection dialog when adding special selections.
· Printing - Set the general printing options.
Note: These settings are personal to each retain user and are stored in each user's local Windows directory
as 'retain.cfg'.
To set Retain preferences:
1. Select 'File-> Preferences' from the menu.
2. In the 'Preferences' dialog amend the default settings as required.
3. Click on the 'OK' button to confirm your changes.

General preferences
The 'General' tab of the 'Preferences' dialog allows you to define various settings which will apply to all your
Retain notebooks:
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· Booking bar tips - Tick this checkbox if you want booking bar tips to be displayed when you move the
mouse pointer over booking bars in Wallchart or Calendar views. Untick the checkbox if you do not want
booking tips displayed.
Shortcut: Right-click over a booking area (but not a booking) within Wallchart and select 'Booking tips' from
the menu.
· Dragging Booking Bars in Wallchart - This option defines what happens when you drag bookings to a
different sub-booking line when in Project view. If you tick these checkboxes:
- Job Project view: when dragging a booking from one job to another, if you move the booking onto a
different resource sub-line at the new job then the booking will also be moved to that new
resource.
- Resource Project view: when dragging a booking from one resource to another, if you move the
booking onto a different job sub-line at the new resource then the booking will also be moved to
that new job.
· Enable auto-scrolling - Tick this checkbox to enable auto-scrolling while moving bookings within the
Wallchart.
· Block Bookings - Tick this checkbox if you want to be able to make block bookings (by drawing a
rectangular block vertically across adjacent resources). The block bookings facility only applies to the
Resource view on Wallchart pages. If you remove the tick, you will only be able to mark an area
horizontally across one resource.
· Date range popup - When you mark an area within Wallchart, a window showing the selected date range
will appear. If you do not tick this checkbox, the date range window will not appear.
· Dialog visibility - Ticking the 'Always show password dialog for authentication' checkbox will enable a
prompt window every time you want to switch to Edit mode.
· The second checkbox should be ticked if you wish a pop-up window to appear when you reject a booking
request. This allows you to provide reasons for the rejection. Deselect the checkbox to disable this pop-up.
· Close booking dialog on save - Tick this checkbox if you want the 'Booking' dialog to close immediately
after clicking on the 'Save' button. It is ticked by default.
· Use filtering in Select Dialog - If you have a large number of resources/jobs, tick this checkbox to optimise
the work of the 'Select Record' dialog. Also, if this checkbox is ticked, only the matching records will be
displayed as you type in the necessary name.
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Booking preferences
The 'Bookings' tab of the 'Preferences' dialog allows you to define settings relating to bookings:

· Snap to - Set this option to determine where bookings will 'snap to' when moved graphically within the
Wallchart. For example, if you set the 'snap to' option to 'Left', when you move a booking on the Wallchart
it will be positioned to the cell which contains the left edge of the booking when you release the mouse
button.
· Field names - Tick the 'Show booking bar field names' checkbox if you want to display the field names on
booking bars and tick the 'Show booking tip field names' checkbox if you want to display the field names
on booking bar tips.
· Visual - Tick the 'Visually indicate which bookings I can edit' checkbox if you want to have a visual
indication (a small black square at the bottom right corner of a booking) of bookings that you have the
authority to edit while 'edit mode' is turned on.
· Confirmations - Tick the 'Confirm dragged bookings' checkbox if you want a notification dialog to appear
when you try to move a booking by dragging it within the Wallchart. Enabling this option ensures that you
do not move bookings accidentally. You can also tick the 'Indicate successful creation of bookings'
checkbox to be notified every time a booking is created.
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Availability preferences
The 'Availability' tab of the 'Preferences' dialog allows you to define settings relating to special selections:

· Availability limit - This is the default percentage criteria to apply to the availability searches. For example, if
the availability percentage is 80% then records will be displayed if they are at least 80% available during
the selected period.
· Hide availability dialog - Tick this checkbox if you want to hide the availability dialog when making
availability selections.
Note: Unless you frequently perform searches based on different availability percentages you will probably
want to hide the availability dialog.

14.2 Customising the toolbar
Toolbar customising overview
Like most Windows applications, Retain provides a 'toolbar' - a list of buttons - located at the top of the
screen. These buttons provide quick access to most of the commonly used features in Retain. See the Button
reference section for a complete list of the Retain buttons.
Related Topics:
Toolbar types
Adding and removing toolbar buttons
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Toolbar types
There are four separate toolbars in Retain:
· No Windows - The toolbar that is displayed when you do not have any open notebooks.
· Wallchart - The toolbar that is displayed when the currently active notebook page is a Wallchart view.
· Calendar - The toolbar that is displayed when the currently active notebook page is a Calendar view.
· Reports - The toolbar that is displayed when the currently active notebook page is a Report page.
Each toolbar should contain only the buttons relevant to the current context. For example, the 'No Windows'
toolbar contains only the buttons to create or open a notebook; the 'Reports' toolbar contains buttons that are
specific to the preparation of reports and so on.

Adding and removing toolbar buttons
The software is supplied with a default set of buttons in each toolbar. You may wish to customise the toolbar
to include the options you use most frequently.
To customise the toolbar:
1. Select 'View-> Toolbar Options...' from the menu.
Shortcut: Right-click over the toolbar area and choose 'Toolbar Options...' from the menu.
2. In the 'Customise Toolbar' dialog, add and remove toolbar buttons as required:

3. Click on the 'OK' button to confirm your changes.
The 'Customise Toolbar' dialog allows you to add and remove buttons for each of the toolbars, set the location
of the toolbar and show or hide the tool tips.
The full list of available buttons is displayed on the left-hand side of the screen and the buttons currently
defined for the selected toolbar are displayed on the right-hand side of the screen.
You can also have different toolbars for Report and Calendar views, for example. To create a different
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toolbar for another view, choose the view from the drop-down list under the 'Selected Toolbar' section
header and customise the toolbar as necessary.
To add a button to the selected toolbar:
1. Click on the position in the current toolbar above which you wish to add the button.
2. Select the new button in the 'Available Buttons' list.
3. Click on the '->' button to add the item to the end of the current toolbar.
Shortcuts: Double-click on the selected item or 'drag and drop' the item to the required location on the
current toolbar.
Repeat the steps above to add more buttons to the toolbar, as necessary.
To remove a button from the selected toolbar:
1. Select the button in the current toolbar.
2. Click on the '<-' button to remove the button from the toolbar.
Shortcuts: Double-click on the selected item or 'drag and drop' the item back to the 'Available Buttons' list.
Repeat the steps above to remove more buttons, as necessary.
To add a separator (space) to the selected toolbar:
1. Click on the position in the current toolbar above which you wish to add the separator.
2. Click on the 'Separator' button to add the separator to the current toolbar.
Repeat the steps above to add more spaces in the toolbar, as necessary.
Tip: Use the gaps in the toolbar to group buttons by type and to distinguish between different types of
function.

To remove a separator (space) from the selected toolbar:
1. Select the separator in the current toolbar.
2. Click on the '<-' button to remove the separator from the toolbar.
Shortcuts: Double-click on the selected item or 'drag and drop' the item back to the 'Available Buttons' list.
Repeat the steps above to remove more spaces, as required.
To move items within the selected toolbar:
1. Select the item in the current toolbar.
2. Click on the 'Up' button to promote the item in the toolbar or 'Down' to demote the item.
Shortcut: 'Drag and drop' the selected item to a new position in the toolbar.
Repeat the steps above to move further items within the selected toolbar, as required.
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To restore the default toolbar buttons, click on the 'Reset' button.
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15 Reference
15.1 Glossary
Booking
An allocation of an individual resource (or several resources) to a job for a specific job which covers a
defined date range and a measurable number of hours.
Calendar View
Shows bookings for one individual resource or job. Time is represented in a calendar style grid and
special navigation features allow you to move between resources or jobs.
Component
A sub-job that provides information regarding the nature of each booking made against a job.
Components supply an element of project planning within Retain, since you can assign a component for
each booking and analyse the job into its component parts for reporting purposes.
Job
Retain uses the term 'jobs' as a general description of any project, product or assignment that is being
planned.
Notebook
Contains one or more notebook pages, allowing you to display and edit your data in various ways as
well as create reports using Retain Report Writer.
Notebook Page
Represents a view of your data. The characteristics of each notebook page can be defined and
maintained independently, using the various sort, selection and other display features.
Project View
Separates bookings into sub-fields, providing a better view of bookings belonging to each resource/job.
It is often used to display bookings against a resource on a separate row for each job.
Reports Page
Allows you to create customised job and resource based reports. You can format, sort, select and
aggregate your reports in a number of ways.
Resource
Retain uses the term 'resources' as a general description of people or entities that can be applied to the
process of completing a job.
Selecting
Refers to filtering resources, jobs and bookings based on certain criteria. Selections are used for
viewing or collective manipulation.
Toolbar
A panel of buttons located at the top of the screen.
Wallchart
Wallchart is a flexible planning tool for viewing and managing staff and job allocations through a user
friendly graphical interface.
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15.2 Button reference
Button Menu

Description

Hot-key

File | New

Creates a new notebook

Ctrl + N

File | Open...

Opens an existing notebook

Ctrl + O

File | Save

Save this document

Ctrl + S

File | Print preview...

Print preview

Ctrl + V

File | Print...

Print this document

Ctrl + P

Edit | Edit mode...

Toggle edit mode

Ctrl + E

Edit | Undo

Undo the last booking change

Ctrl + Z

View | Wallchart

Wallchart view

View | Calendar

Calendar view

View | 3D Wallchart

3-D Wallchart view

View | Project view

Project view

Ctrl + J

View | Rotate view

Toggle Resource and Job view

Ctrl + R

View | Display settings

Change the default date scale settings

View | Fonts...

Edit the format of the report

View | Zoom... | Year

Set the scale to years

Ctrl + Y

View | Zoom... | Month

Set the scale to months

Ctrl + M

View | Zoom... | Week

Set the scale to weeks

Ctrl + W

View | Zoom... | Day

Set the scale to days

Ctrl + D

View | Zoom... | Hour

Set the scale to hours

Ctrl + H

View | Grid

Toggles the grid lines

Ctrl + G

Notebook | Add page...

Add a new page to the notebook

Notebook | Insert page...

Insert a new page into the notebook

Notebook | Delete page...

Delete the active page

Notebook | Rename page... Rename the active page
Notebook | Copy page...

Copy the active page

Actions | Make booking...

Make new booking(s)

Ctrl + K (while in edit mode)

Make a booking request
Actions | Edit booking...

Edit currently selected booking(s)

Actions | Delete booking... Delete the selected booking(s)
Actions | Booking info...

View current booking

Actions | Job info...

View job info for current booking

Actions | Resource info...

View resource info for current booking

Actions | Duplicate
bookings...

Duplicate the currently selected booking

Actions | Modify Record |
Resource...

Modify resources

Delete
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Actions | Modify Record |
Job...

Modify jobs

Actions | Modify Record |
Component...

Modify components

Actions | Modify Record |
Type...

Modify booking types
Actions | Roll forward...

Copy bookings forward

Actions | Refresh

Reload data and recalculate

Data | Fields...

Specify the resource and job fields

Data | Sort...

Specify the sort order

Data | Selection...

Specify the selection criteria

Data | Booking Visibility |
Show Normal Bookings

Show/hide normal bookings

Data | Booking Visibility |
Show Ghost Bookings

Show/hide ghost bookings

Data | Booking Visibility |
Show Booking Requests

Show/hide booking requests

Data | Booking Visibility |
Show Scenario Bookings

Show/hide scenario bookings

F5

Data | Special selections |
Add...

Add a special selection for the displayed date range
Data | Clear entire

selection

Reset the selection to show all records
Stack bookings above each other
Set booking depth proportional
Use large bookings bars
Use medium-sized booking bars
Use small booking bars
Match booking bar depth
Move to the next record

Ctrl + Shift + N

Move to the previous record

Ctrl + Shift + P

Copy the booking to the clipboard
Select a new record from the list
Select the marked records
Data | Clear selection

Remove the marked record selection

Help | Help Topics

Help table of contents

Report View:
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View | Header

Edit the header format (Edit the print header in print preview)

View | Footer

Edit the footer format (Edit the print footer in print preview)

Actions | Open all details

Open all nodes to show maximum detail

Actions | Close all details

Close all nodes to show minimum detail

178

Reference

Actions | Show more
detail

Increase the level of detail shown
Actions | Show less

detail

Decrease the level of detail shown
Toggle the report header
Toggle the report footer

Print Preview buttons:
Previous page
Next page
One page
Two pages
Zoom-in
Zoom-out
Print the previewed page(s)
Print the current page
Date range (in Wallchart print preview)
Page numbering (in Reports print preview)
Page breaks (in Reports print preview)
Close print preview

Note: If you hover over the button with your mouse, a tip will appear indicating the function of that button.

15.3 Report examples
· 'Planned Revenue' report:

· 'Resource Schedule' report:
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· 'Booking Conflict' report:

· 'Utilisation by Grade' report:
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16 Support
16.1 Issue reporting tool
In the unlikely event of Retain crashing, the Retain Error Submitter is automatically run:

This application allows you to provide a brief description of the actions you have taken before the crash
occurred by typing in the text box.
Clicking on the 'Email Error Report' button will open your default E-mail client, automatically attach the error
log, set the recipient and copy the description you have provided to the message's body.
Alternatively, the Retain Error Submitter allows you to copy the contents of the error log to the Windows
clipboard.

16.2 Troubleshooting
General issues

· Can not change the colour/shape of a booking using the Colour/Shape Legend
- Check that the booking you wish to edit is not a booking request for deletion or a lived/archived scenario
booking.
- Check in Retain Security Manager that the colour/shape scheme you wish to use is based on the BKG table.
If, for example, the scheme is based on JOB_CRD_ID (JOB table), you will not be able to change the colour/
shape of a booking. This prevents you from accidentally changing the values of internal Retain fields such as
job (if the colour scheme is based on the JOB table field) by editing a booking.
· Get 'table is not valid' error when setting up colour/shape scheme
For both colour and shape schemes you should only use tables that are directly linked to bookings, i.e. the
Booking (BKG) table: RES (Resources), JOB, JAS (Assignment), BTY (Booking Type) and CMP
(Component).
· Utilisation is appearing as 100% in reports even though the resource is booked for less
This issue can occur after adding a new resource with a new diary. Check the 'Diary Time' value: if it is zero,
run the overnight script to update the DGD_SUM table.
· Can not see the changes made to data after updating the existing/switching to a new database
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Ensure that you clear the cache before using the new/updated database: For Retain Web, clear the contents
in the 'rwpcache' folder; for Retain Wallchart and Security Manager clear the 'cache' folder.

Retain Wallchart specific
· The fields in 'Booking' dialog are not displayed properly
Right-click within the dialog and select 'Reset dimensions'.
· Can not make/edit bookings
Ensure that you are in 'Edit Mode'. In the main menu within Wallchart go to 'Edit-> Edit mode...'.
If you still can not make/edit bookings, it is possible that you do not have the appropriate access rights.
· Can not create a report
You probably do not have the appropriate access rights.
· Some of the data is suddenly missing/has changed
- It is most likely that there is a selection applied to the view you are in. Clear the selection by going to Data->
Clear Selections. Note that only unlocked selection will be cleared.
- Check that you are looking at the correct date range, i.e. the date bar at the bottom of the screen is showing
the date range you expect.
- It is also possible that another user has deleted/amended the data.
· 'Limit results by the locked criteria' checkbox is not working
Ensure that you understand the behaviour of this functionality. If you lock a selection criterion and tick the
'Limit results by the locked criteria' checkbox, the results of the unlocked criteria will be limited to the locked
selection. See Retain Wallchart User guide for more information.
· Increasing the decimal places through 'Numeric Data Formatting' dialog does not work
The number of decimal places is specified in Retain Security Manager. If you wish to override it with a value
entered through the 'Numeric Data Formatting' dialog within Retain Wallchart, enter '-2' as the decimal places
value for that field.
· I want the decimal places defined in 'Numeric Data Formatting' dialog to depend on the regional
settings
In Retain Security Manager, Tables section select the required field and enter '-1' as the decimal places value.
· Get ‘Failed to obtain exclusive licence lock’ error
Confirm that Retain Server is not already running. If the server is on your machine, check the Task Manager
or use a different port.
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Retain Security Manager specific
· The changes made using Security Manager are not applied in Retain Wallchart/Retain Web
Make sure you have saved your changes in Security Manager by clicking on the 'Save Changes' button and
selected 'Structure-> Effect changes' from the menu. If that does not work, try restarting Retain Server (after
saving your changes) as well as Retain Wallchart/Retain Web.

16.3 Support Services
Support for Retain is available worldwide. This topic is linked to your support provider's information: Support
Service Provider.

retaininternational
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USA phone:
UK phone:
World phone:

1 646 688 4496
0845 458 8660
+44 20 7538 4774

USA fax:
World fax:

1 646 478 9475
+44 845 458 8661

General E-mail:
Support E-mail:

info@retaininternational.com
support@retaininternational.com

Postal Address:

Retain International Ltd
33 Beaufort Court
Admirals Way
London, E14 9XL
United Kingdom
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